]> git.pld-linux.org Git - packages/btparser.git/blame - btparser.spec
- rebuild with binutils 2.29
[packages/btparser.git] / btparser.spec
CommitLineData
7dc4c325 1Summary: Parser and analyzer for backtraces produced by GDB
6d92037a 2Summary(pl.UTF-8): Analizator śladów wywołań tworzonych przez GDB
7dc4c325 3Name: btparser
f292a788 4Version: 0.26
ac3443ad 5Release: 5
6d9927ba 6License: GPL v2+
6d92037a 7Group: Development/Tools
f292a788
ER
8Source0: https://github.com/abrt/btparser/archive/%{version}/%{name}-%{version}.tar.gz
9# Source0-md5: 22cb4fe5593344f0acac8936494141f6
10URL: https://github.com/abrt/btparser
7dc4c325
JR
11%ifarch %{x8664}
12BuildRequires: binutils-static
13%endif
6d9927ba
JB
14BuildRequires: glib2-devel >= 1:2.21
15BuildRequires: pkgconfig
7dc4c325
JR
16BuildRequires: python-devel
17BuildRequires: python-distribute
18BuildRequires: rpm-pythonprov
6d9927ba 19BuildRequires: rpmbuild(macros) >= 1.219
53b58081 20BuildRequires: tar >= 1:1.22
6d9927ba 21BuildRequires: xmlto
7dc4c325
JR
22Requires: %{name}-libs = %{version}-%{release}
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26Btparser is a backtrace parser and analyzer, which works with
27backtraces produced by the GNU Project Debugger. It can parse a text
28file with a backtrace to a tree of C structures, allowing to analyze
29the threads and frames of the backtrace and work with them.
30
31Btparser also contains some backtrace manipulation and extraction
32routines:
33- it can find a frame in the crash-time backtrace where the program
34 most likely crashed (a chance is that the function described in that
35 frame is buggy)
36- it can produce a duplication hash of the backtrace, which helps to
37 discover that two crash-time backtraces are duplicates, triggered by
38 the same flaw of the code
39- it can "rate" the backtrace quality, which depends on the number of
f292a788
ER
40 frames with and without the function name known (missing function name
41 is caused by missing debugging symbols)
7dc4c325 42
6d92037a
JB
43%description -l pl.UTF-8
44Btparser to analizator śladów wywołań (backtrace'ów), działający ze
45śladami tworzonymi przez debugger GDB z projektu GNU. Potrafi
46przetworzyć plik tekstowy ze śladem na drzewo struktur C, co pozwala
47na analizę wątków oraz ramek śladu wywołań i dalszą pracę z nimi.
48
49Btparser zawiera także trochę procedur do obróbki i wydobywania śladów
50wywołań:
51- potrafi znaleźć ramkę w pośmiertnym śladzie wywołań, w której
f292a788
ER
52 najprawdopodobniej nastąpiła wywrotka programu (możliwe, że to funkcja
53 w tej ramce zawiera błąd)
6d92037a 54- potrafi utworzyć skrót (hasz) śladu, pozwalający wykryć, czy dwa
f292a788
ER
55 zadane ślady pośmiertne są duplikatami spowodowanymi tym samym błędem
56 w kodzie
6d92037a
JB
57- potrafi "ocenić jakość" śladów, zależną od liczby ramek ze znaną i
58 bez znanej nazwy funkcji (brak nazwy funkcji wynika z braku symboli
59 diagnostycznych)
60
7dc4c325
JR
61%package libs
62Summary: Btparser library
63Summary(pl.UTF-8): Biblioteka btparser
64Group: Libraries
6d9927ba 65Requires: glib2 >= 1:2.21
7dc4c325
JR
66
67%description libs
6d92037a 68Btparser library.
7dc4c325
JR
69
70%description libs -l pl.UTF-8
71Biblioteka btparser.
72
73%package devel
74Summary: Header files for %{name} library
75Summary(pl.UTF-8): Pliki nagłówkowe biblioteki %{name}
76Group: Development/Libraries
77Requires: %{name}-libs = %{version}-%{release}
6d9927ba 78Requires: glib2-devel >= 1:2.21
7dc4c325
JR
79
80%description devel
81Header files for %{name} library.
82
83%description devel -l pl.UTF-8
84Pliki nagłówkowe biblioteki %{name}.
85
86%package -n python-btparser
87Summary: Python bindings for %{name}
6d92037a
JB
88Summary(pl.UTF-8): Wiązania Pythona do biblioteki btparser
89Group: Libraries/Python
7dc4c325 90Requires: %{name}-libs = %{version}-%{release}
6d9927ba 91Requires: python-modules
7dc4c325
JR
92
93%description -n python-btparser
94Python bindings for %{name}.
95
6d92037a
JB
96%description -n python-btparser -l pl.UTF-8
97Wiązania Pythona do biblioteki btparser.
98
7dc4c325
JR
99%prep
100%setup -q
101
102%build
7dc4c325 103%configure \
6d92037a 104%ifarch %{x8664}
7dc4c325 105 --enable-fingerprints
7dc4c325 106%endif
6d92037a 107
7dc4c325
JR
108%{__make}
109
110%install
111rm -rf $RPM_BUILD_ROOT
112
113%{__make} install \
114 DESTDIR=$RPM_BUILD_ROOT
115
116%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la $RPM_BUILD_ROOT%{py_sitedir}/btparser/*.la
117
6d9927ba
JB
118%py_postclean
119
7dc4c325
JR
120%clean
121rm -rf $RPM_BUILD_ROOT
122
123%post libs -p /sbin/ldconfig
124%postun libs -p /sbin/ldconfig
125
126%files
127%defattr(644,root,root,755)
128%doc ChangeLog NEWS README RELEASE TODO
129%attr(755,root,root) %{_bindir}/btparser
130%{_mandir}/man1/btparser.1*
131
132%files libs
133%defattr(644,root,root,755)
134%attr(755,root,root) %{_libdir}/libbtparser.so.*.*
135%attr(755,root,root) %ghost %{_libdir}/libbtparser.so.2
136
137%files devel
138%defattr(644,root,root,755)
6d92037a 139%attr(755,root,root) %{_libdir}/libbtparser.so
7dc4c325 140%{_includedir}/btparser
6d92037a 141%{_pkgconfigdir}/btparser.pc
7dc4c325
JR
142
143%files -n python-btparser
6d92037a 144%defattr(644,root,root,755)
f277cb5b 145%dir %{py_sitedir}/btparser
6d9927ba
JB
146%{py_sitedir}/btparser/__init__.py[co]
147%attr(755,root,root) %{py_sitedir}/btparser/_btparser.so
This page took 0.065665 seconds and 4 git commands to generate.