]> git.pld-linux.org Git - packages/brscan.git/commitdiff
- added
authoraredridel <aredridel@pld-linux.org>
Fri, 8 Jun 2007 23:07:15 +0000 (23:07 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    brscan-fixes.patch -> 1.1
    brscan.spec -> 1.1

brscan-fixes.patch [new file with mode: 0644]
brscan.spec [new file with mode: 0644]

diff --git a/brscan-fixes.patch b/brscan-fixes.patch
new file mode 100644 (file)
index 0000000..226da11
--- /dev/null
@@ -0,0 +1,114 @@
+diff -ur brscan-src-0.2.3-o/brscan/backend_src/brother_advini.c brscan-src-0.2.3/brscan/backend_src/brother_advini.c
+--- brscan-src-0.2.3-o/brscan/backend_src/brother_advini.c     2006-03-03 01:51:55.000000000 -0700
++++ brscan-src-0.2.3/brscan/backend_src/brother_advini.c       2007-06-08 15:10:32.000000000 -0600
+@@ -24,7 +24,7 @@
+ #include <stdlib.h>
+ #include <sys/types.h>
+ #include <dirent.h>
+-#include <curses.h>
++#include <ncurses/curses.h>
+ #include <unistd.h>
+ #include "brother_advini.h"
+diff -ur brscan-src-0.2.3-o/brscan/configure.in brscan-src-0.2.3/brscan/configure.in
+--- brscan-src-0.2.3-o/brscan/configure.in     2006-06-30 00:30:24.000000000 -0600
++++ brscan-src-0.2.3/brscan/configure.in       2007-06-08 15:10:32.000000000 -0600
+@@ -40,64 +40,6 @@
+ AC_ISC_POSIX
+ AM_PROG_CC_STDC
+-INCLUDES="${INCLUDES} -I/usr/local/include"
+-CPPFLAGS="${CPPFLAGS} -D_GNU_SOURCE"
+-
+-if test "${ac_cv_prog_gcc}" = "yes"; then
+-  NORMAL_CFLAGS="\
+-      -W \
+-      -Wall"
+-  WARN_CFLAGS="\
+-      -W \
+-      -Wall \
+-      -Wcast-align \
+-      -Wcast-qual \
+-      -Wmissing-declarations \
+-      -Wmissing-prototypes \
+-      -Wpointer-arith \
+-      -Wreturn-type \
+-      -Wstrict-prototypes \
+-      -pedantic"
+-
+-  dnl OS/2 and others don't include some headers with -ansi enabled
+-  ANSI_FLAG=-ansi
+-  AC_CHECK_HEADER(os2.h,[ANSI_FLAG=],)
+-  case "${host_os}" in  
+-    solaris*)
+-      ANSI_FLAG=
+-      ;;
+-  esac
+-  WARN_CFLAGS="${WARN_CFLAGS} ${ANSI_FLAG}"
+-
+-  # Warnings enabled by default (development)
+-  AC_ARG_ENABLE(warnings,
+-    [  --enable-warnings       turn on tons of compiler warnings (GCC only) 
+-                          [default=yes]],
+-    [
+-      if eval "test x$enable_warnings = xyes"; then 
+-        for flag in $WARN_CFLAGS; do
+-          JAPHAR_GREP_CFLAGS($flag, [ CFLAGS="$CFLAGS $flag" ])
+-        done
+-      else
+-        for flag in $NORMAL_CFLAGS; do
+-          JAPHAR_GREP_CFLAGS($flag, [ CFLAGS="$CFLAGS $flag" ])
+-        done
+-      fi
+-    ],
+-    [if false; then # release (false) or development (true)
+-       # Warnings enabled by default (development)
+-       for flag in $WARN_CFLAGS; do
+-         JAPHAR_GREP_CFLAGS($flag, [ CFLAGS="$CFLAGS $flag" ])
+-       done
+-    else
+-       # Warnings disabled by default (release)
+-       for flag in $NORMAL_CFLAGS; do
+-         JAPHAR_GREP_CFLAGS($flag, [ CFLAGS="$CFLAGS $flag" ])
+-       done
+-    fi])
+-fi # ac_cv_prog_gcc
+-echo using CFLAGS=${CFLAGS}
+-
+ dnl Checks for header files.
+ AC_HEADER_STDC
+ AC_CHECK_HEADERS(fcntl.h unistd.h libc.h sys/dsreq.h sys/select.h \
+diff -ur brscan-src-0.2.3-o/brscan/netconfig/brsaneconfig.c brscan-src-0.2.3/brscan/netconfig/brsaneconfig.c
+--- brscan-src-0.2.3-o/brscan/netconfig/brsaneconfig.c 2007-01-25 00:20:06.000000000 -0700
++++ brscan-src-0.2.3/brscan/netconfig/brsaneconfig.c   2007-06-08 15:10:32.000000000 -0600
+@@ -22,7 +22,7 @@
+ #include <stdlib.h>
+ #include <sys/types.h>
+ #include <dirent.h>
+-#include <curses.h>
++#include <ncurses/curses.h>
+ #include <unistd.h>
+ #include "brother_advini.h"
+diff -ur brscan-src-0.2.3-o/brscan/sanei/sanei_scsi.c brscan-src-0.2.3/brscan/sanei/sanei_scsi.c
+--- brscan-src-0.2.3-o/brscan/sanei/sanei_scsi.c       2006-06-30 00:30:24.000000000 -0600
++++ brscan-src-0.2.3/brscan/sanei/sanei_scsi.c 2007-06-08 15:10:56.000000000 -0600
+@@ -1916,7 +1916,7 @@
+             }
+           req->sgdata.sg3.hdr.dxfer_len = src_size;
+           memcpy(&req->sgdata.sg3.data[MAX_CDB], src, src_size);
+-          (const void*) req->sgdata.sg3.hdr.dxferp = &req->sgdata.sg3.data[MAX_CDB];
++          req->sgdata.sg3.hdr.dxferp = &req->sgdata.sg3.data[MAX_CDB];
+         }
+       else
+         {
+@@ -1930,7 +1930,7 @@
+           cmd_size = MAX_CDB;
+         }
+       memcpy(req->sgdata.sg3.data, cmd, cmd_size);
+-      (const void*) req->sgdata.sg3.hdr.cmdp = req->sgdata.sg3.data;
++      req->sgdata.sg3.hdr.cmdp = req->sgdata.sg3.data;
+       req->sgdata.sg3.hdr.sbp = &(req->sgdata.sg3.sense_buffer[0]);
+       /* 1 minute should be ok even for slow scanners */
+       req->sgdata.sg3.hdr.timeout = 1000 * SANE_SCSICMD_TIMEOUT;
+Only in brscan-src-0.2.3/brscan/sanei: sanei_scsi.c~
diff --git a/brscan.spec b/brscan.spec
new file mode 100644 (file)
index 0000000..811a8e0
--- /dev/null
@@ -0,0 +1,85 @@
+#
+Summary:       Brother scanner driver
+Name:          brscan
+Version:       0.2.3
+Release:       1
+License:       GPL v2
+Group:         Applications
+Source0:       http://solutions.brother.com/Library/sol/printer/linux/rpmfiles/sane_source/%{name}-src-%{version}.tar.gz
+# Source0-md5: 99a7f21fc15661690b296023253bcca6
+URL:           http://solutions.brother.com/linux/sol/printer/linux/sane_drivers.html
+Patch0:                %{name}-fixes.patch
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: libtool
+Requires:      sane-backends
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Scanner driver for Brother MFC printers, both USB and network.
+
+%prep
+%setup -q -n %{name}-src-%{version}
+%patch0 -p1
+
+%build
+cd brscan
+rm configure acinclude.m4
+%{__libtoolize}
+%{__aclocal}
+%{__autoconf}
+#%%{__autoheader}
+#%%{__automake}
+%configure
+cd lib
+%{__make}
+cd ..
+cd netconfig
+%{__make}
+cd ..
+cd sanei
+%{__make}
+cd ..
+cd backend_brscan
+%{__make}
+cd ..
+cd backend_brscan2
+%{__make}
+cd ..
+
+#%{__make} \
+#      CFLAGS="%{rpmcflags}" \
+#      LDFLAGS="%{rpmldflags}"
+
+%install
+rm -rf $RPM_BUILD_ROOT
+# create directories if necessary
+install -d $RPM_BUILD_ROOT{%{_sbindir},%{_libdir}/sane}
+#install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+
+cd brscan
+cd backend_brscan
+libtool --mode=install install libsane-brother.la $RPM_BUILD_ROOT%{_libdir}/sane/
+cd ..
+cd backend_brscan2
+libtool --mode=install install libsane-brother2.la $RPM_BUILD_ROOT%{_libdir}/sane/
+cd ..
+cd netconfig
+libtool --mode=install install brsaneconfig $RPM_BUILD_ROOT%{_sbindir}/
+libtool --mode=install install brsaneconfig2 $RPM_BUILD_ROOT%{_sbindir}/
+cd ..
+
+
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%{_libdir}/sane/lib*.so
+%attr(755,root,root) %{_libdir}/sane/lib*.so.*.*.*
+%attr(755,root,root) %{_sbindir}/brsaneconfig
+%attr(755,root,root) %{_sbindir}/brsaneconfig2
This page took 0.068471 seconds and 4 git commands to generate.