]> git.pld-linux.org Git - packages/browser-plugins.git/blobdiff - browser-plugins.spec
- local.* files are not handled. drop them
[packages/browser-plugins.git] / browser-plugins.spec
index 27f25036a66f923b7b68b939687f8ec0130c725b..defd891f16b4ebbf37e40396494e9348b4bf376c 100644 (file)
@@ -1,28 +1,34 @@
 # TODO
 # - convert all plugin packages to store their plugins in this base
 #   directory.
-# known NPAPI compatible browsers from PLD CVS:
-# - mozilla
-# - mozilla-firefox
-# - konqueror
-# - opera (ix86 only)
+# known NPAPI compatible browsers from PLD Linux CVS:
 # - galeon
-# - skipstone
 # - kazehakase
+# - konqueror
+# - mozilla
+# - mozilla-firefox
+# - mozilla-firefox-bin
 # - netscape (trigger on netscape-common)
+# - opera (ix86, ppc, sparc* only)
 # - seamonkey
+# - skipstone
 Summary:       Base package for web browser plugins
 Summary(pl):   Podstawowy pakiet dla wtyczek przeglĀ±darek WWW
-Name:          browser-plugins
-Version:       1.0
-Release:       5
+# TODO: to be renamed to actual package name when package is finished
+Name:          browser-plugins2
+Version:       2.0
+Release:       0.10
 License:       GPL
 Group:         Base
-Provides:      %{name}(%{_target_cpu}) = %{version}-%{release}
-Provides:      %{name}(%{_target_base_arch}) = %{version}-%{release}
-URL:           http://www.mozilla.org/projects/plugins/
+Source0:       browser-plugins.README
+Source1:       browser-plugins-update.sh
+BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _sysconfdir     /etc/browser-plugins
+# TODO: to be moved to rpm-build-macros
+%define                update_browser_plugins /usr/sbin/update-browser-plugins
+
 %description
 This package provides base directory for browser plugins complying to
 Netscape Plugin API (NPAPI).
@@ -44,14 +50,48 @@ Przegl
 - Konqueror
 
 %prep
+%setup -qcT
+cp -a %{SOURCE0} README
+cp -a %{SOURCE1} update-browser-plugins
+
+cat > blacklist <<'EOF'
+# The format is shell globs at base dir of plugindir
+EOF
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_libdir}/browser-plugins
+install -d $RPM_BUILD_ROOT{%{_sysconfdir}/{blacklist,browsers}.d,%{_sbindir}}
+install update-browser-plugins $RPM_BUILD_ROOT%{_sbindir}
+
+# TODO: to be moved to browser packages
+for browser in opera firefox mozilla mozilla-firefox mozilla-firefox-bin; do
+       for arch in i386 x86_64; do
+               cp -a blacklist $RPM_BUILD_ROOT%{_sysconfdir}/blacklist.d/$browser.$arch.blacklist
+       done
+done
+cat <<'EOF'>> $RPM_BUILD_ROOT%{_sysconfdir}/blacklist.d/opera.i386.blacklist
+# opera has no use of .xpt files.
+*.xpt
+EOF
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%if 0
+# TODO: to be enabled if tested enough
+%post
+%update_browser_plugins
+
+%preun
+if [ "$1" = 0 ]; then
+       %update_browser_plugins uninstall
+fi
+%endif
+
 %files
 %defattr(644,root,root,755)
-%{_libdir}/browser-plugins
+%dir %{_sysconfdir}
+%dir %{_sysconfdir}/browsers.d
+%dir %{_sysconfdir}/blacklist.d
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/blacklist.d/*.blacklist
+%attr(755,root,root) %{_sbindir}/update-browser-plugins
This page took 0.0740690000000001 seconds and 4 git commands to generate.