]> git.pld-linux.org Git - packages/browser-plugins.git/blob - browser-plugins.spec
- local.* files are not handled. drop them
[packages/browser-plugins.git] / browser-plugins.spec
1 # TODO
2 # - convert all plugin packages to store their plugins in this base
3 #   directory.
4 # known NPAPI compatible browsers from PLD Linux CVS:
5 # - galeon
6 # - kazehakase
7 # - konqueror
8 # - mozilla
9 # - mozilla-firefox
10 # - mozilla-firefox-bin
11 # - netscape (trigger on netscape-common)
12 # - opera (ix86, ppc, sparc* only)
13 # - seamonkey
14 # - skipstone
15 Summary:        Base package for web browser plugins
16 Summary(pl):    Podstawowy pakiet dla wtyczek przegl±darek WWW
17 # TODO: to be renamed to actual package name when package is finished
18 Name:           browser-plugins2
19 Version:        2.0
20 Release:        0.10
21 License:        GPL
22 Group:          Base
23 Source0:        browser-plugins.README
24 Source1:        browser-plugins-update.sh
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _sysconfdir     /etc/browser-plugins
29 # TODO: to be moved to rpm-build-macros
30 %define         update_browser_plugins /usr/sbin/update-browser-plugins
31
32 %description
33 This package provides base directory for browser plugins complying to
34 Netscape Plugin API (NPAPI).
35
36 Browsers known to support NPAPI:
37 - Netscape Communicator/Navigator
38 - Mozilla/Mozilla Firefox/Seamonkey
39 - Opera
40 - Konqueror
41
42 %description -l pl
43 Ten pakiet dostarcza podstawowy katalog dla wtyczek przegl±darek
44 zgodnych z Netscape Plugin API (NPAPI).
45
46 Przegl±darki obs³uguj±ce NPAPI to:
47 - Netscape Communicator/Navigator
48 - Mozilla/Mozilla Firefox/Seamonkey
49 - Opera
50 - Konqueror
51
52 %prep
53 %setup -qcT
54 cp -a %{SOURCE0} README
55 cp -a %{SOURCE1} update-browser-plugins
56
57 cat > blacklist <<'EOF'
58 # The format is shell globs at base dir of plugindir
59 EOF
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/{blacklist,browsers}.d,%{_sbindir}}
64 install update-browser-plugins $RPM_BUILD_ROOT%{_sbindir}
65
66 # TODO: to be moved to browser packages
67 for browser in opera firefox mozilla mozilla-firefox mozilla-firefox-bin; do
68         for arch in i386 x86_64; do
69                 cp -a blacklist $RPM_BUILD_ROOT%{_sysconfdir}/blacklist.d/$browser.$arch.blacklist
70         done
71 done
72 cat <<'EOF'>> $RPM_BUILD_ROOT%{_sysconfdir}/blacklist.d/opera.i386.blacklist
73 # opera has no use of .xpt files.
74 *.xpt
75 EOF
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %if 0
81 # TODO: to be enabled if tested enough
82 %post
83 %update_browser_plugins
84
85 %preun
86 if [ "$1" = 0 ]; then
87         %update_browser_plugins uninstall
88 fi
89 %endif
90
91 %files
92 %defattr(644,root,root,755)
93 %dir %{_sysconfdir}
94 %dir %{_sysconfdir}/browsers.d
95 %dir %{_sysconfdir}/blacklist.d
96 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/blacklist.d/*.blacklist
97 %attr(755,root,root) %{_sbindir}/update-browser-plugins
This page took 0.053517 seconds and 3 git commands to generate.