6ee92feb27925abd061295010824ae5e99b29fa3
[packages/browser-plugins.git] / browser-plugins.spec
1 # TODO
2 # - convert all plugin packages to store their plugins in this base
3 #   directory.
4 # - Add addons and themes support for gecko based browsers
5 # Known NPAPI compatible browsers from PLD Linux CVS:
6 # - galeon
7 # - kazehakase
8 # - konqueror
9 # - mozilla
10 # - mozilla-firefox
11 # - mozilla-firefox-bin
12 # - netscape (update script on netscape-common package)
13 # - opera (ix86, x86_64, ppc only)
14 # - seamonkey
15 # - skipstone
16 # - iceweasel
17 # - iceape
18 Summary:        Base package for web browser plugins
19 Summary(pl.UTF-8):      Podstawowy pakiet dla wtyczek przeglądarek WWW
20 Name:           browser-plugins
21 Version:        3.0
22 Release:        1
23 License:        GPL
24 Group:          Base
25 BuildRequires:  rpmbuild(macros) >= 1.356
26 Source0:        %{name}.README
27 Source1:        %{name}-update.sh
28 Requires:       filesystem >= 2.0-1.2
29 Requires:       findutils
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _sysconfdir     %{_browserpluginsconfdir}
34
35 %description
36 This package provides base directory for browser plugins complying to
37 Netscape Plugin API (NPAPI).
38
39 Browsers known to support NPAPI:
40 - Netscape Communicator/Navigator
41 - Mozilla/Mozilla Firefox/Seamonkey
42 - Opera
43 - Konqueror
44
45 %description -l pl.UTF-8
46 Ten pakiet dostarcza podstawowy katalog dla wtyczek przeglądarek
47 zgodnych z Netscape Plugin API (NPAPI).
48
49 Przeglądarki obsługujące NPAPI to:
50 - Netscape Communicator/Navigator
51 - Mozilla/Mozilla Firefox/Seamonkey
52 - Opera
53 - Konqueror
54
55 %prep
56 %setup -qcT
57 cp -a %{SOURCE0} README
58 cp -a %{SOURCE1} update-browser-plugins
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/{blacklist,browsers}.d,%{_sbindir}}
63 install update-browser-plugins $RPM_BUILD_ROOT%{_sbindir}
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %post
69 %update_browser_plugins
70
71 # we don't need postin script as all browsers depend on this package and
72 # therefore this package should be last one to go from system.
73
74 %files
75 %defattr(644,root,root,755)
76 %dir %{_sysconfdir}
77 %dir %{_sysconfdir}/browsers.d
78 %dir %{_sysconfdir}/blacklist.d
79 %attr(755,root,root) %{_sbindir}/update-browser-plugins
This page took 0.032182 seconds and 2 git commands to generate.