]> git.pld-linux.org Git - packages/browser-plugin-wacom.git/blob - browser-plugin-wacom.spec
initial
[packages/browser-plugin-wacom.git] / browser-plugin-wacom.spec
1 Summary:        An implementation of the Wacom Tablet Plugin
2 Name:           browser-plugin-wacom
3 Version:        0.3.0
4 Release:        1
5 License:        GPL v2+
6 Group:          X11/Applications/Multimedia
7 Source0:        https://github.com/ZaneA/WacomWebPlugin/archive/v%{version}.tar.gz
8 # Source0-md5:  ac25285a639280cb9d92a912e0ee6b63
9 BuildRequires:  iceweasel-devel
10 BuildRequires:  pkgconfig
11 BuildRequires:  rpmbuild(macros) >= 1.357
12 Requires:       browser-plugins >= 2.0
13 Requires:       browser-plugins(%{_target_base_arch})
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 # directory where you store the plugin
17 %define         _plugindir      %{_libdir}/browser-plugins
18
19 %description
20 An implementation of the Wacom Tablet Plugin for modern browsers on
21 Linux.
22
23 %prep
24 %setup -q -n WacomWebPlugin-%{version}
25 sed -i -e 's#/usr/include/firefox#%{_includedir}/iceweasel#g' Makefile
26 sed -i -e 's#gcc#%{__cc} %{rpmcflags} %{rpmcppflags}#g' Makefile
27
28 %build
29 %{__make}
30
31 %install
32 rm -rf $RPM_BUILD_ROOT
33
34 install -D npWacomWebPlugin.so $RPM_BUILD_ROOT%{_plugindir}/npWacomWebPlugin.so
35
36 %clean
37 rm -rf $RPM_BUILD_ROOT
38
39 %post
40 %update_browser_plugins
41
42 %postun
43 if [ "$1" = "0" ]; then
44         %update_browser_plugins
45 fi
46
47 %files
48 %defattr(644,root,root,755)
49 %doc README.md
50 %attr(755,root,root) %{_plugindir}/npWacomWebPlugin.so
This page took 0.062349 seconds and 3 git commands to generate.