]> git.pld-linux.org Git - packages/browser-plugin-genres.git/blob - browser-plugin-genres.spec
- 1.0.2 - needs porting to new xulrunner
[packages/browser-plugin-genres.git] / browser-plugin-genres.spec
1 # TODO:
2 # - browser-plugins v2
3 # - port to xulrunner >= 1.9.0
4 Summary:        GenReS browser scriptable plugin
5 Summary(pl.UTF-8):      GenReS - skryptowalna wtyczka do przeglądarki
6 Name:           browser-plugin-genres
7 Version:        1.0.2
8 Release:        0.1
9 License:        GPL
10 Group:          X11/Applications/Multimedia
11 Source0:        http://download.savannah.nongnu.org/releases/genres/genres-%{version}.tar.bz2
12 # Source0-md5:  b18778368fd5f9889557ab98f4998dcd
13 Patch0:         genres-mozilla-config.patch
14 Patch1:         genres-itvp.patch
15 URL:            https://savannah.nongnu.org/projects/genres
16 BuildRequires:  pkgconfig
17 BuildRequires:  xulrunner-devel < 1.9.0
18 Requires:       perl-Gtk2
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _plugindir      %{_libdir}/browser-plugins
22 %define         browsers        mozilla, mozilla-firefox
23
24 %description
25 GenReS is a generic reconfigurable scriptable plugin for
26 Mozilla/Firefox. It allows to use external programs for EMBED or
27 OBJECT HTML tags. The plugin is supplied with a Perl script for
28 embedding mplayer and mencoder in a browser and controlling it with
29 Javascript. It allows to play audio and video files and streams and to
30 record them to set of files. Manipulations with object variables in
31 JavaScript are translated to a Perl program. Status messages from the
32 controlled program (mplayer or mencoder) are translated back to
33 Javascript object variables, and Javascript functions are called for
34 notifications.
35
36 Supported browsers: %{browsers}.
37
38 %description -l pl.UTF-8
39 GenReS to uniwersalna skryptowalna wtyczka dla przeglądarek z rodziny
40 Mozilli. Umożliwia używanie zewnętrznych programów do obsługi
41 znaczników EMBED i OBJECT. Wtyczka pełni rolę interfejsu między stroną
42 WWW/JavaScriptem, a skryptem zdefiniowanym do obsługi danego typu
43 MIME. Dwustronna komunikacja między skryptem a stroną oparta jest na
44 strumieniach we/wy, dzięki czemu tworzenie skryptów jest proste, można
45 je pisać w dowolnym języku. W pakiecie znajduje się przykładowy, ale w
46 pełni funkcjonalny skrypt napisany w Perlu osadzający mplayera oraz
47 mencodera i umożliwiający ich kontrolę z okna przeglądarki.
48
49 %prep
50 %setup -q -n genres-%{version}
51 %patch0 -p1
52 %patch1 -p1
53
54 %build
55 %{__make}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 install -D genres.so $RPM_BUILD_ROOT%{_plugindir}/genres.so
60 install -D slaves/video/mplayer.sh $RPM_BUILD_ROOT%{_libdir}/genres/mplayer.sh
61 install -D doc/genres.conf $RPM_BUILD_ROOT%{_sysconfdir}/genres.conf
62
63 %{__make} install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 rm -rf $RPM_BUILD_ROOT%{_libdir}/mozilla
67 rm -rf $RPM_BUILD_ROOT%{_libdir}/mozilla-firefox
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %triggerin -- mozilla-firefox
73 %nsplugin_install -d %{_libdir}/mozilla-firefox/plugins genres.so genres.so
74
75 %triggerun -- mozilla-firefox
76 %nsplugin_uninstall -d %{_libdir}/mozilla-firefox/plugins genres.so genres.so
77
78 %triggerin -- mozilla
79 %nsplugin_install -d %{_libdir}/mozilla/plugins genres.so genres.so
80
81 %triggerun -- mozilla
82 %nsplugin_uninstall -d %{_libdir}/mozilla/plugins genres.so genres.so
83
84 %files
85 %defattr(644,root,root,755)
86 %doc README.en.html example
87 %attr(755,root,root) %{_plugindir}/genres.so
88 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/genres.conf
89 %attr(755,root,root) %{_libdir}/genres/config.pl
90 %attr(755,root,root) %{_libdir}/genres/mplayer.pl
91 %attr(755,root,root) %{_libdir}/genres/mplayer.sh
92 %attr(755,root,root) %{_libdir}/genres/slaves
This page took 0.083586 seconds and 3 git commands to generate.