]> git.pld-linux.org Git - packages/brltty.git/blob - brltty.spec
- updated to 6.6
[packages/brltty.git] / brltty.spec
1 # TODO:
2 #       - what is that huge %post script?
3 #
4 # Conditional build:
5 %bcond_without  apidocs                 # documentation generated with doxygen
6 %bcond_without  java                    # Java bindings
7 %bcond_without  ocaml                   # OCaml bindings
8 %bcond_without  python                  # Python bindings
9 %bcond_without  python3                 # Python 3.x bindings
10 %bcond_without  tcl                     # Tcl bindings
11 %bcond_without  x                       # X11-based utilities
12 %bcond_without  gpm                     # mouse tracking via GPM
13 %bcond_without  libbraille              # libbraille Braille driver
14 %bcond_without  espeak                  # eSpeak synthesizer driver
15 %bcond_without  flite                   # Flite synthesizer driver
16 %bcond_with     mikropuhe               # Mikropuhe synthesizer driver [commercial, Finnish]
17 %bcond_without  speech_dispatcher       # Speech Dispatcher synthesizer driver
18 %bcond_with     swift                   # Swift synthesizer driver [commercial, from Cepstral]
19 %bcond_with     theta                   # Theta synthesizer driver [commercial, from Cepstral]
20 %bcond_with     viavoice                # IBM ViaVoice synthesizer driver [commercial]
21 %bcond_with     at_spi                  # AtSpi screen driver
22 %bcond_without  at_spi2                 # AtSpi2 screen driver
23
24 %define         brlapi_ver      0.6.6
25 %include        /usr/lib/rpm/macros.java
26 Summary:        Braille display driver for Linux/Unix
27 Summary(pl.UTF-8):      Sterownik do wyświetlaczy Braille'a
28 Name:           brltty
29 Version:        5.5
30 Release:        3
31 License:        GPL v2+ (brltty and drivers), LGPL v2.1+ (APIs)
32 Group:          Daemons
33 Source0:        http://mielke.cc/brltty/archive/%{name}-%{version}.tar.xz
34 # Source0-md5:  cd2fb2158b9fc85b23c4225d1d067df6
35 Patch1:         %{name}-speech-dispatcher.patch
36 Patch2:         %{name}-python.patch
37 Patch3:         make.patch
38 URL:            http://mielke.cc/brltty/
39 BuildRequires:  alsa-lib-devel
40 %{?with_at_spi:BuildRequires:   at-spi-devel}
41 BuildRequires:  autoconf >= 2.64
42 BuildRequires:  automake
43 BuildRequires:  bison
44 BuildRequires:  rpmbuild(macros) >= 1.710
45 # just headers
46 BuildRequires:  bluez-libs-devel
47 %{?with_at_spi2:BuildRequires:  dbus-devel >= 1.0}
48 %{?with_apidocs:BuildRequires:  doxygen}
49 %{?with_espeak:BuildRequires:   espeak-devel}
50 %{?with_flite:BuildRequires:    flite-devel}
51 %{?with_gpm:BuildRequires:      gpm-devel}
52 %{?with_java:BuildRequires:     jdk}
53 %{?with_java:BuildRequires:     jpackage-utils}
54 %{?with_libbraille:BuildRequires:       libbraille-devel}
55 BuildRequires:  libicu-devel
56 BuildRequires:  ncurses-devel
57 %{?with_ocaml:BuildRequires:    ocaml}
58 BuildRequires:  pkgconfig
59 %{?with_python:BuildRequires:   python-Cython}
60 %{?with_python3:BuildRequires:  python3-Cython}
61 %{?with_java:BuildRequires:     rpm-javaprov}
62 %{?with_python:BuildRequires:   rpm-pythonprov}
63 %{?with_speech_dispatcher:BuildRequires:        speech-dispatcher-devel >= 0.8}
64 BuildRequires:  systemd-devel
65 BuildRequires:  tar >= 1:1.22
66 %{?with_tcl:BuildRequires:      tcl-devel >= 8.5}
67 %if %{with x}
68 BuildRequires:  xorg-lib-libX11-devel
69 BuildRequires:  xorg-lib-libXaw-devel
70 BuildRequires:  xorg-lib-libXext-devel
71 BuildRequires:  xorg-lib-libXt-devel
72 BuildRequires:  xorg-lib-libXtst-devel
73 %endif
74 #%{?with_mikropuhe:BuildRequires:       Mikropuhe-devel (-lmikropuhe <mpwrfile.h>)}
75 #%{?with_swift:BuildRequires:   Swift-devel (-lswift <swift.h>)}
76 #%{?with_theta:BuildRequires:   Theta-devel (-ltheta <theta.h>)}
77 #%{?with_viavoice:BuildRequires:        ViaVoice-devel (-libmeci50 <eci.h>)}
78 BuildRequires:  xz
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 %description
82 BRLTTY is a background process (daemon) which provides access to the
83 Linux/Unix console (when in text mode) for a blind person using a
84 refreshable Braille display. It drives the Braille display, and
85 provides complete screen review functionality. Some speech capability
86 has also been incorporated.
87
88 %description -l pl.UTF-8
89 BRLTTY jest demonem, który udostępnia dostęp do linuksowej konsoli (w
90 trybie tekstowym) dla niewidomych używających wyświetlaczy Braille'a z
91 odświeżaniem (refreshable Braille display). BRLTTY steruje
92 wyświetlaczem Braille'a i dostarcza funkcjonalność całkowitego
93 przeglądu ekranu. Do tego pakietu została włączona możliwość syntezy
94 mowy.
95
96 %package -n brlapi
97 Summary:        Application Programming Interface for BRLTTY
98 Summary(pl.UTF-8):      API do BRLTTY
99 License:        LGPL v2.1+
100 Group:          Libraries
101
102 %description -n brlapi
103 This package provides the run-time support for the Application
104 Programming Interface to BRLTTY.
105
106 Install this package if you have an application which directly
107 accesses a refreshable Braille display.
108
109 %description -n brlapi -l pl.UTF-8
110 Ten pakiet zawiera środowisko uruchomieniowe dla programów
111 korzystających z API BRLTTY.
112
113 Zainstaluj ten pakiet jeśli masz aplikację, która bezpośrednio używa
114 wyświetlacza Braille'a z odświeżaniem.
115
116 %package -n brlapi-devel
117 Summary:        Headers and documentation for BrlAPI
118 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do BrlAPI
119 License:        LGPL v2.1+
120 Group:          Development/Libraries
121 Requires:       brlapi = %{version}-%{release}
122
123 %description -n brlapi-devel
124 This package provides the header files, shared object linker
125 reference, and reference documentation for BrlAPI (the Application
126 Programming Interface to BRLTTY). It enables the implementation of
127 applications which take direct advantage of a refreshable Braille
128 display in order to present information in ways which are more
129 appropriate for blind users and/or to provide user interfaces which
130 are more specifically atuned to their needs.
131
132 Install this package if you're developing or maintaining an
133 application which directly accesses a refreshable Braille display.
134
135 %description -n brlapi-devel -l pl.UTF-8
136 Ten pakiet zawiera pliki nagłówkowe oraz dokumentację do BrlAPI (API
137 do BRLTTY). BrlAPI pozwala implementować aplikacje, które bezpośrednio
138 korzystają z wyświetlaczy Braille'a dostarczając interfejs użytkownika
139 bardziej przystosowany dla osób niewidomych.
140
141 Zainstaluj ten pakiet, jeśli tworzysz lub nadzorujesz aplikację
142 korzystającą bezpośrednio z odświeżalnych wyświetlaczy Braille'a.
143
144 %package -n brlapi-static
145 Summary:        Static BrlAPI library
146 Summary(pl.UTF-8):      Statyczna biblioteka BrlAPI
147 License:        LGPL v2.1+
148 Group:          Development/Libraries
149 Requires:       brlapi-devel = %{version}-%{release}
150
151 %description -n brlapi-static
152 This is package with static BrlAPI library.
153
154 %description -n brlapi-static -l pl.UTF-8
155 Ten pakiet zawiera statyczną wersję biblioteki BrlAPI.
156
157 %package -n brlapi-apidocs
158 Summary:        BrlAPI documentation
159 Summary(pl.UTF-8):      Documentacja BrlAPI
160 Group:          Documentation
161 %if "%{_rpmversion}" >= "5"
162 BuildArch:      noarch
163 %endif
164
165 %description -n brlapi-apidocs
166 Documentation for BrlAPI in HTML format generated from brltty sources
167 by doxygen.
168
169 %description -n brlapi-apidocs -l pl.UTF-8
170 Dokumentacja BrlAPI w formacie HTML generowane ze źrodeł brltty przez
171 doxygen.
172
173 %package -n java-brlapi
174 Summary:        BrlAPI library for Java
175 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Javy
176 License:        LGPL v2.1+
177 Group:          Libraries
178 Requires:       brlapi = %{version}-%{release}
179
180 %description -n java-brlapi
181 BrlAPI library for Java.
182
183 %description -n java-brlapi -l pl.UTF-8
184 Biblioteka BrlAPI dla Javy.
185
186 %package -n ocaml-brlapi
187 Summary:        OCaml binding for BrlAPI
188 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI
189 License:        LGPL v2.1+
190 Group:          Libraries
191 Requires:       brlapi = %{version}-%{release}
192 %requires_eq    ocaml-runtime
193
194 %description -n ocaml-brlapi
195 OCaml binding for BrlAPI.
196
197 %description -n ocaml-brlapi -l pl.UTF-8
198 Wiązania OCamla do BrlAPI.
199
200 %package -n ocaml-brlapi-devel
201 Summary:        OCaml binding for BrlAPI - development files
202 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI - pliki programistyczne
203 License:        LGPL v2.1+
204 Group:          Libraries
205 Requires:       ocaml-brlapi = %{version}-%{release}
206 %requires_eq    ocaml
207
208 %description -n ocaml-brlapi-devel
209 OCaml binding for BrlAPI - development files.
210
211 %description -n ocaml-brlapi-devel -l pl.UTF-8
212 Wiązania OCamla do BrlAPI - pliki programistyczne.
213
214 %package -n python-brlapi
215 Summary:        Python 2.x interface to BrlAPI
216 Summary(pl.UTF-8):      Interfejs Pythona 2.x do BrlAPI
217 License:        LGPL v2.1+
218 Group:          Libraries
219 Requires:       brlapi = %{version}-%{release}
220
221 %description -n python-brlapi
222 Python 2.x interface to BrlAPI.
223
224 %description -n python-brlapi -l pl.UTF-8
225 Interfejs Pythona 2.x do BrlAPI.
226
227 %package -n python3-brlapi
228 Summary:        Python 3.x interface to BrlAPI
229 Summary(pl.UTF-8):      Interfejs Pythona 3.x do BrlAPI
230 License:        LGPL v2.1+
231 Group:          Libraries
232 Requires:       brlapi = %{version}-%{release}
233
234 %description -n python3-brlapi
235 Python 3.x interface to BrlAPI.
236
237 %description -n python3-brlapi -l pl.UTF-8
238 Interfejs Pythona 3.x do BrlAPI.
239
240 %package -n brlapi-tcl
241 Summary:        BrlAPI library for Tcl
242 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Tcl
243 License:        LGPL v2.1+
244 Group:          Libraries
245 Requires:       brlapi = %{version}-%{release}
246
247 %description -n brlapi-tcl
248 BrlAPI library for Tcl.
249
250 %description -n brlapi-tcl -l pl.UTF-8
251 Biblioteka BrlAPI dla Tcl.
252
253 %prep
254 %setup -q
255 %patch1 -p1
256 %patch2 -p1
257 %patch3 -p1
258
259 %build
260 %{__autoconf}
261 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
262 %configure \
263         %{?with_java:JAVA_HOME=%{java_home}} \
264         --with-install-root="$RPM_BUILD_ROOT" \
265         %{!?with_libbraille:--without-libbraille} \
266         %{!?with_espeak:--without-espeak} \
267         %{!?with_flite:--without-flite} \
268         %{!?with_speech_dispatcher:--without-speechd} \
269         %{!?with_ocaml:--disable-caml-bindings} \
270         %{!?with_gpm:--disable-gpm} \
271         %{!?with_java:--disable-java-bindings} \
272         %{!?with_python:--disable-python-bindings} \
273         %{!?with_tcl:--disable-tcl-bindings} \
274         %{!?with_x:--disable-x} \
275         --enable-api
276
277 %{__make} -j1
278
279 %if %{with python}
280 cd Bindings/Python
281 %py_build
282 cd ../..
283 %endif
284
285 %if %{with python3}
286 cd Bindings/Python
287 %py3_build
288 cd ../..
289 %endif
290
291 %install
292 rm -rf $RPM_BUILD_ROOT
293
294 %{__make} -j1 install \
295         OCAML_INSTALL_TARGET=install-without-findlib
296
297 # findlib-specific, useless in rpm
298 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so.owner
299
300 %if %{with python}
301 cd Bindings/Python
302 %py_install
303 cd ../..
304 %endif
305
306 %if %{with python3}
307 cd Bindings/Python
308 %py3_install
309 cd ../..
310 %endif
311
312 %if %{_lib} != "lib"
313         # Fix java plugin install path on 64-bit archs
314         install -d $RPM_BUILD_ROOT%{_libdir}/java
315         %{__mv} $RPM_BUILD_ROOT%{_prefix}/{lib,%{_lib}}/java/libbrlapi_java.so
316 %endif
317
318 cp -p Documents/brltty.conf $RPM_BUILD_ROOT%{_sysconfdir}
319
320 install -d $RPM_BUILD_ROOT%{systemdtmpfilesdir}
321 cat >$RPM_BUILD_ROOT%{systemdtmpfilesdir}/brltty.conf <<EOF
322 d /var/run/brltty 0755 root root -
323 EOF
324
325 # no sign in source wheter it is zh_CN or zh_TW so just remove it
326 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/zh
327
328 %find_lang %{name}
329
330 %clean
331 rm -rf $RPM_BUILD_ROOT
332
333 %pre
334 # The pre-install scriptlet.
335
336 # If a configuration file already exists then rpm installs the new one as
337 # <path>.rpmnew. If this is done then the .rpmnew file is overwritten if it
338 # already exists.
339
340 # There's no explicit way to tell if a configuration file has been installed
341 # as itself or as a .rpmnew file. The way we'll figure it out, therefore, is by
342 # erasing the .rpmnew file now so that we can see if it gets created later.
343 rm -f "%{_sysconfdir}/brltty.conf.rpmnew"
344
345 %post
346 # The post-install scriptlet.
347
348 # If BRLTTY's boot parameter has been specified then update the just installed
349 # configuration file template to reflect the options supplied thereby.
350
351 # First, we need to determine which file to update. If there's a .rpmnew file
352 # then update it since a previous configuration file must already have existed.
353 file="%{_sysconfdir}/brltty.conf"
354 new="${file}.rpmnew"
355 [ -f "${new}" ] && file="${new}"
356
357 # Update the configuration file template via the Bootdisks/bp2cf script.
358 # Include it right within this scriptlet so that it needn't be installed.
359 # Imbed it within a subshell to ensure that it won't impact this scriptlet.
360 (
361         # First, set bp2cf's command line arguments.
362         set -- -u -f "${file}"
363
364 #!/bin/sh
365 ###############################################################################
366 # BRLTTY - A background process providing access to the Linux console (when in
367 #          text mode) for a blind person using a refreshable Braille display.
368 #
369 # Copyright (C) 1995-2003 by The BRLTTY Team. All rights reserved.
370 #
371 # BRLTTY comes with ABSOLUTELY NO WARRANTY.
372 #
373 # This is free software, placed under the terms of the
374 # GNU General Public License, as published by the Free Software
375 # Foundation.  Please see the file COPYING for details.
376 #
377 # Web Page: http://mielke.cc/brltty/
378 #
379 # This software is maintained by Dave Mielke <dave@mielke.cc>.
380 ###############################################################################
381
382 # Convert the boot parameter to configuration file directives.
383 # If /proc is mounted then use the brltty= boot parameter in /proc/cmdline.
384 # If /proc is not mounted then use the brltty environment variable.
385 # Invoke with -h for usage information.
386
387 programName="${0##*/}"
388 programMessage()
389 {
390         echo 2>&1 "${programName}: ${1}"
391 }
392 syntaxError()
393 {
394         programMessage "${1}"
395         exit 2
396 }
397 internalError()
398 {
399         programMessage "${1}"
400         exit 3
401 }
402
403 configurationFile=""
404 requestedAction=create
405 deviceTranslation=none
406 requestedParameter=""
407 OPTIND=1
408 while getopts ":f:cundop:h" option
409 do
410         case "${option}" in
411             f) configurationFile="${OPTARG}";;
412             c) requestedAction=create;;
413             u) requestedAction=update;;
414             n) deviceTranslation=none;;
415             d) deviceTranslation=devfs;;
416             o) deviceTranslation=old;;
417             p) requestedParameter="${OPTARG}";;
418             h)
419                 cat <<EOF
420 Usage: ${programName} [option ...]
421 -f file  The configuration file to create/update.
422 -c       Create the configuration file (write to stdout if no -f).
423 -u       Update the configuration file (copying from stdin to stdout if no -f).
424 -n       Do not translate device paths.
425 -d       Do old-style to devfs device path translation.
426 -o       Do devfs to old-style device path translation.
427 -p [driver][,[device][,[table]]]
428          Explicitly specify the boot parameter.
429 -h       Display this usage summary.
430 EOF
431                 exit 0
432                 ;;
433             \?) syntaxError "unknown option: -${OPTARG}";;
434             :) syntaxError "missing value: -${OPTARG}";;
435             *) internalError "unimplemented option: -${option}";;
436         esac
437 done
438 shift "`expr $OPTIND - 1`"
439 [ "${#}" -eq 0 ] || syntaxError "too many parameters."
440
441 case "${requestedAction}" in
442     create)
443         putConfigurationLine()
444         {
445                 echo "${1}" || exit 4
446         }
447         startConfigurationFile()
448         {
449                 [ -n "${configurationFile}" ] && exec >"${configurationFile}"
450                 putConfigurationLine "`makeHeaderLine Created`"
451                 putConfigurationLine "`makeParameterLine`"
452                 putConfigurationLine ""
453         }
454         putConfigurationDirective()
455         {
456                 putConfigurationLine "${1} ${2}"
457         }
458         finalizeConfigurationFile()
459         {
460                 :
461         }
462         ;;
463     update)
464         putSedCommand()
465         {
466                 sedScript="${sedScript}
467 ${1}"
468         }
469         startConfigurationFile()
470         {
471                 if [ -n "${configurationFile}" ]; then
472                         [ -e "${configurationFile}" ] || syntaxError "file not found: ${configurationFile}"
473                         [ -f "${configurationFile}" ] || syntaxError "not a file: ${configurationFile}"
474                         [ -r "${configurationFile}" ] || syntaxError "file not readable: ${configurationFile}"
475                         [ -w "${configurationFile}" ] || syntaxError "file not writable: ${configurationFile}"
476                         outputFile="${configurationFile}.new"
477                         exec <"${configurationFile}" >"${outputFile}"
478                 fi
479                 sedScript=""
480                 putSedCommand "1i\\
481 `makeHeaderLine Updated`\\
482 `makeParameterLine`\\
483 "
484         }
485         putConfigurationDirective()
486         {
487                 value="`echo "${2}" | sed -e 's%\\([/\\]\\)%\\\\\\1%g'`"
488                 putSedCommand "/^ *#\\(${1} .*\\)/s//\\1/"
489                 putSedCommand "/^ *\\(${1}\\) .*/s//\\1 ${value}/"
490         }
491         finalizeConfigurationFile()
492         {
493                 sed -e "${sedScript}"
494                 [ -n "${outputFile}" ] && mv -f "${outputFile}" "${configurationFile}"
495         }
496         ;;
497     *) internalError "unimplemented action: ${requestedAction}";;
498 esac
499
500 translateDevice_none()
501 {
502         :
503 }
504 translateDevice_devfs()
505 {
506         minor="${device#ttyS}"
507         if [ "${minor}" != "${device}" ]; then
508                 device="tts/${minor}"
509                 return 0
510         fi
511         minor="${device#lp}"
512         if [ "${minor}" != "${device}" ]; then
513                 device="printers/${minor}"
514                 return 0
515         fi
516         programMessage "unsupported old-style device: ${device}"
517 }
518 translateDevice_old()
519 {
520         major="${device%%/*}"
521         if [ "${major}" != "${device}" ]; then
522                 minor="${device#*/}"
523                 case "${major}" in
524                     tts) devfs="ttyS${minor}";;
525                     printers) devfs="lp${minor}";;
526                 esac
527         fi
528         if [ -n "${devfs}" ]; then
529                 device="${devfs}"
530         else
531                 programMessage "unsupported devfs device: ${device}"
532         fi
533 }
534
535 makeHeaderLine()
536 {
537         echo "# ${1} by brltty-bp2cf`date +' on %Y-%m-%d at %H:%M:%S %Z (UTC%z)'`."
538 }
539 makeParameterLine()
540 {
541         echo "# Boot Parameter:${bootParameter}"
542 }
543 putConfigurationFile()
544 {
545         startConfigurationFile
546         [ -n "${brailleDriver}" ] && putConfigurationDirective "braille-driver" "${brailleDriver}"
547         [ -n "${brailleDevice}" ] && {
548         device="`echo "${brailleDevice}" | sed -e 's%//*%/%g' -e 's%^/dev/%%'`"
549         if [ "${device#/}" = "${device}" ]; then
550                 translateDevice_${deviceTranslation}
551         fi
552         putConfigurationDirective "braille-device" "${device}"
553         }
554         [ -n "${textTable}" ] && putConfigurationDirective "text-table" "${textTable}"
555         finalizeConfigurationFile
556 }
557 parseBootParameter()
558 {
559         bootParameter="${bootParameter} ${1}"
560         number=1
561         while [ "${number}" -le 3 ]; do
562                 cut="cut -d, -f${number}"
563                 [ "${number}" -gt 1 ] && cut="${cut} -s"
564                 operand="`echo ${1} | ${cut}`"
565                 if [ -n "${operand}" ]; then
566                         case "${number}" in
567                             1) brailleDriver="${operand}";;
568                             2) brailleDevice="${operand}";;
569                             3) textTable="${operand}";;
570                         esac
571                 fi
572                 number="`expr ${number} + 1`"
573         done
574 }
575 putBootParameter()
576 {
577         parseBootParameter "${1}"
578         putConfigurationFile
579 }
580 parseBootCommand()
581 {
582         found=false
583         while [ "${#}" -gt 0 ]; do
584                 case "${1}" in
585                     "brltty="*)
586                         found=true
587                         parseBootParameter "${1#*=}"
588                         ;;
589                 esac
590                 shift
591         done
592         "${found}" && putConfigurationFile
593 }
594
595 brailleDriver=""
596 brailleDevice=""
597 textTable=""
598 bootCommandFile="/proc/cmdline"
599 if [ -n "${requestedParameter}" ]; then
600         putBootParameter "${requestedParameter}"
601 elif [ -f "${bootCommandFile}" ]; then
602         parseBootCommand `cat "${bootCommandFile}"`
603 elif [ -n "${brltty}" ]; then
604         putBootParameter "${brltty}"
605 fi
606 exit 0
607 )
608
609 %post   -n brlapi -p /sbin/ldconfig
610 %postun -n brlapi -p /sbin/ldconfig
611
612 %files -f %{name}.lang
613 %defattr(644,root,root,755)
614 %doc Documents/{Manual-BRLTTY/English/BRLTTY*,ChangeLog,HISTORY,TODO}
615 %attr(755,root,root) %{_bindir}/brltty
616 %attr(755,root,root) %{_bindir}/brltty-atb
617 %attr(755,root,root) %{_bindir}/brltty-config
618 %attr(755,root,root) %{_bindir}/brltty-ctb
619 %attr(755,root,root) %{_bindir}/brltty-ktb
620 %attr(755,root,root) %{_bindir}/brltty-trtxt
621 %attr(755,root,root) %{_bindir}/brltty-ttb
622 %attr(755,root,root) %{_bindir}/brltty-tune
623 %attr(755,root,root) %{_bindir}/eutp
624 %attr(755,root,root) %{_bindir}/vstp
625 %{?with_x:%attr(755,root,root) %{_bindir}/xbrlapi}
626 %dir %{_libdir}/brltty
627 # Braille drivers
628 %attr(755,root,root) %{_libdir}/brltty/libbrlttybal.so
629 %attr(755,root,root) %{_libdir}/brltty/libbrlttybat.so
630 %attr(755,root,root) %{_libdir}/brltty/libbrlttybba.so
631 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbc.so
632 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbd.so
633 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbg.so
634 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbl.so
635 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbm.so
636 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbn.so
637 %attr(755,root,root) %{_libdir}/brltty/libbrlttybcb.so
638 %attr(755,root,root) %{_libdir}/brltty/libbrlttybce.so
639 %attr(755,root,root) %{_libdir}/brltty/libbrlttybec.so
640 %attr(755,root,root) %{_libdir}/brltty/libbrlttybeu.so
641 %attr(755,root,root) %{_libdir}/brltty/libbrlttybfs.so
642 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhd.so
643 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhm.so
644 %attr(755,root,root) %{_libdir}/brltty/libbrlttybht.so
645 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhw.so
646 %attr(755,root,root) %{_libdir}/brltty/libbrlttybir.so
647 %{?with_libbraille:%attr(755,root,root) %{_libdir}/brltty/libbrlttyblb.so}
648 %attr(755,root,root) %{_libdir}/brltty/libbrlttyblt.so
649 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmb.so
650 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmd.so
651 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmm.so
652 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmn.so
653 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmt.so
654 %attr(755,root,root) %{_libdir}/brltty/libbrlttybnp.so
655 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpg.so
656 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpm.so
657 %attr(755,root,root) %{_libdir}/brltty/libbrlttybsk.so
658 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtn.so
659 %attr(755,root,root) %{_libdir}/brltty/libbrlttybts.so
660 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtt.so
661 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvd.so
662 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvo.so
663 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvr.so
664 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvs.so
665 %{?with_x:%attr(755,root,root) %{_libdir}/brltty/libbrlttybxw.so}
666 # speech synthesizer drivers
667 %attr(755,root,root) %{_libdir}/brltty/libbrlttysal.so
668 %attr(755,root,root) %{_libdir}/brltty/libbrlttysbl.so
669 %attr(755,root,root) %{_libdir}/brltty/libbrlttyscb.so
670 %{?with_espeak:%attr(755,root,root) %{_libdir}/brltty/libbrlttyses.so}
671 %{?with_flite:%attr(755,root,root) %{_libdir}/brltty/libbrlttysfl.so}
672 %attr(755,root,root) %{_libdir}/brltty/libbrlttysfv.so
673 %attr(755,root,root) %{_libdir}/brltty/libbrlttysgs.so
674 %{?with_mikropuhe:%attr(755,root,root) %{_libdir}/brltty/libbrlttysmp.so}
675 %{?with_speech_dispatcher:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssd.so}
676 %{?with_swift:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssw.so}
677 %{?with_theta:%attr(755,root,root) %{_libdir}/brltty/libbrlttysth.so}
678 %{?with_viavoice:%attr(755,root,root) %{_libdir}/brltty/libbrlttysvv.so}
679 %attr(755,root,root) %{_libdir}/brltty/libbrlttysxs.so
680 # screen drivers
681 %{?with_at_spi2:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxa2.so}
682 %{?with_at_spi:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxas.so}
683 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxlx.so
684 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxsc.so
685 %{_sysconfdir}/brltty
686 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/brltty.conf
687 %{systemdtmpfilesdir}/brltty.conf
688 %dir /var/lib/BrlAPI
689 %dir /var/run/brltty
690 %{_mandir}/man1/brltty.1*
691 %{_mandir}/man1/eutp.1*
692 %{_mandir}/man1/vstp.1*
693 %{?with_x:%{_mandir}/man1/xbrlapi.1*}
694
695 %if %{with x}
696 # gdm autostart - subpackage?
697 #%{_datadir}/gdm/greeter/autostart/xbrlapi.desktop
698 #/etc/X11/Xsession.d/60xbrlapi
699 %{_datadir}/metainfo/org.a11y.brltty.metainfo.xml
700 %endif
701 %{_datadir}/polkit-1/actions/org.a11y.brlapi.policy
702
703 %files -n brlapi
704 %defattr(644,root,root,755)
705 %attr(755,root,root) %{_libdir}/libbrlapi.so.*.*.*
706 %attr(755,root,root) %ghost %{_libdir}/libbrlapi.so.0.6
707
708 %files -n brlapi-devel
709 %defattr(644,root,root,755)
710 %doc Documents/Manual-BrlAPI/English/BrlAPI*
711 %attr(755,root,root) %{_libdir}/libbrlapi.so
712 %{_includedir}/brltty
713 %{_includedir}/brlapi*.h
714 %{_mandir}/man3/brlapi_*.3*
715
716 %files -n brlapi-static
717 %defattr(644,root,root,755)
718 %{_libdir}/libbrlapi.a
719
720 %if %{with apidocs}
721 %files -n brlapi-apidocs
722 %defattr(644,root,root,755)
723 %doc Documents/BrlAPIref/html/*
724 %endif
725
726 %if %{with java}
727 %files -n java-brlapi
728 %defattr(644,root,root,755)
729 %attr(755,root,root) %{_libdir}/java/libbrlapi_java.so
730 %{_javadir}/brlapi.jar
731 %endif
732
733 %if %{with ocaml}
734 %files -n ocaml-brlapi
735 %defattr(644,root,root,755)
736 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so
737
738 %files -n ocaml-brlapi-devel
739 %defattr(644,root,root,755)
740 %dir %{_libdir}/ocaml/brlapi
741 %{_libdir}/ocaml/brlapi/META
742 %{_libdir}/ocaml/brlapi/brlapi.cm[aix]*
743 %{_libdir}/ocaml/brlapi/brlapi.mli
744 %{_libdir}/ocaml/brlapi/libbrlapi_stubs.a
745 %endif
746
747 %if %{with python}
748 %files -n python-brlapi
749 %defattr(644,root,root,755)
750 %attr(755,root,root) %{py_sitedir}/brlapi.so
751 %{py_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
752
753 %if %{with python3}
754 %files -n python3-brlapi
755 %defattr(644,root,root,755)
756 %attr(755,root,root) %{py3_sitedir}/brlapi.cpython-*.so
757 %{py3_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
758 %endif
759 %endif
760
761 %if %{with tcl}
762 %files -n brlapi-tcl
763 %defattr(644,root,root,755)
764 %dir %{_libdir}/brlapi-%{brlapi_ver}
765 %attr(755,root,root) %{_libdir}/brlapi-%{brlapi_ver}/libbrlapi_tcl.so
766 %{_libdir}/brlapi-%{brlapi_ver}/pkgIndex.tcl
767 %endif
This page took 0.098595 seconds and 3 git commands to generate.