]> git.pld-linux.org Git - packages/bootsplash.git/commitdiff
- added theme darkblue (via dropin)
authorpzurowski <pzurowski@pld-linux.org>
Mon, 22 Dec 2003 23:14:50 +0000 (23:14 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- created /etc/sysconfig/bootsplash and suitably moficated bootsplash.script

Changed files:
    bootsplash.script -> 1.3
    bootsplash.spec -> 1.9
    bootsplash.sysconfig -> 1.1

bootsplash.script
bootsplash.spec
bootsplash.sysconfig [new file with mode: 0644]

index f50ad67d4368f060032ad8688b4d8ec0e2550b3b..c66908441e4d6979fc556c946568e8763f4de3e7 100644 (file)
@@ -34,7 +34,7 @@
 #
 # Modified for PLD (arekm@pld-linux.org)
 
-[ -f /etc/sysconfig/system ] && . /etc/sysconfig/system
+[ -f /etc/sysconfig/bootsplash ] && . /etc/sysconfig/bootsplash
 
 _procsplash=$(cat /proc/splash 2> /dev/null)
 
@@ -76,14 +76,13 @@ fi
 
 if [ "$progress" == 1 -o "$1" == "splash start" ]; then
   [ "$_shutdown" == "yes" ] && ( echo "silent" > /proc/splash ; chvt 1)
-  _boot="Booting"
-  [ "$_shutdown" == "yes" ] && _boot="Shutting down"
+  _boot=$BOOT_TXT
+  [ "$_shutdown" == "yes" ] && _boot=$SHUTDOWN_TXT
 
   if [ "$text_x" != "" -a "$text_y" != "" \
        -a "$text_color" != "" -a "$text_size" != "" -a "$_silent" == "yes" ]; 
   then
-    fbtruetype -x $text_x -y $text_y -t $text_color -s $text_size \
-                       "$_boot the system... Press F2 for verbose mode"
+    fbtruetype -x $text_x -y $text_y -t $text_color -s $text_size "$_boot"
   fi
 fi
 
index e5c5fc8770274152593b1a9be78fbc39bbd89a12..bc70bfc00f33e66b9a4e05e0850fb8e1f8c98241 100644 (file)
@@ -1,14 +1,20 @@
+
+%bcond_without themes          # build without themes
+
 Summary:       Bootsplash - graphical boot process for Linux
 Summary(pl):   Bootsplash - graficzny proces startu systemu dla Linuksa
 Name:          bootsplash
 Version:       3.0.7
-Release:       0.3
+Release:       0.4
 Epoch:         0
 License:       GPL v2
 Group:         Applications/System
 Source0:       ftp://ftp.suse.com/pub/people/stepan/%{name}/rpm-sources/%{name}/%{name}-%{version}.tar.bz2
 # Source0-md5: d7c7cdab692fb2edc5cf5ebb554f20a1
 Source1:       %{name}.script
+Source2:       %{name}.sysconfig
+Source3:       %{name}-theme-darkblue-1.2.tar.gz
+# Source3-md5: a5b64219f284ff772a4f3ebcd4f2bc34
 Patch0:                %{name}-freetype-includes.patch
 URL:           http://www.bootsplash.org/
 BuildRequires: freetype-devel >= 2.1
@@ -27,8 +33,23 @@ Maj
 startu systemu i sterowaæ jego zachowaniem przy u¿yciu tego zbioru
 narzêdzi przestrzeni u¿ytkownika.
 
+%if %{with themes}
+%package theme-darkblue
+Summary:       Bootsplash - darkblue theme
+Summary(pl):   Bootsplash - motyw darkblue
+Group:         Themes
+Requires:      bootsplash
+
+%description theme-darkblue
+Darkblue theme for bootsplash.
+
+%description theme-darkblue -l pl
+Motyw darkblue do bootsplash.
+
+%endif
+
 %prep
-%setup -q
+%setup -q %{?with_themes:-a3}
 %patch0 -p1
 
 %build
@@ -39,13 +60,22 @@ narz
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{name}}
+install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{name},/etc/{bootsplash/themes,sysconfig}}
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/splash
+install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/bootsplash
 install Scripts/* $RPM_BUILD_ROOT%{_datadir}/%{name}
 install Utilities/splash $RPM_BUILD_ROOT%{_bindir}/splash.bin
 install Utilities/{fbmngplay,fbresolution,fbtruetype} $RPM_BUILD_ROOT%{_bindir}
 install Utilities/*.ttf $RPM_BUILD_ROOT%{_datadir}/%{name}
+%if %{with themes}
+#darkblue theme
+THEME_DIR=$RPM_BUILD_ROOT/etc/bootsplash/themes/darkblue
+install -d $THEME_DIR{,/animations,/config,/images}
+install darkblue/animations/*.mng $THEME_DIR/animations
+install darkblue/config/*.cfg $THEME_DIR/config
+install darkblue/images/*.jpeg $THEME_DIR/images
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -54,4 +84,11 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc {Documentation,Utilities}/README.*
 %attr(755,root,root) %{_bindir}/*
+%attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/bootsplash
 %{_datadir}/%{name}
+
+%files theme-darkblue
+%defattr(644,root,root,755)
+/etc/bootsplash/themes/darkblue/animations/*
+%config(noreplace) %verify(not md5 size mtime)/etc/bootsplash/themes/darkblue/config/*
+/etc/bootsplash/themes/darkblue/images/*
diff --git a/bootsplash.sysconfig b/bootsplash.sysconfig
new file mode 100644 (file)
index 0000000..9079621
--- /dev/null
@@ -0,0 +1,18 @@
+# $Id$
+
+# boot splash enabled?
+#SPLASH=yes
+BOOT_SPLASH=yes
+
+# bootsplash theme... You have to have installed one
+#THEME=darkblue
+THEME=darkblue
+
+# Text to show when booting...
+#BOOT_TXT="Booting the system... press F2 for verbose mode"
+BOOT_TXT="Booting the system... press F2 for verbose mode"
+
+# Text to show when shutting down...
+#SHUTDOWN_TXT="Shutting down the system... press F2 for verbose mode"
+SHUTDOWN_TXT="Shutting down the system... press F2 for verbose mode"
+
This page took 0.113988 seconds and 4 git commands to generate.