]> git.pld-linux.org Git - packages/bootparamd.git/blob - bootparamd.spec
- many small fixes, inspired by kloczek
[packages/bootparamd.git] / bootparamd.spec
1 Summary:        A server process which provides boot information to diskless clients
2 Summary(pl):    Demon zapewniaj±cy informacje potrzebne do uruchomienia bezdyskowych klientów
3 Name:           bootparamd
4 Version:        0.17
5 Release:        10
6 License:        BSD
7 Group:          Networking/Daemons
8 Source0:        ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/netkit-%{name}-%{version}.tar.gz
9 # Source0-md5:  00d211115b11aec2e214b701fe72f397
10 Source1:        %{name}.init
11 Patch0:         %{name}-install_man_fix.patch
12 Prereq:         /sbin/chkconfig
13 Prereq:         rc-scripts
14 Requires:       portmap
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 The bootparamd process provides bootparamd, a server process which
19 provides the information needed by diskless clients in order for them
20 to successfully boot. Bootparamd looks first in /etc/bootparams for an
21 entry for that particular client; if a local bootparams file doesn't
22 exist, it looks at the appropriate Network Information Service (NIS)
23 map. Some network boot loaders (notably Sun's) rely on special boot
24 server code on the server, in addition to the rarp and tftp servers.
25 This bootparamd server process is compatible with SunOS bootparam
26 clients and servers which need that boot server code.
27
28 %description -l pl
29 Pakiet zawiera program bootparamd - demon, który zapewnia informacje
30 potrzebne dla uruchomienia bezdyskowych klientów. bootparamd szuka w
31 /etc/bootparams wpisu dla konkretnego klienta; je¿eli plik ten nie
32 istnieje, szuka odpowiedniej mapy NIS. Niektóre sieciowe bootloadery
33 (np. Suna) polegaj± na specjalnym kodzie bootuj±cym na serwerze. Ten
34 bootparamd jest kompatybilny z klientami bootparam na SunOS-ie i
35 serwerami potrzebuj±cymi tego kodu.
36
37 %prep
38 %setup -q -n netkit-bootparamd-%{version}
39 %patch -p1
40
41 %build
42 ./configure \
43         --with-c-compiler=%{__cc}
44 %{__make} CFLAGS="%{rpmcflags}"
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_mandir}/man8} \
49         $RPM_BUILD_ROOT/etc/rc.d/init.d
50
51 %{__make} install \
52         INSTALLROOT=$RPM_BUILD_ROOT \
53         MANDIR=%{_mandir}
54
55 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/bootparamd
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %post
61 /sbin/chkconfig --add bootparamd
62 if [ -f /var/lock/subsys/rpc.bootparamd ]; then
63         /etc/rc.d/init.d/bootparamd restart 1>&2
64 else
65         echo "Type \"/etc/rc.d/init.d/bootparamd start\" to start rpc.bootparamd server" 1>&2
66 fi
67
68 %preun
69 if [ "$1" = "0" ]; then
70         if [ -f /var/lock/subsys/rpc.bootparamd ]; then
71                 /etc/rc.d/init.d/bootparamd stop 1>&2
72         fi
73         /sbin/chkconfig --del bootparamd
74 fi
75
76 %files
77 %defattr(644,root,root,755)
78 %attr(754,root,root) /etc/rc.d/init.d/bootparamd
79 %attr(755,root,root) %{_sbindir}/rpc.bootparamd
80 %attr(755,root,root) %{_bindir}/callbootd
81 %{_mandir}/man[58]/*
This page took 0.075554 seconds and 4 git commands to generate.