]> git.pld-linux.org Git - packages/bootparamd.git/blob - bootparamd.spec
- reverting last change: removing new macros from %p{re,ost}{,un}
[packages/bootparamd.git] / bootparamd.spec
1 Summary:        A server process which provides boot information to diskless clients
2 Summary(pl):    Demon który zapewnia informacje potrzebne do uruchomienia bezdyskowych klientów
3 Name:           bootparamd
4 Version:        0.17
5 Release:        8
6 License:        BSD
7 Group:          Networking/Daemons
8 Group(de):      Netzwerkwesen/Server
9 Group(pl):      Sieciowe/Serwery
10 Source0:        ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/netkit-%{name}-%{version}.tar.gz
11 Source1:        %{name}.init
12 Patch0:         %{name}-install_man_fix.patch
13 Prereq:         rc-scripts
14 Requires:       /sbin/chkconfig
15 Requires:       portmap
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 The bootparamd process provides bootparamd, a server process which
20 provides the information needed by diskless clients in order for them
21 to successfully boot. Bootparamd looks first in /etc/bootparams for an
22 entry for that particular client; if a local bootparams file doesn't
23 exist, it looks at the appropriate Network Information Service (NIS)
24 map. Some network boot loaders (notably Sun's) rely on special boot
25 server code on the server, in addition to the rarp and tftp servers.
26 This bootparamd server process is compatible with SunOS bootparam
27 clients and servers which need that boot server code.
28
29 %prep
30 %setup -q -n netkit-bootparamd-%{version}
31 %patch -p1
32
33 %build
34 ./configure --with-c-compiler=%{__cc}
35 %{__make} CFLAGS="%{rpmcflags}"
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_mandir}/man8} \
40         $RPM_BUILD_ROOT/etc/rc.d/init.d
41
42 %{__make} install \
43         INSTALLROOT=$RPM_BUILD_ROOT \
44         MANDIR=%{_mandir}
45
46 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/bootparamd
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %post
52 /sbin/chkconfig --add bootparamd
53 if [ -f /var/lock/subsys/rpc.bootparamd ]; then
54         /etc/rc.d/init.d/bootparamd restart 1>&2
55 else
56         echo "Type \"/etc/rc.d/init.d/bootparamd start\" to start rpc.bootparamd server" 1>&2
57 fi
58
59 %postun
60 if [ "$1" = "0" ]; then
61         if [ -f /var/lock/subsys/rpc.bootparamd ]; then
62                 /etc/rc.d/init.d/bootparamd stop 1>&2
63         fi
64         /sbin/chkconfig --del bootparamd
65 fi
66
67 %files
68 %defattr(644,root,root,755)
69 %attr(754,root,root) /etc/rc.d/init.d/bootparamd
70 %attr(755,root,root) %{_sbindir}/rpc.bootparamd
71 %attr(755,root,root) %{_bindir}/callbootd
72 %{_mandir}/man[58]/*
This page took 0.064515 seconds and 3 git commands to generate.