]> git.pld-linux.org Git - packages/bootparamd.git/blob - bootparamd.spec
- changed %%{!?debug:...}%%{?debug...} to %%{?debug:...}%%{!?debug...}
[packages/bootparamd.git] / bootparamd.spec
1 Summary:        A server process which provides boot information to diskless clients
2 Name:           bootparamd
3 Version:        0.17
4 Release:        6
5 License:        BSD
6 Group:          Networking/Daemons
7 Group(de):      Netzwerkwesen/Server
8 Group(pl):      Sieciowe/Serwery
9 Source0:        ftp://ftp.linux.org.uk/pub/linux/Networking/netkit/netkit-%{name}-%{version}.tar.gz
10 Source1:        %{name}.init
11 Patch0:         %{name}-install_man_fix.patch
12 Prereq:         /sbin/chkconfig
13 Requires:       portmap
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 The bootparamd process provides bootparamd, a server process which
18 provides the information needed by diskless clients in order for them
19 to successfully boot. Bootparamd looks first in /etc/bootparams for an
20 entry for that particular client; if a local bootparams file doesn't
21 exist, it looks at the appropriate Network Information Service (NIS)
22 map. Some network boot loaders (notably Sun's) rely on special boot
23 server code on the server, in addition to the rarp and tftp servers.
24 This bootparamd server process is compatible with SunOS bootparam
25 clients and servers which need that boot server code.
26
27 %prep
28 %setup -q -n netkit-bootparamd-%{version}
29 %patch -p1
30
31 %build
32 ./configure --with-c-compiler=%{__cc}
33 %{__make} CFLAGS="%{?debug:-O -g}%{!?debug:$RPM_OPT_FLAGS}"
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_mandir}/man8} \
38         $RPM_BUILD_ROOT/etc/rc.d/init.d
39
40 %{__make} install \
41         INSTALLROOT=$RPM_BUILD_ROOT \
42         MANDIR=%{_mandir}
43
44 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/bootparamd
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %post
50 /sbin/chkconfig --add bootparamd
51 if [ -f /var/lock/subsys/rpc.bootparamd ]; then
52         /etc/rc.d/init.d/bootparamd restart 1>&2
53 else
54         echo "Type \"/etc/rc.d/init.d/bootparamd start\" to start rpc.bootparamd server" 1>&2
55 fi
56
57 %postun
58 if [ "$1" = "0" ]; then
59         if [ -f /var/lock/subsys/rpc.bootparamd ]; then
60                 /etc/rc.d/init.d/bootparamd stop 1>&2
61         fi
62         /sbin/chkconfig --del bootparamd
63 fi
64
65 %files
66 %defattr(644,root,root,755)
67 %attr(754,root,root) /etc/rc.d/init.d/bootparamd
68 %attr(755,root,root) %{_sbindir}/rpc.bootparamd
69 %attr(755,root,root) %{_bindir}/callbootd
70 %{_mandir}/man[58]/*
This page took 0.033816 seconds and 3 git commands to generate.