]> git.pld-linux.org Git - packages/bootparamd.git/blob - bootparamd.spec
- finished updated to 0.17
[packages/bootparamd.git] / bootparamd.spec
1 Summary:        A server process which provides boot information to diskless clients
2 Name:           bootparamd
3 Version:        0.17
4 Release:        1
5 License:        BSD
6 Group:          Networking/Daemons
7 Group(pl):      Sieciowe/Serwery
8 Source0:        ftp://ftp.linux.org.uk/pub/linux/Networking/netkit/netkit-%{name}-%{version}.tar.gz
9 Source1:        bootparamd.init
10 Prereq:         /sbin/chkconfig
11 Requires:       portmap
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 The bootparamd process provides bootparamd, a server process which
16 provides the information needed by diskless clients in order for them
17 to successfully boot. Bootparamd looks first in /etc/bootparams for an
18 entry for that particular client; if a local bootparams file doesn't
19 exist, it looks at the appropriate Network Information Service (NIS)
20 map. Some network boot loaders (notably Sun's) rely on special boot
21 server code on the server, in addition to the rarp and tftp servers.
22 This bootparamd server process is compatible with SunOS bootparam
23 clients and servers which need that boot server code.
24
25 %prep
26 %setup -q -n netkit-bootparamd-%{version}
27
28 %build
29 ./configure --with-c-compiler=gcc
30 %{__make} CFLAGS="$RPM_OPT_FLAGS"
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_mandir}/man8} \
35         $RPM_BUILD_ROOT/etc/rc.d/init.d
36
37 %{__make} install \
38         INSTALLROOT=$RPM_BUILD_ROOT \
39         MANDIR=%{_mandir}
40
41 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/bootparamd
42
43 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man8/*
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %post
49 /sbin/chkconfig --add bootparamd
50 if [ -f /var/lock/subsys/rpc.bootparamd ]; then
51         /etc/rc.d/init.d/bootparamd restart 1>&2
52 else
53         echo "Type \"/etc/rc.d/init.d/bootparamd start\" to start rpc.bootparamd server" 1>&2
54 fi
55
56 %postun
57 if [ "$1" = "0" ]; then
58         if [ -f /var/lock/subsys/rpc.bootparamd ]; then
59                 /etc/rc.d/init.d/bootparamd stop 1>&2
60         fi
61         /sbin/chkconfig --del bootparamd
62 fi
63
64 %files
65 %defattr(644,root,root,755)
66 %attr(754,root,root) /etc/rc.d/init.d/bootparamd
67 %attr(755,root,root) %{_sbindir}/rpc.bootparamd
68 %attr(755,root,root) %{_bindir}/callbootd
69 %{_mandir}/man8/*
This page took 0.030091 seconds and 3 git commands to generate.