]> git.pld-linux.org Git - packages/bootil.git/commitdiff
- new master auto/th/bootil-0-0.20140109.1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 11 Jan 2014 20:45:45 +0000 (21:45 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 11 Jan 2014 20:45:45 +0000 (21:45 +0100)
bootil-includes.patch [new file with mode: 0644]
bootil.spec [new file with mode: 0644]

diff --git a/bootil-includes.patch b/bootil-includes.patch
new file mode 100644 (file)
index 0000000..856052c
--- /dev/null
@@ -0,0 +1,20 @@
+--- bootil/src/3rdParty/happyhttp/happyhttp.cpp.orig   2014-01-11 17:58:10.000000000 +0100
++++ bootil/src/3rdParty/happyhttp/happyhttp.cpp        2014-01-11 18:36:14.462546050 +0100
+@@ -34,6 +34,7 @@
+       #include <arpa/inet.h>
+       #include <netdb.h>      // for gethostbyname()
+       #include <errno.h>
++      #include <unistd.h>
+ #endif
+ #ifdef _WIN32
+--- bootil/src/Bootil/Network/Socket.cpp.orig  2014-01-11 17:58:10.000000000 +0100
++++ bootil/src/Bootil/Network/Socket.cpp       2014-01-11 18:50:46.302509462 +0100
+@@ -13,6 +13,7 @@
+       #include <sys/ioctl.h>
+       #include <arpa/inet.h>
+       #include <netdb.h>
++      #include <unistd.h>
+       #define ioctlsocket ioctl
+       #define closesocket close
+       #define WSAGetLastError() errno
diff --git a/bootil.spec b/bootil.spec
new file mode 100644 (file)
index 0000000..65f0eaa
--- /dev/null
@@ -0,0 +1,77 @@
+Summary:       Garry Newman's utility library
+Summary(pl.UTF-8):     Biblioteka narzędziowa Garry'ego Newmana
+Name:          bootil
+Version:       0
+%define        snap    20140109
+Release:       0.%{snap}.1
+# URL says: "My personal utility library, feel free to steal :)"
+License:       unknown (free)
+Group:         Libraries
+# git clone https://github.com/garrynewman/bootil
+# tar cJ --exclude=.git -f bootil.tar.xz
+Source0:       %{name}.tar.xz
+# Source0-md5: fcbf821466349cc3d91f362fea8bd9de
+Patch0:                %{name}-includes.patch
+URL:           https://github.com/garrynewman/bootil
+BuildRequires: libstdc++-devel
+BuildRequires: premake >= 4
+BuildRequires: sed >= 4.0
+BuildRequires: tar >= 1:1.22
+BuildRequires: xz
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Garry Newman's utility library.
+
+%description -l pl.UTF-8
+Biblioteka narzędziowa Garry'ego Newmana.
+
+%package devel
+Summary:       Header files for Bootil library
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki Bootil
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+Requires:      libstdc++-devel
+
+%description devel
+Header files for Bootil library.
+
+%description devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki Bootil.
+
+%prep
+%setup -q -n bootil
+%patch0 -p1
+
+%{__sed} -i -e 's/bootil_static/bootil/;s/StaticLib/SharedLib/' projects/bootil.lua
+
+%build
+cd projects
+premake4 gmake
+LDFLAGS="%{rpmldflags}" \
+%{__make} -C linux/gmake \
+       CC="%{__cc}" \
+       CXX="%{__cxx}" \
+       CFLAGS='%{rpmcflags} %{rpmcppflags} $(CPPFLAGS) $(ARCH) -ffast-math -fPIC' \
+       verbose=1
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_includedir}
+
+install -D lib/linux/gmake/libbootil.so $RPM_BUILD_ROOT%{_libdir}/libbootil.so
+cp -pr include/Bootil $RPM_BUILD_ROOT%{_includedir}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
+%files
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libbootil.so
+
+%files devel
+%defattr(644,root,root,755)
+%{_includedir}/Bootil
This page took 0.082303 seconds and 4 git commands to generate.