]> git.pld-linux.org Git - packages/bootchart.git/blobdiff - bootchart.spec
- use quotes in shell for the sake of clarity
[packages/bootchart.git] / bootchart.spec
index 34c8be9f520b700ff749e56e98953606257ca1fc..2df9323b8bc72e7bb535ec6779be7a831933044c 100644 (file)
@@ -21,7 +21,7 @@ Requires:     jpackage-utils >= 0:1.5
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define boottitle "Bootchart logging"
+%define                boottitle Bootchart logging
 
 %description
 A tool for performance analysis and visualization of the GNU/Linux
@@ -118,8 +118,8 @@ if [ -x /sbin/grubby ]; then
        init=$(echo "$info" |sed -n '/^args=.*init=/{s/^args=.*init=//;s/"$//;p;q;}')
        [ -n "$initrd" ] && initrd="--initrd=$initrd"
        [ -n "$init" ] && init="bootchart_init=$init"
-       /sbin/grubby --remove-kernel TITLE=%{boottitle}
-       /sbin/grubby --copy-default --add-kernel=$kernel $initrd --args="init=/sbin/bootchartd $init" --title=%{boottitle} || :
+       /sbin/grubby --remove-kernel TITLE='%{boottitle}'
+       /sbin/grubby --copy-default --add-kernel=$kernel $initrd --args="init=/sbin/bootchartd $init" --title='%{boottitle}' || :
 else
        %banner -e %{name}-logger <<-EOF
 You should adjust your bootloader to boot with
@@ -131,7 +131,7 @@ fi
 if [ "$1" = 0 ]; then
        # Remove the grub/lilo entry
        if [ -x /sbin/grubby ]; then
-               /sbin/grubby --remove-kernel TITLE=%{boottitle} || :
+               /sbin/grubby --remove-kernel TITLE='%{boottitle}' || :
        fi
 fi
 
This page took 0.093394 seconds and 4 git commands to generate.