]> git.pld-linux.org Git - packages/boost.git/commitdiff
- updated to 1.53.0 (note: new sonames, new libboost_atomic library) auto/th/boost-1.53.0-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 13 Apr 2013 10:50:19 +0000 (12:50 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 13 Apr 2013 10:50:19 +0000 (12:50 +0200)
- removed obsolete hash-enum patch

boost-hash-enum.patch [deleted file]
boost.spec

diff --git a/boost-hash-enum.patch b/boost-hash-enum.patch
deleted file mode 100644 (file)
index e00795f..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-$NetBSD: patch-boost_functional_hash_hash.hpp,v 1.1 2012/08/31 12:20:56 adam Exp $
-
-Allow hashing enums.
-
---- boost/functional/hash/hash.hpp.orig        2012-07-15 23:28:30.000000000 +0000
-+++ boost/functional/hash/hash.hpp
-@@ -15,6 +15,8 @@
- #include <boost/functional/hash/detail/hash_float.hpp>
- #include <string>
- #include <boost/limits.hpp>
-+#include <boost/type_traits/is_enum.hpp>
-+#include <boost/utility/enable_if.hpp>
- #if defined(BOOST_NO_TEMPLATE_PARTIAL_SPECIALIZATION)
- #include <boost/type_traits/is_pointer.hpp>
-@@ -90,6 +92,10 @@ namespace boost
-     template <typename T>
-     typename boost::hash_detail::ulong_numbers<T>::type hash_value(T);
-+    template <typename T>
-+    typename boost::enable_if<boost::is_enum<T>, std::size_t>::type
-+      hash_value(T);
-+
- #if !BOOST_WORKAROUND(__DMC__, <= 0x848)
-     template <class T> std::size_t hash_value(T* const&);
- #else
-@@ -179,6 +185,13 @@ namespace boost
-         return hash_detail::hash_value_unsigned(v);
-     }
-+    template <typename T>
-+    typename boost::enable_if<boost::is_enum<T>, std::size_t>::type
-+      hash_value(T v)
-+    {
-+      return static_cast<std::size_t>(v);
-+    }
-+
-     // Implementation by Alberto Barbati and Dave Harris.
- #if !BOOST_WORKAROUND(__DMC__, <= 0x848)
-     template <class T> std::size_t hash_value(T* const& v)
index 209006c1a97885a2d52ed1d4da64f8f6ac1d8a1f..1c4b443af59bbf561aafd14711a21b3dc7a41dfd 100644 (file)
 Summary:       The Boost C++ Libraries
 Summary(pl.UTF-8):     Biblioteki C++ "Boost"
 Name:          boost
-Version:       1.51.0
-Release:       6
+Version:       1.53.0
+Release:       1
 License:       Boost Software License and others
 Group:         Libraries
 Source0:       http://downloads.sourceforge.net/boost/%{name}_%{fver}.tar.bz2
-# Source0-md5: 4b6bd483b692fd138aef84ed2c8eb679
+# Source0-md5: a00d22605d5dbcfb4c9936a9b35bc4c2
 Patch0:                %{name}-link.patch
-Patch1:                %{name}-hash-enum.patch
 URL:           http://www.boost.org/
 BuildRequires: bzip2-devel
 BuildRequires: expat-devel
@@ -366,7 +365,6 @@ Dokumentacja dla biblioteki Boost C++.
 %prep
 %setup -q -n %{name}_%{fver}
 %patch0 -p1
-%patch1 -p0
 
 # - don't know how to pass it through (b)jam -s (no way?)
 #   due to oversophisticated build flags system.
@@ -508,6 +506,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libboost_atomic.so.*.*.*
 %attr(755,root,root) %{_libdir}/libboost_iostreams.so.*.*.*
 %attr(755,root,root) %{_libdir}/libboost_math_*.so.*.*.*
 %attr(755,root,root) %{_libdir}/libboost_random.so.*.*.*
@@ -516,6 +515,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libboost_atomic.so
 %attr(755,root,root) %{_libdir}/libboost_chrono.so
 %attr(755,root,root) %{_libdir}/libboost_context.so
 %attr(755,root,root) %{_libdir}/libboost_date_time.so
@@ -542,6 +542,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files static
 %defattr(644,root,root,755)
+%{_libdir}/libboost_atomic.a
 %{_libdir}/libboost_chrono.a
 %{_libdir}/libboost_context.a
 %{_libdir}/libboost_date_time.a
This page took 0.132266 seconds and 4 git commands to generate.