]> git.pld-linux.org Git - packages/boost.git/commitdiff
- rel 6; fix build auto/th/boost-1.63.0-6
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 1 Jul 2018 20:53:45 +0000 (22:53 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 1 Jul 2018 20:53:45 +0000 (22:53 +0200)
boost.spec
fix-python37.patch [new file with mode: 0644]

index 866eed418436fe88fd16f28f5d3d44ec4998a2e7..2cc9ee5c89445d7eb4d0741db933c590f3d86165 100644 (file)
@@ -13,7 +13,7 @@ Summary:      The Boost C++ Libraries
 Summary(pl.UTF-8):     Biblioteki C++ "Boost"
 Name:          boost
 Version:       1.63.0
-Release:       5
+Release:       6
 License:       Boost Software License and others
 Group:         Libraries
 Source0:       http://downloads.sourceforge.net/boost/%{name}_%{fver}.tar.bz2
@@ -23,6 +23,7 @@ Patch1:               %{name}-x32-context.patch
 Patch2:                %{name}-clean-gcc-flags.patch
 Patch3:                %{name}-numpy3.patch
 Patch4:                hash-new-char-types.patch
+Patch5:                fix-python37.patch
 # FC Patches:
 Patch201:      %{name}-python-abi_letters.patch
 # https://github.com/boostorg/build/issues/163
@@ -486,6 +487,7 @@ Dokumentacja dla biblioteki Boost C++.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 %patch201 -p1
 %patch202 -p1
diff --git a/fix-python37.patch b/fix-python37.patch
new file mode 100644 (file)
index 0000000..da1c93e
--- /dev/null
@@ -0,0 +1,18 @@
+From: Giovanni Mascellani <gio@debian.org>
+Subject: Fix FTBFS with Python 3.7
+
+The patch is backported from later Boost releases.
+
+Index: boost1.62-1.62.0+dfsg/libs/python/src/converter/builtin_converters.cpp
+===================================================================
+--- boost1.62-1.62.0+dfsg.orig/libs/python/src/converter/builtin_converters.cpp
++++ boost1.62-1.62.0+dfsg/libs/python/src/converter/builtin_converters.cpp
+@@ -48,7 +48,7 @@ namespace
+ #else
+   void* convert_to_cstring(PyObject* obj)
+   {
+-      return PyUnicode_Check(obj) ? _PyUnicode_AsString(obj) : 0;
++      return PyUnicode_Check(obj) ? const_cast<void*>(reinterpret_cast<const void*>(_PyUnicode_AsString(obj))) : 0;
+   }
+ #endif
This page took 0.109597 seconds and 4 git commands to generate.