]> git.pld-linux.org Git - packages/bochs.git/blobdiff - bochs.spec
- now we have svgalib on all supported archs
[packages/bochs.git] / bochs.spec
index 86cac3ac0310caf04b4f6acae6a7aacf85308a1a..b34982e1cb9c5d46da1df18001852b8a26b76688 100644 (file)
@@ -1,14 +1,32 @@
+# TODO:
+#      - more subpackages (plugins)
+#
+# Conditional build:
+%bcond_without  svga    # without svgalib support
+#
 Summary:       Portable x86 PC Emulator
 Summary(pl):   Przeno¶ny emulator x86 PC
 Name:          bochs
-Version:       1.2.1
-Release:       1
+Version:       2.1.1
+Release:       2
 License:       GPL
 Group:         Applications/Emulators
-Source0:       http://prdownloads.sourceforge.net/bochs/%{name}-%{version}.tar.gz
+Source0:       http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
+# Source0-md5: 7b21efbe2b56cc15d110993234259b33
+Patch0:                %{name}-ncurses.patch
 URL:           http://bochs.sourceforge.net/
+BuildRequires: SDL-devel
 BuildRequires: XFree86-devel
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: docbook-dtd41-sgml
+BuildRequires: gtk+-devel
 BuildRequires: libstdc++-devel
+BuildRequires: ncurses-devel
+%{?with_svga:BuildRequires:    svgalib-devel}
+BuildRequires: wxGTK2-devel
+BuildRequires: zlib-devel
+Requires:      XFree86-fonts
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -19,66 +37,95 @@ Windows '95, Minix 2.0, and other OS's, all on your workstation.
 %description -l pl
 Bochs jest przeno¶nym emulatorem x86 PC emuluj±cym wystarczaj±co du¿o
 architektury procesora x86 oraz hardware'u AT i BIOS-u ¿eby uruchomiæ
-DOS-a, Windows'95, Minix 2.0 i inne systemu operacyjne, wszystkie na
+DOS-a, Windows 95, Minix 2.0 i inne systemu operacyjne, wszystkie na
 Twoim komputerze.
 
 %prep
 %setup -q
+%patch0        -p1
 
 %build
-%configure2_13 \
-       --with-x \
-       --enable-cpu-level=5 \
-       --enable-vga \
+cp -f /usr/share/automake/config.sub .
+%{__autoconf}
+# --enable-x86-64 (not supported together with --enable-sep)
+# --enable-debugger --enable-iodebug --enable-x86-debugger (slowdowns emulation)
+# --enable-apic (no need to specify, configure will choose best depending on nr cpus)
+%configure \
+       WX_CONFIG=wxgtk2-2.4-config \
+       --enable-config-interface \
+       --enable-new-pit \
+       --enable-plugins \
+       --enable-cpu-level=6 \
+       --enable-compressed-hd \
+       --enable-ne2000 \
+       --enable-pci \
+       --enable-usb \
+       --enable-4meg-pages \
+       --enable-pae \
+       --enable-guest2host-tlb \
+       --enable-repeat-speedups \
+       --enable-icache \
+%ifarch %{ix86}
+       --enable-fast-function-calls \
+%endif
+       --enable-global-pages \
+       --enable-host-specific-asms \
+       --enable-ignore-bad-msr \
+       --enable-disasm \
+       --enable-all-optimizations \
+       --enable-readline \
+       --enable-instrumentation \
+       --enable-vbe \
        --enable-fpu \
+       --enable-mmx \
+       --enable-3dnow \
+       --enable-sse=2 \
+       --enable-sep \
        --enable-cdrom \
-       --with-x11
+       --enable-sb16=linux \
+       --enable-gameport \
+       --with-x \
+       --with-wx \
+       --with-rfb \
+       --with-sdl \
+       %{?with_svga:-with-svga} \
+       --with-x11 \
+       --with-term \
+       --with-rfb
+
 %{__make}
-cd font
-#for i in vga.bdf hercules.bdf; 
-#do
-#      bdftopcf $i -o `basename $i .bdf`.pcf
-#done;
-# vga.pcf has moved to XFree86-fonts
-bdftopcf hercules.bdf -o hercules.pcf
-cd ..
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-install -d $RPM_BUILD_ROOT/{%{_bindir},%{_datadir}/bochs/bios,%{_datadir}/fonts/misc,%{_datadir}/man/man1}
-install bochs install-x11-fonts bximage $RPM_BUILD_ROOT/%{_bindir}
-install bios/BIOS-bochs-latest* bios/VGABIOS-elpin-2.40 $RPM_BUILD_ROOT%{_datadir}/bochs/bios
-install doc/man/* $RPM_BUILD_ROOT%{_datadir}/man/man1
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT \
+       docdir=%{_docdir}/%{name}-%{version}
 
-mv -f .bochsrc .brc
-echo "Example .bochrc file - put it into selected directory and modify" \
-     "path to images" >.bochsrc
-sed -e 's#bios#%{_datadir}/bochs/bios#g' <.brc >>.bochsrc
+mv -f $RPM_BUILD_ROOT%{_datadir}/bochs/VGABIOS*{LICENSE,README,latest} \
+    $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
 
-gzip -9nf docs-html/* bios/VGABIOS-elpin-LICENSE .bochsrc font/*.pcf CHANGES TESTFORM.txt
+cp -f TESTFORM.txt $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
 
-install font/*.pcf* $RPM_BUILD_ROOT%{_datadir}/fonts/misc
+#rm -f $RPM_BUILD_ROOT%{_datadir}/bochs/*fonts
+#rm -f $RPM_BUILD_ROOT%{_datadir}/bochs/*pcf
+
+#find $RPM_BUILD_ROOT -type d -name CVS | xargs rm -rf
 
 %clean
 rm -rf $RPM_BUILD_ROOT
-%post
-if [ -x /usr/X11R6/bin/mkfontdir ]; then
-        (cd /usr/share/fonts/misc; /usr/X11R6/bin/mkfontdir)
-fi
-killall -USR1 xfs > /dev/null 2>&1 ||:
-
-%postun
-if [ -x /usr/X11R6/bin/mkfontdir ]; then
-        (cd /usr/share/fonts/misc; /usr/X11R6/bin/mkfontdir)
-fi
-killall -USR1 xfs > /dev/null 2>&1 ||:
 
 %files
 %defattr(644,root,root,755)
-%doc docs-html/* bios/VGABIOS-elpin-LICENSE* .bochsrc* *.gz
 %attr(755,root,root) %{_bindir}/*
-%dir %{_datadir}/bochs
-%{_datadir}/bochs/*
-%{_datadir}/fonts/misc/*.pcf*
-%{_datadir}/man/man1/*
+%dir %{_libdir}/%{name}
+%dir %{_libdir}/%{name}/plugins
+%attr(755,root,root) %{_libdir}/%{name}/plugins/*.so.*
+%{_libdir}/%{name}/plugins/*.la
+%dir %{_datadir}/%{name}
+%dir %{_datadir}/%{name}/keymaps
+%attr(755,root,root) %{_datadir}/%{name}/keymaps/convertmap.pl
+%{_datadir}/%{name}/keymaps/*.map
+%{_datadir}/%{name}/*BIOS*
+%{_mandir}/man[15]/*
+%{_docdir}/%{name}-%{version}
This page took 0.060209 seconds and 4 git commands to generate.