]> git.pld-linux.org Git - packages/bochs.git/blob - bochs.spec
- copy config.sub, mayby it works on amd64... who know... release 1.1
[packages/bochs.git] / bochs.spec
1 # TODO:
2 #       - more subpackages (plugins)
3
4 # Conditional build:
5 %bcond_without  svga    # without svgalib support
6 #
7 %ifnarch %{ix86} alpha
8 %undefine with_svga
9 %endif
10 Summary:        Portable x86 PC Emulator
11 Summary(pl):    Przeno¶ny emulator x86 PC
12 Name:           bochs
13 Version:        2.1.1
14 Release:        1.1
15 License:        GPL
16 Group:          Applications/Emulators
17 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
18 # Source0-md5:  7b21efbe2b56cc15d110993234259b33
19 Patch0:         %{name}-ncurses.patch
20 URL:            http://bochs.sourceforge.net/
21 BuildRequires:  SDL-devel
22 BuildRequires:  XFree86-devel
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  docbook-dtd41-sgml
26 BuildRequires:  gtk+-devel
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  ncurses-devel
29 %{?with_svga:BuildRequires:     svgalib-devel}
30 BuildRequires:  wxGTK2-devel
31 BuildRequires:  zlib-devel
32 Requires:       XFree86-fonts
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Bochs is a portable x86 PC emulation software package that emulates
37 enough of the x86 CPU, related AT hardware, and BIOS to run DOS,
38 Windows '95, Minix 2.0, and other OS's, all on your workstation.
39
40 %description -l pl
41 Bochs jest przeno¶nym emulatorem x86 PC emuluj±cym wystarczaj±co du¿o
42 architektury procesora x86 oraz hardware'u AT i BIOS-u ¿eby uruchomiæ
43 DOS-a, Windows 95, Minix 2.0 i inne systemu operacyjne, wszystkie na
44 Twoim komputerze.
45
46 %prep
47 %setup -q
48 %patch0 -p1
49
50 %build
51 cp -f /usr/share/automake/config.sub .
52 %{__autoconf}
53 # --enable-x86-64 (not supported together with --enable-sep)
54 # --enable-debugger --enable-iodebug --enable-x86-debugger (slowdowns emulation)
55 # --enable-apic (no need to specify, configure will choose best depending on nr cpus)
56 %configure \
57         WX_CONFIG=wxgtk2-2.4-config \
58         --enable-config-interface \
59         --enable-new-pit \
60         --enable-plugins \
61         --enable-cpu-level=6 \
62         --enable-compressed-hd \
63         --enable-ne2000 \
64         --enable-pci \
65         --enable-usb \
66         --enable-4meg-pages \
67         --enable-pae \
68         --enable-guest2host-tlb \
69         --enable-repeat-speedups \
70         --enable-icache \
71 %ifarch %{ix86}
72         --enable-fast-function-calls \
73 %endif
74         --enable-global-pages \
75         --enable-host-specific-asms \
76         --enable-ignore-bad-msr \
77         --enable-disasm \
78         --enable-all-optimizations \
79         --enable-readline \
80         --enable-instrumentation \
81         --enable-vbe \
82         --enable-fpu \
83         --enable-mmx \
84         --enable-3dnow \
85         --enable-sse=2 \
86         --enable-sep \
87         --enable-cdrom \
88         --enable-sb16=linux \
89         --enable-gameport \
90         --with-x \
91         --with-wx \
92         --with-rfb \
93         --with-sdl \
94         %{?with_svga:-with-svga} \
95         --with-x11 \
96         --with-term \
97         --with-rfb
98
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT \
106         docdir=%{_docdir}/%{name}-%{version}
107
108 mv -f $RPM_BUILD_ROOT%{_datadir}/bochs/VGABIOS*{LICENSE,README,latest} \
109     $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
110
111 cp -f TESTFORM.txt $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
112
113 #rm -f $RPM_BUILD_ROOT%{_datadir}/bochs/*fonts
114 #rm -f $RPM_BUILD_ROOT%{_datadir}/bochs/*pcf
115
116 #find $RPM_BUILD_ROOT -type d -name CVS | xargs rm -rf
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %files
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_bindir}/*
124 %dir %{_libdir}/%{name}
125 %dir %{_libdir}/%{name}/plugins
126 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so.*
127 %{_libdir}/%{name}/plugins/*.la
128 %dir %{_datadir}/%{name}
129 %dir %{_datadir}/%{name}/keymaps
130 %attr(755,root,root) %{_datadir}/%{name}/keymaps/convertmap.pl
131 %{_datadir}/%{name}/keymaps/*.map
132 %{_datadir}/%{name}/*BIOS*
133 %{_mandir}/man[15]/*
134 %{_docdir}/%{name}-%{version}
This page took 0.070134 seconds and 4 git commands to generate.