]> git.pld-linux.org Git - packages/bochs.git/blob - bochs.spec
-typo
[packages/bochs.git] / bochs.spec
1 Summary:        Portable x86 PC Emulator
2 Summary(pl):    Przeno¶ny emulator x86 PC
3 Name:           bochs
4 Version:        1.1.2
5 Release:        1
6 License:        GPL
7 Group:          Applications/Emulators
8 Group(de):      Applikationen/Emulators
9 Group(pl):      Aplikacje/Emulatory
10 Source0:        ftp://bochs.com/pub/%{name}-%{version}.tar.gz
11 URL:            http://www.bochs.com/
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 Bochs is a portable x86 PC emulation software package that emulates
16 enough of the x86 CPU, related AT hardware, and BIOS to run DOS,
17 Windows '95, Minix 2.0, and other OS's, all on your workstation.
18
19 %description -l pl
20 Bochs jest przeno¶nym emulatorem x86 PC emuluj±cym wystarczaj±co du¿o
21 architektóry procesora x86 oraz hardwaru AT i BIOS-u ¿eby uruchomiæ
22 DOS-a, windows'95, Minix 2.0 i inne systemu operacyjne, wszystkie na
23 twoim komputerze.
24
25 %prep
26 %setup -q
27
28 %build
29 %configure \
30         --with-x \
31         --enable-cpu-level=5 \
32         --enable-vga \
33         --enable-fpu \
34         --enable-cdrom \
35         --with-x11
36 %{__make}
37 cd font
38 for i in vga.bdf hercules.bdf; 
39 do
40         bdftopcf $i -o `basename $i .bdf`.pcf
41 done;
42 cd ..
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 install -d $RPM_BUILD_ROOT/{%{_bindir},%{_datadir}/bochs/bios,%{_datadir}/fonts/misc}
48 install bochs $RPM_BUILD_ROOT/%{_bindir}
49 install bios/BIOS-bochs-990925a bios/VGABIOS-elpin-2.40 $RPM_BUILD_ROOT%{_datadir}/bochs/bios
50 mv -f .bochsrc .brc
51 echo "Example .bochrc file - put it into selected directory and modify" \
52      "path to images" >.bochsrc
53 sed -e 's#bios#%{_datadir}/bochs/bios#g' <.brc >>.bochsrc
54 gzip -9nf docs-html/* bios/VGABIOS-elpin-LICENSE .bochsrc font/*.pcf
55 install font/*.pcf* $RPM_BUILD_ROOT%{_datadir}/fonts/misc
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59 %post
60 if [ -x /usr/X11R6/bin/mkfontdir ]; then
61         (cd /usr/share/fonts/misc; /usr/X11R6/bin/mkfontdir)
62 fi
63 killall -USR1 xfs > /dev/null 2>&1 ||:
64
65 %postun
66 if [ -x /usr/X11R6/bin/mkfontdir ]; then
67         (cd /usr/share/fonts/misc; /usr/X11R6/bin/mkfontdir)
68 fi
69 killall -USR1 xfs > /dev/null 2>&1 ||:
70
71 %files
72 %defattr(644,root,root,755)
73 %doc docs-html/* bios/VGABIOS-elpin-LICENSE* .bochsrc*
74 %attr(755,root,root) %{_bindir}/bochs
75 %dir %{_datadir}/bochs
76 %{_datadir}/bochs/*
77 %{_datadir}/fonts/misc/*.pcf*
This page took 0.040832 seconds and 4 git commands to generate.