]> git.pld-linux.org Git - packages/bochs.git/blob - bochs.spec
fbccfa894050b306a6db42a096fb9d19d218c688
[packages/bochs.git] / bochs.spec
1 # TODO:
2 #       - more subpackages (plugins)
3 #
4 # Conditional build:
5 %bcond_without  svga    # without svgalib support
6 #
7 Summary:        Portable x86 PC Emulator
8 Summary(pl):    Przeno¶ny emulator x86 PC
9 Name:           bochs
10 Version:        2.1.1
11 Release:        3
12 License:        GPL
13 Group:          Applications/Emulators
14 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
15 # Source0-md5:  7b21efbe2b56cc15d110993234259b33
16 Patch0:         %{name}-ncurses.patch
17 URL:            http://bochs.sourceforge.net/
18 BuildRequires:  SDL-devel
19 BuildRequires:  XFree86-devel
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  docbook-dtd41-sgml
23 BuildRequires:  gtk+-devel
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  ncurses-devel
26 %{?with_svga:BuildRequires:     svgalib-devel}
27 BuildRequires:  wxGTK2-devel
28 BuildRequires:  zlib-devel
29 Requires:       XFree86-fonts
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Bochs is a portable x86 PC emulation software package that emulates
34 enough of the x86 CPU, related AT hardware, and BIOS to run DOS,
35 Windows '95, Minix 2.0, and other OS's, all on your workstation.
36
37 %description -l pl
38 Bochs jest przeno¶nym emulatorem x86 PC emuluj±cym wystarczaj±co du¿o
39 architektury procesora x86 oraz hardware'u AT i BIOS-u ¿eby uruchomiæ
40 DOS-a, Windows 95, Minix 2.0 i inne systemy operacyjne, wszystkie na
41 Twoim komputerze.
42
43 %prep
44 %setup -q
45 %patch0 -p1
46
47 %build
48 cp -f /usr/share/automake/config.sub .
49 %{__autoconf}
50 # --enable-x86-64 (not supported together with --enable-sep)
51 # --enable-debugger --enable-iodebug --enable-x86-debugger (slowdowns emulation)
52 # --enable-apic (no need to specify, configure will choose best depending on nr cpus)
53 %configure \
54         WX_CONFIG=wxgtk2-2.4-config \
55         --enable-config-interface \
56         --enable-new-pit \
57         --enable-plugins \
58         --enable-cpu-level=6 \
59         --enable-compressed-hd \
60         --enable-ne2000 \
61         --enable-pci \
62         --enable-usb \
63         --enable-4meg-pages \
64         --enable-pae \
65         --enable-guest2host-tlb \
66         --enable-repeat-speedups \
67         --enable-icache \
68 %ifarch %{ix86}
69         --enable-fast-function-calls \
70 %endif
71         --enable-global-pages \
72         --enable-host-specific-asms \
73         --enable-ignore-bad-msr \
74         --enable-disasm \
75         --enable-all-optimizations \
76         --enable-readline \
77         --enable-instrumentation \
78         --enable-vbe \
79         --enable-fpu \
80         --enable-mmx \
81         --enable-3dnow \
82         --enable-sse=2 \
83         --enable-sep \
84         --enable-cdrom \
85         --enable-sb16=linux \
86         --enable-gameport \
87         --with-x \
88         --with-wx \
89         --with-rfb \
90         --with-sdl \
91         %{?with_svga:-with-svga} \
92         --with-x11 \
93         --with-term \
94         --with-rfb
95
96 %{__make}
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT \
103         docdir=%{_docdir}/%{name}-%{version}
104
105 mv -f $RPM_BUILD_ROOT%{_datadir}/bochs/VGABIOS*{LICENSE,README,latest} \
106         $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
107
108 cp -f TESTFORM.txt $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
109
110 #rm -f $RPM_BUILD_ROOT%{_datadir}/bochs/*fonts
111 #rm -f $RPM_BUILD_ROOT%{_datadir}/bochs/*pcf
112
113 #find $RPM_BUILD_ROOT -type d -name CVS | xargs rm -rf
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %files
119 %defattr(644,root,root,755)
120 %attr(755,root,root) %{_bindir}/*
121 %dir %{_libdir}/%{name}
122 %dir %{_libdir}/%{name}/plugins
123 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so.*
124 %{_libdir}/%{name}/plugins/*.la
125 %dir %{_datadir}/%{name}
126 %dir %{_datadir}/%{name}/keymaps
127 %attr(755,root,root) %{_datadir}/%{name}/keymaps/convertmap.pl
128 %{_datadir}/%{name}/keymaps/*.map
129 %{_datadir}/%{name}/*BIOS*
130 %{_mandir}/man[15]/*
131 %{_docdir}/%{name}-%{version}
This page took 0.072927 seconds and 2 git commands to generate.