]> git.pld-linux.org Git - packages/bochs.git/blob - bochs.spec
- updated to 2.1.1
[packages/bochs.git] / bochs.spec
1 # TODO:
2 #       - more subpackages (plugins)
3 #
4 # Conditional build:
5 %bcond_without  svga    # without svgalib support
6 #
7 Summary:        Portable x86 PC Emulator
8 Summary(pl):    Przeno¶ny emulator x86 PC
9 Name:           bochs
10 Version:        2.2.1
11 Release:        1
12 License:        GPL
13 Group:          Applications/Emulators
14 Source0:        http://dl.sourceforge.net/bochs/%{name}-%{version}.tar.gz
15 # Source0-md5:  50484c75d8175fcd97a81432ac18fb71
16 Patch0:         %{name}-instrumentation.patch
17 URL:            http://bochs.sourceforge.net/
18 BuildRequires:  SDL-devel
19 BuildRequires:  XFree86-devel
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  docbook-dtd41-sgml
23 BuildRequires:  gtk+2-devel
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  ncurses-devel
26 %{?with_svga:BuildRequires:     svgalib-devel}
27 BuildRequires:  wxGTK2-devel
28 BuildRequires:  zlib-devel
29 BuildRequires:  pkgconfig
30 Requires:       XFree86-fonts
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Bochs is a portable x86 PC emulation software package that emulates
35 enough of the x86 CPU, related AT hardware, and BIOS to run DOS,
36 Windows '95, Minix 2.0, and other OS's, all on your workstation.
37
38 %description -l pl
39 Bochs jest przeno¶nym emulatorem x86 PC emuluj±cym wystarczaj±co du¿o
40 architektury procesora x86 oraz hardware'u AT i BIOS-u ¿eby uruchomiæ
41 DOS-a, Windows 95, Minix 2.0 i inne systemy operacyjne, wszystkie na
42 Twoim komputerze.
43
44 %prep
45 %setup -q
46 %patch0 -p1
47
48 %build
49 cp -f /usr/share/automake/config.sub .
50 %{__autoconf}
51 CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses `pkg-config gdk-2.0 --cflags`"
52 LDFLAGS=`pkg-config gdk-2.0 --libs`
53 export CXXFLAGS LDFLAGS
54 # --enable-x86-64 (not supported together with --enable-sep)
55 # --enable-debugger --enable-iodebug --enable-x86-debugger (slowdowns emulation)
56 # --enable-apic (no need to specify, configure will choose best depending on nr cpus)
57
58 WXGTK2CONFIG=""
59 [ -x /usr/bin/wx-gtk2-ansi-config ] && WXGTK2CONFIG=wx-gtk2-ansi-config
60 [ -x /usr/bin/wxgtk-2.4-config ] && WXGTK2CONFIG=wxgtk-2.4-config
61
62 [ "x$WXGTK2CONFIG" == "x" ] && echo "Can't find wxGTK2 config file!" && exit 1
63
64 %configure \
65         WX_CONFIG=$WXGTK2CONFIG \
66         --enable-config-interface \
67         --enable-new-pit \
68         --enable-plugins \
69         --enable-cpu-level=6 \
70         --enable-compressed-hd \
71         --enable-ne2000 \
72         --enable-pci \
73         --enable-usb \
74         --enable-4meg-pages \
75         --enable-pae \
76         --enable-guest2host-tlb \
77         --enable-repeat-speedups \
78         --enable-icache \
79 %ifarch %{ix86}
80         --enable-fast-function-calls \
81 %endif
82         --enable-global-pages \
83         --enable-host-specific-asms \
84         --enable-ignore-bad-msr \
85         --enable-disasm \
86         --enable-all-optimizations \
87         --enable-readline \
88         --enable-instrumentation \
89         --enable-vbe \
90         --enable-fpu \
91         --enable-mmx \
92         --enable-3dnow \
93         --enable-sse=2 \
94         --enable-sep \
95         --enable-cdrom \
96         --enable-sb16=linux \
97         --enable-gameport \
98         --with-x \
99         --with-wx \
100         --with-rfb \
101         --with-sdl \
102         %{?with_svga:-with-svga} \
103         --with-x11 \
104         --with-term \
105         --with-rfb
106
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT \
114         docdir=%{_docdir}/%{name}-%{version}
115
116 mv -f $RPM_BUILD_ROOT%{_datadir}/bochs/VGABIOS*{LICENSE,README,latest} \
117         $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
118
119 cp -f TESTFORM.txt $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
120
121 #rm -f $RPM_BUILD_ROOT%{_datadir}/bochs/*fonts
122 #rm -f $RPM_BUILD_ROOT%{_datadir}/bochs/*pcf
123
124 #find $RPM_BUILD_ROOT -type d -name CVS | xargs rm -rf
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %files
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_bindir}/*
132 %dir %{_libdir}/%{name}
133 %dir %{_libdir}/%{name}/plugins
134 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so.*
135 %{_libdir}/%{name}/plugins/*.la
136 %dir %{_datadir}/%{name}
137 %dir %{_datadir}/%{name}/keymaps
138 %{_datadir}/%{name}/keymaps/*.map
139 %{_datadir}/%{name}/*BIOS*
140 %{_mandir}/man[15]/*
141 %{_docdir}/%{name}-%{version}
This page took 0.063841 seconds and 3 git commands to generate.