]> git.pld-linux.org Git - packages/bochs.git/blob - bochs.spec
- don't put VGABIOS-lgpl image to docs, but to %%{_datadir}/bochs
[packages/bochs.git] / bochs.spec
1 # TODO:
2 #       - more subpackages (plugins)
3 #
4 # Conditional build:
5 %bcond_without  svga    # without svgalib support
6 #
7 Summary:        Portable x86 PC Emulator
8 Summary(pl):    Przeno¶ny emulator x86 PC
9 Name:           bochs
10 Version:        2.2.1
11 Release:        1
12 License:        GPL
13 Group:          Applications/Emulators
14 Source0:        http://dl.sourceforge.net/bochs/%{name}-%{version}.tar.gz
15 # Source0-md5:  50484c75d8175fcd97a81432ac18fb71
16 URL:            http://bochs.sourceforge.net/
17 BuildRequires:  SDL-devel
18 BuildRequires:  XFree86-devel
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  docbook-dtd41-sgml
22 BuildRequires:  gtk+2-devel
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  ncurses-devel
25 %{?with_svga:BuildRequires:     svgalib-devel}
26 BuildRequires:  wxGTK2-devel
27 BuildRequires:  zlib-devel
28 BuildRequires:  pkgconfig
29 Requires:       XFree86-fonts
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Bochs is a portable x86 PC emulation software package that emulates
34 enough of the x86 CPU, related AT hardware, and BIOS to run DOS,
35 Windows '95, Minix 2.0, and other OS's, all on your workstation.
36
37 %description -l pl
38 Bochs jest przeno¶nym emulatorem x86 PC emuluj±cym wystarczaj±co du¿o
39 architektury procesora x86 oraz hardware'u AT i BIOS-u ¿eby uruchomiæ
40 DOS-a, Windows 95, Minix 2.0 i inne systemy operacyjne, wszystkie na
41 Twoim komputerze.
42
43 %prep
44 %setup -q
45
46 %build
47 cp -f /usr/share/automake/config.sub .
48 %{__autoconf}
49 CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses `pkg-config gdk-2.0 --cflags`"
50 LDFLAGS=`pkg-config gdk-2.0 --libs`
51 export CXXFLAGS LDFLAGS
52 # --enable-x86-64 (not supported together with --enable-sep)
53 # --enable-debugger --enable-iodebug --enable-x86-debugger (slowdowns emulation)
54 # --enable-apic (no need to specify, configure will choose best depending on nr cpus)
55
56 WXGTK2CONFIG=""
57 [ -x /usr/bin/wx-gtk2-ansi-config ] && WXGTK2CONFIG=wx-gtk2-ansi-config
58 [ -x /usr/bin/wxgtk-2.4-config ] && WXGTK2CONFIG=wxgtk-2.4-config
59
60 [ "x$WXGTK2CONFIG" == "x" ] && echo "Can't find wxGTK2 config file!" && exit 1
61
62 %configure \
63         WX_CONFIG=$WXGTK2CONFIG \
64         --enable-config-interface \
65         --enable-new-pit \
66         --enable-plugins \
67         --enable-cpu-level=6 \
68         --enable-compressed-hd \
69         --enable-ne2000 \
70         --enable-pci \
71         --enable-usb \
72         --enable-4meg-pages \
73         --enable-pae \
74         --enable-guest2host-tlb \
75         --enable-repeat-speedups \
76         --enable-icache \
77 %ifarch %{ix86}
78         --enable-fast-function-calls \
79 %endif
80         --enable-global-pages \
81         --enable-host-specific-asms \
82         --enable-ignore-bad-msr \
83         --enable-disasm \
84         --enable-all-optimizations \
85         --enable-readline \
86         --enable-instrumentation \
87         --enable-vbe \
88         --enable-fpu \
89         --enable-mmx \
90         --enable-3dnow \
91         --enable-sse=2 \
92         --enable-sep \
93         --enable-cdrom \
94         --enable-sb16=linux \
95         --enable-gameport \
96         --with-x \
97         --with-wx \
98         --with-rfb \
99         --with-sdl \
100         %{?with_svga:-with-svga} \
101         --with-x11 \
102         --with-term \
103         --with-rfb
104
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT \
112         docdir=%{_docdir}/%{name}-%{version}
113
114 mv -f $RPM_BUILD_ROOT%{_datadir}/bochs/VGABIOS*{LICENSE,README} \
115         $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
116
117 cp -f TESTFORM.txt $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
118
119 #rm -f $RPM_BUILD_ROOT%{_datadir}/bochs/*fonts
120 #rm -f $RPM_BUILD_ROOT%{_datadir}/bochs/*pcf
121
122 #find $RPM_BUILD_ROOT -type d -name CVS | xargs rm -rf
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %files
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_bindir}/*
130 %dir %{_libdir}/%{name}
131 %dir %{_libdir}/%{name}/plugins
132 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so.*
133 %{_libdir}/%{name}/plugins/*.la
134 %dir %{_datadir}/%{name}
135 %dir %{_datadir}/%{name}/keymaps
136 %{_datadir}/%{name}/keymaps/*.map
137 %{_datadir}/%{name}/*BIOS*
138 %{_mandir}/man[15]/*
139 %{_docdir}/%{name}-%{version}
This page took 0.03112 seconds and 3 git commands to generate.