]> git.pld-linux.org Git - packages/bochs.git/blob - bochs.spec
d6c862dc5cb07d14d7b8abf322cdde6724d7ab93
[packages/bochs.git] / bochs.spec
1 # TODO:
2 #       - more subpackages (plugins)
3 #
4 # Conditional build:
5 %bcond_without  svga    # without svgalib support
6 #
7 Summary:        Portable x86 PC Emulator
8 Summary(pl):    Przeno¶ny emulator x86 PC
9 Name:           bochs
10 Version:        2.2
11 Release:        1
12 License:        GPL
13 Group:          Applications/Emulators
14 Source0:        http://dl.sourceforge.net/bochs/%{name}-%{version}.tar.gz
15 # Source0-md5:  2f0d82bda2193242a2d7ece1917016c1
16 Patch0:         %{name}-instrumentation.patch
17 URL:            http://bochs.sourceforge.net/
18 BuildRequires:  SDL-devel
19 BuildRequires:  XFree86-devel
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  docbook-dtd41-sgml
23 BuildRequires:  gtk+-devel
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  ncurses-devel
26 %{?with_svga:BuildRequires:     svgalib-devel}
27 BuildRequires:  wxGTK2-devel
28 BuildRequires:  zlib-devel
29 Requires:       XFree86-fonts
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Bochs is a portable x86 PC emulation software package that emulates
34 enough of the x86 CPU, related AT hardware, and BIOS to run DOS,
35 Windows '95, Minix 2.0, and other OS's, all on your workstation.
36
37 %description -l pl
38 Bochs jest przeno¶nym emulatorem x86 PC emuluj±cym wystarczaj±co du¿o
39 architektury procesora x86 oraz hardware'u AT i BIOS-u ¿eby uruchomiæ
40 DOS-a, Windows 95, Minix 2.0 i inne systemy operacyjne, wszystkie na
41 Twoim komputerze.
42
43 %prep
44 %setup -q
45 %patch0 -p1
46
47 %build
48 cp -f /usr/share/automake/config.sub .
49 %{__autoconf}
50 CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
51 export CXXFLAGS
52 # --enable-x86-64 (not supported together with --enable-sep)
53 # --enable-debugger --enable-iodebug --enable-x86-debugger (slowdowns emulation)
54 # --enable-apic (no need to specify, configure will choose best depending on nr cpus)
55 %configure \
56         WX_CONFIG=wxgtk2-2.4-config \
57         --enable-config-interface \
58         --enable-new-pit \
59         --enable-plugins \
60         --enable-cpu-level=6 \
61         --enable-compressed-hd \
62         --enable-ne2000 \
63         --enable-pci \
64         --enable-usb \
65         --enable-4meg-pages \
66         --enable-pae \
67         --enable-guest2host-tlb \
68         --enable-repeat-speedups \
69         --enable-icache \
70 %ifarch %{ix86}
71         --enable-fast-function-calls \
72 %endif
73         --enable-global-pages \
74         --enable-host-specific-asms \
75         --enable-ignore-bad-msr \
76         --enable-disasm \
77         --enable-all-optimizations \
78         --enable-readline \
79         --enable-instrumentation \
80         --enable-vbe \
81         --enable-fpu \
82         --enable-mmx \
83         --enable-3dnow \
84         --enable-sse=2 \
85         --enable-sep \
86         --enable-cdrom \
87         --enable-sb16=linux \
88         --enable-gameport \
89         --with-x \
90         --with-wx \
91         --with-rfb \
92         --with-sdl \
93         %{?with_svga:-with-svga} \
94         --with-x11 \
95         --with-term \
96         --with-rfb
97
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT \
105         docdir=%{_docdir}/%{name}-%{version}
106
107 mv -f $RPM_BUILD_ROOT%{_datadir}/bochs/VGABIOS*{LICENSE,README,latest} \
108         $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
109
110 cp -f TESTFORM.txt $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
111
112 #rm -f $RPM_BUILD_ROOT%{_datadir}/bochs/*fonts
113 #rm -f $RPM_BUILD_ROOT%{_datadir}/bochs/*pcf
114
115 #find $RPM_BUILD_ROOT -type d -name CVS | xargs rm -rf
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %files
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_bindir}/*
123 %dir %{_libdir}/%{name}
124 %dir %{_libdir}/%{name}/plugins
125 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so.*
126 %{_libdir}/%{name}/plugins/*.la
127 %dir %{_datadir}/%{name}
128 %dir %{_datadir}/%{name}/keymaps
129 %{_datadir}/%{name}/keymaps/*.map
130 %{_datadir}/%{name}/*BIOS*
131 %{_mandir}/man[15]/*
132 %{_docdir}/%{name}-%{version}
This page took 0.078914 seconds and 2 git commands to generate.