]> git.pld-linux.org Git - packages/bochs.git/blob - bochs.spec
a826392a26a9943f5fa5368ec738165e0c68694b
[packages/bochs.git] / bochs.spec
1 # TODO:
2 #       - more subpackages (plugins)
3 #
4 # Conditional build:
5 %bcond_without  svga    # without svgalib support
6 #
7 Summary:        Portable x86 PC Emulator
8 Summary(pl.UTF-8):   Przenośny emulator x86 PC
9 Name:           bochs
10 Version:        2.3
11 Release:        0.1
12 License:        GPL
13 Group:          Applications/Emulators
14 Source0:        http://dl.sourceforge.net/bochs/%{name}-%{version}.tar.gz
15 # Source0-md5:  100c02fbcd402c2b4862d0251be539fd
16 Patch0:         %{name}-wx.patch
17 URL:            http://bochs.sourceforge.net/
18 BuildRequires:  SDL-devel
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  docbook-dtd41-sgml
22 BuildRequires:  gtk+2-devel >= 1:2.0
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  ncurses-devel
25 BuildRequires:  pkgconfig
26 %{?with_svga:BuildRequires:     svgalib-devel}
27 BuildRequires:  wxGTK2-devel
28 #BuildRequires: xorg-???-devel
29 BuildRequires:  zlib-devel
30 #Requires:      xorg-font-???
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Bochs is a portable x86 PC emulation software package that emulates
35 enough of the x86 CPU, related AT hardware, and BIOS to run DOS,
36 Windows '95, Minix 2.0, and other OS's, all on your workstation.
37
38 %description -l pl.UTF-8
39 Bochs jest przenośnym emulatorem x86 PC emulującym wystarczająco dużo
40 architektury procesora x86 oraz hardware'u AT i BIOS-u żeby uruchomić
41 DOS-a, Windows 95, Minix 2.0 i inne systemy operacyjne, wszystkie na
42 Twoim komputerze.
43
44 %prep
45 %setup -q
46 %patch0 -p1
47
48 %build
49 cp -f /usr/share/automake/config.sub .
50 %{__autoconf}
51 CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses `pkg-config gdk-2.0 --cflags`"
52 LDFLAGS=`pkg-config gdk-2.0 --libs`
53 export CXXFLAGS LDFLAGS
54 # --enable-x86-64 (not supported together with --enable-sep)
55 # --enable-debugger --enable-iodebug --enable-x86-debugger (slowdowns emulation)
56 # --enable-apic (no need to specify, configure will choose best depending on nr cpus)
57
58 WXGTK2CONFIG=""
59 [ -x /usr/bin/wx-gtk2-ansi-config ] && WXGTK2CONFIG=wx-gtk2-ansi-config
60 [ -x /usr/bin/wxgtk-2.4-config ] && WXGTK2CONFIG=wxgtk-2.4-config
61
62 [ "x$WXGTK2CONFIG" == "x" ] && echo "Can't find wxGTK2 config file!" && exit 1
63
64 %configure \
65         WX_CONFIG=$WXGTK2CONFIG \
66         --enable-new-pit \
67         --enable-plugins \
68         --enable-cpu-level=6 \
69         --enable-compressed-hd \
70         --enable-ne2000 \
71         --enable-pci \
72         --enable-usb \
73         --enable-4meg-pages \
74         --enable-pae \
75         --enable-guest2host-tlb \
76         --enable-repeat-speedups \
77         --enable-icache \
78 %ifarch %{ix86}
79         --enable-fast-function-calls \
80 %endif
81         --enable-global-pages \
82         --enable-host-specific-asms \
83         --enable-ignore-bad-msr \
84         --enable-disasm \
85         --enable-all-optimizations \
86         --enable-readline \
87         --enable-instrumentation \
88         --enable-vbe \
89         --enable-fpu \
90         --enable-mmx \
91         --enable-3dnow \
92         --enable-sse=2 \
93         --enable-sep \
94         --enable-cdrom \
95         --enable-sb16=linux \
96         --enable-gameport \
97         --with-x \
98         --with-wx \
99         --with-rfb \
100         --with-sdl \
101         %{?with_svga:-with-svga} \
102         --with-x11 \
103         --with-term \
104         --with-rfb
105
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT \
113         docdir=%{_docdir}/%{name}-%{version}
114
115 mv -f $RPM_BUILD_ROOT%{_datadir}/bochs/VGABIOS*{LICENSE,README} \
116         $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
117
118 cp -f TESTFORM.txt $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
119
120 #rm -f $RPM_BUILD_ROOT%{_datadir}/bochs/*fonts
121 #rm -f $RPM_BUILD_ROOT%{_datadir}/bochs/*pcf
122
123 #find $RPM_BUILD_ROOT -type d -name CVS | xargs rm -rf
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %files
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{_bindir}/*
131 %dir %{_libdir}/%{name}
132 %dir %{_libdir}/%{name}/plugins
133 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so.*
134 %{_libdir}/%{name}/plugins/*.la
135 %dir %{_datadir}/%{name}
136 %dir %{_datadir}/%{name}/keymaps
137 %{_datadir}/%{name}/keymaps/*.map
138 %{_datadir}/%{name}/*BIOS*
139 %{_mandir}/man[15]/*
140 %{_docdir}/%{name}-%{version}
This page took 0.054877 seconds and 2 git commands to generate.