]> git.pld-linux.org Git - packages/bochs.git/blob - bochs.spec
66d75ef62adc43a52641b838cc134799540abca0
[packages/bochs.git] / bochs.spec
1 # TODO:
2 #       - more subpackages (plugins)
3 #
4 # Conditional build:
5 %bcond_without  svga    # without svgalib support
6 #
7 Summary:        Portable x86 PC Emulator
8 Summary(pl):    Przeno¶ny emulator x86 PC
9 Name:           bochs
10 Version:        2.2.6
11 Release:        1
12 License:        GPL
13 Group:          Applications/Emulators
14 Source0:        http://dl.sourceforge.net/bochs/%{name}-%{version}.tar.gz
15 # Source0-md5:  961482eb78b55fe3e0e0639e34b4c2c1
16 URL:            http://bochs.sourceforge.net/
17 BuildRequires:  SDL-devel
18 BuildRequires:  XFree86-devel
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  docbook-dtd41-sgml
22 BuildRequires:  gtk+2-devel
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  ncurses-devel
25 %{?with_svga:BuildRequires:     svgalib-devel}
26 BuildRequires:  wxGTK2-devel
27 BuildRequires:  zlib-devel
28 BuildRequires:  pkgconfig
29 Requires:       XFree86-fonts
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Bochs is a portable x86 PC emulation software package that emulates
34 enough of the x86 CPU, related AT hardware, and BIOS to run DOS,
35 Windows '95, Minix 2.0, and other OS's, all on your workstation.
36
37 %description -l pl
38 Bochs jest przeno¶nym emulatorem x86 PC emuluj±cym wystarczaj±co du¿o
39 architektury procesora x86 oraz hardware'u AT i BIOS-u ¿eby uruchomiæ
40 DOS-a, Windows 95, Minix 2.0 i inne systemy operacyjne, wszystkie na
41 Twoim komputerze.
42
43 %prep
44 %setup -q
45
46 %build
47 cp -f /usr/share/automake/config.sub .
48 %{__autoconf}
49 CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses `pkg-config gdk-2.0 --cflags`"
50 LDFLAGS=`pkg-config gdk-2.0 --libs`
51 export CXXFLAGS LDFLAGS
52 # --enable-x86-64 (not supported together with --enable-sep)
53 # --enable-debugger --enable-iodebug --enable-x86-debugger (slowdowns emulation)
54 # --enable-apic (no need to specify, configure will choose best depending on nr cpus)
55
56 WXGTK2CONFIG=""
57 [ -x /usr/bin/wx-gtk2-ansi-config ] && WXGTK2CONFIG=wx-gtk2-ansi-config
58 [ -x /usr/bin/wxgtk-2.4-config ] && WXGTK2CONFIG=wxgtk-2.4-config
59
60 [ "x$WXGTK2CONFIG" == "x" ] && echo "Can't find wxGTK2 config file!" && exit 1
61
62 %configure \
63         WX_CONFIG=$WXGTK2CONFIG \
64         --enable-new-pit \
65         --enable-plugins \
66         --enable-cpu-level=6 \
67         --enable-compressed-hd \
68         --enable-ne2000 \
69         --enable-pci \
70         --enable-usb \
71         --enable-4meg-pages \
72         --enable-pae \
73         --enable-guest2host-tlb \
74         --enable-repeat-speedups \
75         --enable-icache \
76 %ifarch %{ix86}
77         --enable-fast-function-calls \
78 %endif
79         --enable-global-pages \
80         --enable-host-specific-asms \
81         --enable-ignore-bad-msr \
82         --enable-disasm \
83         --enable-all-optimizations \
84         --enable-readline \
85         --enable-instrumentation \
86         --enable-vbe \
87         --enable-fpu \
88         --enable-mmx \
89         --enable-3dnow \
90         --enable-sse=2 \
91         --enable-sep \
92         --enable-cdrom \
93         --enable-sb16=linux \
94         --enable-gameport \
95         --with-x \
96         --with-wx \
97         --with-rfb \
98         --with-sdl \
99         %{?with_svga:-with-svga} \
100         --with-x11 \
101         --with-term \
102         --with-rfb
103
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT \
111         docdir=%{_docdir}/%{name}-%{version}
112
113 mv -f $RPM_BUILD_ROOT%{_datadir}/bochs/VGABIOS*{LICENSE,README} \
114         $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
115
116 cp -f TESTFORM.txt $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
117
118 #rm -f $RPM_BUILD_ROOT%{_datadir}/bochs/*fonts
119 #rm -f $RPM_BUILD_ROOT%{_datadir}/bochs/*pcf
120
121 #find $RPM_BUILD_ROOT -type d -name CVS | xargs rm -rf
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %files
127 %defattr(644,root,root,755)
128 %attr(755,root,root) %{_bindir}/*
129 %dir %{_libdir}/%{name}
130 %dir %{_libdir}/%{name}/plugins
131 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so.*
132 %{_libdir}/%{name}/plugins/*.la
133 %dir %{_datadir}/%{name}
134 %dir %{_datadir}/%{name}/keymaps
135 %{_datadir}/%{name}/keymaps/*.map
136 %{_datadir}/%{name}/*BIOS*
137 %{_mandir}/man[15]/*
138 %{_docdir}/%{name}-%{version}
This page took 0.115919 seconds and 2 git commands to generate.