]> git.pld-linux.org Git - packages/bochs.git/blame - bochs.spec
- converted to UTF-8
[packages/bochs.git] / bochs.spec
CommitLineData
cb8c4929 1# TODO:
3912903f 2# - more subpackages (plugins)
28971182 3#
ecb20ae6 4# Conditional build:
c9e015c3 5%bcond_without svga # without svgalib support
ecb20ae6 6#
a47f34bd 7Summary: Portable x86 PC Emulator
6b345bcc 8Summary(pl.UTF-8): Przenośny emulator x86 PC
a47f34bd 9Name: bochs
21393ca4
AM
10Version: 2.3
11Release: 0.1
a47f34bd 12License: GPL
13Group: Applications/Emulators
45854ac5 14Source0: http://dl.sourceforge.net/bochs/%{name}-%{version}.tar.gz
21393ca4
AM
15# Source0-md5: 100c02fbcd402c2b4862d0251be539fd
16Patch0: %{name}-wx.patch
0339db01 17URL: http://bochs.sourceforge.net/
f5ed92ec 18BuildRequires: SDL-devel
f5ed92ec 19BuildRequires: autoconf
4f52c938 20BuildRequires: automake
79bc089f 21BuildRequires: docbook-dtd41-sgml
560465c4 22BuildRequires: gtk+2-devel >= 1:2.0
47f0ac5c 23BuildRequires: libstdc++-devel
63df024a 24BuildRequires: ncurses-devel
560465c4 25BuildRequires: pkgconfig
ecb20ae6 26%{?with_svga:BuildRequires: svgalib-devel}
68752047 27BuildRequires: wxGTK2-devel
560465c4 28#BuildRequires: xorg-???-devel
63df024a 29BuildRequires: zlib-devel
560465c4 30#Requires: xorg-font-???
a47f34bd 31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34Bochs is a portable x86 PC emulation software package that emulates
35enough of the x86 CPU, related AT hardware, and BIOS to run DOS,
36Windows '95, Minix 2.0, and other OS's, all on your workstation.
37
6b345bcc
JR
38%description -l pl.UTF-8
39Bochs jest przenośnym emulatorem x86 PC emulującym wystarczająco dużo
40architektury procesora x86 oraz hardware'u AT i BIOS-u żeby uruchomić
19437b6d 41DOS-a, Windows 95, Minix 2.0 i inne systemy operacyjne, wszystkie na
34857763 42Twoim komputerze.
a47f34bd 43
44%prep
881a94e3 45%setup -q
21393ca4 46%patch0 -p1
a47f34bd 47
48%build
4f52c938 49cp -f /usr/share/automake/config.sub .
80cb4805 50%{__autoconf}
d3235216 51CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses `pkg-config gdk-2.0 --cflags`"
52LDFLAGS=`pkg-config gdk-2.0 --libs`
53export CXXFLAGS LDFLAGS
63df024a
AM
54# --enable-x86-64 (not supported together with --enable-sep)
55# --enable-debugger --enable-iodebug --enable-x86-debugger (slowdowns emulation)
56# --enable-apic (no need to specify, configure will choose best depending on nr cpus)
d3235216 57
58WXGTK2CONFIG=""
59[ -x /usr/bin/wx-gtk2-ansi-config ] && WXGTK2CONFIG=wx-gtk2-ansi-config
60[ -x /usr/bin/wxgtk-2.4-config ] && WXGTK2CONFIG=wxgtk-2.4-config
61
62[ "x$WXGTK2CONFIG" == "x" ] && echo "Can't find wxGTK2 config file!" && exit 1
63
eff64eef 64%configure \
d3235216 65 WX_CONFIG=$WXGTK2CONFIG \
3912903f 66 --enable-new-pit \
3912903f 67 --enable-plugins \
63df024a
AM
68 --enable-cpu-level=6 \
69 --enable-compressed-hd \
70 --enable-ne2000 \
71 --enable-pci \
72 --enable-usb \
73 --enable-4meg-pages \
74 --enable-pae \
75 --enable-guest2host-tlb \
3912903f 76 --enable-repeat-speedups \
77 --enable-icache \
63df024a
AM
78%ifarch %{ix86}
79 --enable-fast-function-calls \
80%endif
81 --enable-global-pages \
3912903f 82 --enable-host-specific-asms \
63df024a
AM
83 --enable-ignore-bad-msr \
84 --enable-disasm \
3912903f 85 --enable-all-optimizations \
63df024a
AM
86 --enable-readline \
87 --enable-instrumentation \
88 --enable-vbe \
89 --enable-fpu \
3912903f 90 --enable-mmx \
63df024a 91 --enable-3dnow \
3912903f 92 --enable-sse=2 \
63df024a
AM
93 --enable-sep \
94 --enable-cdrom \
95 --enable-sb16=linux \
96 --enable-gameport \
eff64eef 97 --with-x \
956b8471 98 --with-wx \
3912903f 99 --with-rfb \
100 --with-sdl \
ecb20ae6 101 %{?with_svga:-with-svga} \
80cb4805 102 --with-x11 \
103 --with-term \
104 --with-rfb
75e08ea9 105
a47f34bd 106%{__make}
107
108%install
109rm -rf $RPM_BUILD_ROOT
110
cb8c4929 111%{__make} install \
f5ed92ec
JB
112 DESTDIR=$RPM_BUILD_ROOT \
113 docdir=%{_docdir}/%{name}-%{version}
cb8c4929 114
46bbd7b8 115mv -f $RPM_BUILD_ROOT%{_datadir}/bochs/VGABIOS*{LICENSE,README} \
c9e015c3 116 $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
4a222e90 117
cb8c4929 118cp -f TESTFORM.txt $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
75e08ea9 119
881a94e3 120#rm -f $RPM_BUILD_ROOT%{_datadir}/bochs/*fonts
121#rm -f $RPM_BUILD_ROOT%{_datadir}/bochs/*pcf
4a222e90 122
881a94e3 123#find $RPM_BUILD_ROOT -type d -name CVS | xargs rm -rf
a47f34bd 124
125%clean
126rm -rf $RPM_BUILD_ROOT
127
128%files
129%defattr(644,root,root,755)
cb8c4929 130%attr(755,root,root) %{_bindir}/*
f5ed92ec
JB
131%dir %{_libdir}/%{name}
132%dir %{_libdir}/%{name}/plugins
3912903f 133%attr(755,root,root) %{_libdir}/%{name}/plugins/*.so.*
134%{_libdir}/%{name}/plugins/*.la
f5ed92ec
JB
135%dir %{_datadir}/%{name}
136%dir %{_datadir}/%{name}/keymaps
cb8c4929 137%{_datadir}/%{name}/keymaps/*.map
138%{_datadir}/%{name}/*BIOS*
139%{_mandir}/man[15]/*
140%{_docdir}/%{name}-%{version}
This page took 0.106781 seconds and 4 git commands to generate.