]> git.pld-linux.org Git - packages/boa.git/commitdiff
- revert user changes
authorpascalek <pascalek@pld-linux.org>
Sat, 17 May 2003 06:04:00 +0000 (06:04 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    boa.spec -> 1.57

boa.spec

index 57e425acc37e621636be7b9138305b7768117b3e..da1eedda1854321e87289b8c1a2ff34214d13a85 100644 (file)
--- a/boa.spec
+++ b/boa.spec
@@ -19,7 +19,12 @@ BuildRequires:       autoconf
 BuildRequires: flex
 BuildRequires: sgml-tools
 PreReq:                rc-scripts
-Requires(pre): user-http
+Requires(pre): /usr/bin/getgid
+Requires(pre): /bin/id
+Requires(pre): /usr/sbin/groupadd
+Requires(pre): /usr/sbin/useradd
+Requires(postun):      /usr/sbin/groupdel
+Requires(postun):      /usr/sbin/userdel
 Requires(post,preun):  /sbin/chkconfig
 Provides:      httpd
 Provides:      webserver
@@ -82,6 +87,34 @@ touch $RPM_BUILD_ROOT/var/log/httpd/{access_log,agent_log,error_log,referer_log}
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%pre
+if [ -n "`getgid http`" ]; then
+        if [ "`getgid http`" != "51" ]; then
+               echo "Error: group http doesn't have gid=51. Correct this before installing boa." 1>&2
+            exit 1
+        fi
+else
+        echo "Creating group http GID=51"
+        /usr/sbin/groupadd -g 51 -r -f http
+fi
+if [ -n "`id -u http 2>/dev/null`" ]; then
+        if [ "`id -u http`" != "51" ]; then
+                echo "Error: user http doesn't have uid=51. Correct this before installing boa." 1>&2
+                exit 1
+        fi
+else
+        echo "Creating user http UID=51"
+        /usr/sbin/useradd -u 51 -r -d /home/services/httpd -s /bin/false -c "HTTP User" -g http http 1>&2
+fi
+
+%postun
+if [ "$1" = "0" ]; then
+        echo "Removing user http UID=51"
+        /usr/sbin/userdel http > /dev/null 2>&1
+        echo "Removing group http GID=51"
+       /usr/sbin/groupdel http > /dev/null 2>&1
+fi
+
 %post
 /sbin/chkconfig --add boa
 if [ -f /var/lock/subsys/boa ]; then
This page took 0.0867 seconds and 4 git commands to generate.