]> git.pld-linux.org Git - packages/boa.git/commitdiff
- reverting last change: removing new macros from %p{re,ost}{,un}
authorsaq <saq@pld-linux.org>
Thu, 26 Jul 2001 05:42:05 +0000 (05:42 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    boa.spec -> 1.36

boa.spec

index 00a6a95a9c49b86953ba2ae7e5998d172eeca347..19f398971b51abc3033232667e1d5440c038e468 100644 (file)
--- a/boa.spec
+++ b/boa.spec
@@ -73,18 +73,47 @@ gzip -9nf README
 rm -rf $RPM_BUILD_ROOT
 
 %pre
-GROUP=http; GID=51; %groupadd
-USER=http; UID=51; HOMEDIR=/home/httpd; COMMENT="HTTP User"; %useradd
+if [ -n "`getgid http`" ]; then
+        if [ "`getgid http`" != "51" ]; then
+                echo "Warning:group http haven't gid=51. Correct this before install boa" 1>&2
+                exit 1
+        fi
+else
+        /usr/sbin/groupadd -g 51 -r -f http
+fi
+if [ -n "`id -u http 2>/dev/null`" ]; then
+        if [ "`id -u http`" != "51" ]; then
+                echo "Warning:user http haven't uid=51. Correct this before install boa" 1>&2
+                exit 1
+        fi
+else
+        /usr/sbin/useradd -u 51 -r -d /home/httpd -s /bin/false -c "HTTP User" -g http http 1>&2
+fi
+
 
 %postun
-USER=http; %userdel
-GROUP=http; %groupdel
+if [ "$1" = "0" ]; then
+       %{_sbindir}/userdel http > /dev/null 2>&1
+       %{_sbindir}/groupdel http > /dev/null 2>&1
+fi
 
 %post
-DESC="boa http daemon"; %chkconfig_add
+/sbin/chkconfig --add %{name}
+
+if [ -f /var/lock/subsys/httpd ]; then
+        /etc/rc.d/init.d/httpd restart 1>&2
+else
+        echo "Run \"/etc/rc.d/init.d/boa start\" to start boa http daemon."
+fi
+
 
 %preun
-%chkconfig_del
+if [ "$1" = "0" ]; then
+        if [ -f /var/lock/subsys/boa ]; then
+                /etc/rc.d/init.d/boa stop 1>&2
+        fi
+        /sbin/chkconfig --del boa
+fi
 
 %files
 %defattr(644,root,root,755)
This page took 0.063283 seconds and 4 git commands to generate.