]> git.pld-linux.org Git - packages/boa.git/blobdiff - boa.spec
- HTTP group
[packages/boa.git] / boa.spec
index afb03b1b4a8755c87e6d6fd1dec6cffc4caa7dff..e7db7826a099e3294e61e1bf01df34d3c051420a 100644 (file)
--- a/boa.spec
+++ b/boa.spec
@@ -1,27 +1,40 @@
+#
+# Conditional build:
+%bcond_without ipv6    # IPv4-only version (doesn't require IPv6 in kernel)
+#
+%define        _rc             rc21
+%define        _rel    3
 Summary:       Boa high speed HTTP server
-Summary(pl):   Boa - szybki serwer HTTP
+Summary(pl.UTF-8):     Boa - szybki serwer HTTP
 Name:          boa
-Version:       0.94.8.2
-Release:       2
-License:       GPL
-Group:         Networking/Daemons
-Group(de):     Netzwerkwesen/Server
-Group(pl):     Sieciowe/Serwery
-Source0:       http://www.boa.org/%{name}-%{version}.tar.gz
+Version:       0.94.14
+Release:       0.%{_rc}.%{_rel}
+Epoch:         1
+License:       GPL v2
+Group:         Networking/Daemons/HTTP
+Source0:       http://www.boa.org/%{name}-%{version}%{_rc}.tar.gz
+# Source0-md5: e24b570bd767a124fcfb40a34d148ba9
 Source1:       %{name}.init
 Patch0:                %{name}-PLD.patch
-Provides:      httpd                                                           
-Provides:      webserver                                                       
-Prereq:                sh-utils
-Prereq:                %{_sbindir}/groupadd
-Prereq:                %{_sbindir}/groupdel
-Prereq:                %{_sbindir}/useradd
-Prereq:                %{_sbindir}/userdel
+URL:           http://www.boa.org/
+BuildRequires: autoconf >= 2.59
+BuildRequires: automake
 BuildRequires: flex
+BuildRequires: rpmbuild(macros) >= 1.268
+BuildRequires: sed >= 4.0
+BuildRequires: texinfo
+Requires(post,preun):  /sbin/chkconfig
+Requires(postun):      /usr/sbin/groupdel
+Requires(postun):      /usr/sbin/userdel
+Requires(pre): /bin/id
+Requires(pre): /usr/bin/getgid
+Requires(pre): /usr/sbin/groupadd
+Requires(pre): /usr/sbin/useradd
 Requires:      rc-scripts
+Provides:      group(http)
+Provides:      user(http)
+Provides:      webserver
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
-%define                _sysconfdir     /etc/httpd
-Obsoletes:     apache
 
 %description
 A high speed, lightweight web server (HTTP protocol). Based on direct
@@ -29,77 +42,89 @@ use of the select(2) system call, it internally multiplexes all
 connections without forking, for maximum speed and minimum system
 resource use.
 
-%description -l pl
-Niezwykle szybki i wysoko wydajny serwer WWW (protokó³ HTTP). Bazuje
-na bezpo¶rednim u¿yciu funkcji systemowej select(2) dziêki czemu mo¿e
-obs³ugiwaæ wiele po³±czeñ równocze¶nie bez fork()owania co w efekcie
-znacznie zwiêksza szybko¶æ dzia³ania oraz zmniejsza zu¿ycie zasobów
+%description -l pl.UTF-8
+Niezwykle szybki i wysoko wydajny serwer WWW (protokół HTTP). Bazuje
+na bezpośrednim użyciu funkcji systemowej select(2) dzięki czemu może
+obsługiwać wiele połączeń równocześnie bez fork()owania co w efekcie
+znacznie zwiększa szybkość działania oraz zmniejsza zużycie zasobów
 systemowych.
 
 %prep
-%setup -q
-%patch0 -p1
+%setup -q -n %{name}-%{version}%{_rc}
+cp examples/boa.conf .
+%patch0 -p0
 
 %build
-cd src
-CFLAGS="$RPM_OPT_FLAGS -DINET6"
+cp -f /usr/share/automake/config.sub .
+%{__sed} -i 's,},  olddir /var/log/archive/boa\x0a},' contrib/rpm/boa.logrotate
+CFLAGS="%{rpmcflags} %{?with_ipv6:-DINET6} -DSERVER_ROOT='\"%{_sysconfdir}\"'"
+%{__autoconf}
 %configure
 %{__make}
-(cd ../docs; make boa.html )
+%{__make} -C docs boa.html
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d/,/var/log/httpd} \
-       $RPM_BUILD_ROOT/home/httpd/{cgi-bin,html} \
-       $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/conf,%{_mandir}/man8}
+install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
+       $RPM_BUILD_ROOT/var/log/{,archive/}boa \
+       $RPM_BUILD_ROOT%{_sbindir} \
+       $RPM_BUILD_ROOT%{_mandir}/man8 \
+       $RPM_BUILD_ROOT/etc/logrotate.d \
+       $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
 install src/{boa,boa_indexer} $RPM_BUILD_ROOT%{_sbindir}
 
-install src/*.pl $RPM_BUILD_ROOT/home/httpd/cgi-bin
-install examples/resolver.pl $RPM_BUILD_ROOT/home/httpd/cgi-bin
-install        %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
+install examples/*.pl examples/*.cgi \
+       $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
 
 install boa.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
+install contrib/rpm/boa.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
 
-install docs/boa.8 $RPM_BUILD_ROOT%{_mandir}/man8/
+install docs/boa.8 $RPM_BUILD_ROOT%{_mandir}/man8
 
-touch $RPM_BUILD_ROOT/var/log/httpd/{access_log,agent_log,error_log,referer_log}
-
-gzip -9nf README $RPM_BUILD_ROOT%{_mandir}/man*/*
+touch $RPM_BUILD_ROOT/var/log/boa/{access_log,agent_log,error_log,referer_log}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %pre
-%{_sbindir}/groupadd -g 51 -f http > /dev/null 2>&1
-%{_sbindir}/useradd -u 51 -f http -g http > /dev/null 2>&1
+%groupadd -g 51 -r -f http
+%useradd -u 51 -r -d /usr/share/empty -s /bin/false -c "HTTP User" -g http http
 
 %postun
 if [ "$1" = "0" ]; then
-       %{_sbindir}/userdel http > /dev/null 2>&1
-       %{_sbindir}/groupdel http > /dev/null 2>&1
+       %userremove http
+       %groupremove http
 fi
 
 %post
-/sbin/chkconfig -add %{name}
+/sbin/chkconfig --add boa
+%service boa restart "boa HTTP daemon"
 
 %preun
 if [ "$1" = "0" ]; then
-        if [ -f /var/lock/subsys/boa ]; then
-                /etc/rc.d/init.d/boa stop 1>&2
-        fi
-        /sbin/chkconfig --del boa
+       %service boa stop
+       /sbin/chkconfig --del boa
+fi
+
+%triggerpostun -- boa < 0.94.14-0.rc20.0
+if [ -f /etc/httpd/boa.conf.rpmsave ]; then
+       echo "warning: installing /etc/boa.conf as /etc/boa.conf.rpmnew"
+       mv /etc/boa.conf /etc/boa.conf.rpmnew
+       echo "warning: moving /etc/httpd/boa.conf.rpmsave to /etc/boa.conf"
+       mv /etc/httpd/boa.conf.rpmsave /etc/boa.conf
 fi
 
 %files
 %defattr(644,root,root,755)
-%doc README.gz docs/*.html docs/*.png docs/boa.{ps,sgml}
-%attr(750, root,http) %dir %{_sysconfdir}
-%attr(640, root,http) %config %{_sysconfdir}/*
-%attr(755, root,http) /home/httpd/html
-%attr(755, root,http) /home/httpd/cgi-bin
-%attr(750, root,http) %dir /var/log/httpd/
-%attr(640, root,http) %ghost /var/log/httpd/*
-%attr(755, root,root) %{_sbindir}/*
-%attr(754, root,root) /etc/rc.d/init.d/%{name}
+%doc CHANGES README docs/*.html docs/*.png
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/boa.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
+%attr(750,root,root) %dir /var/log/%{name}/
+%attr(750,root,root) %dir /var/log/archive/%{name}/
+%attr(640,root,root) %ghost /var/log/%{name}/*
+%attr(755,root,root) %{_sbindir}/*
+%attr(754,root,root) /etc/rc.d/init.d/%{name}
 %{_mandir}/man8/*
+%{_examplesdir}/%{name}-%{version}
This page took 0.210204 seconds and 4 git commands to generate.