]> git.pld-linux.org Git - packages/boa.git/blobdiff - boa.spec
- HTTP group
[packages/boa.git] / boa.spec
index 7adbd51f88ef8e3875829016edf731d570a3c028..e7db7826a099e3294e61e1bf01df34d3c051420a 100644 (file)
--- a/boa.spec
+++ b/boa.spec
@@ -1,35 +1,36 @@
 #
 # Conditional build:
-%bcond_without         ipv6    # IPv4-only version (doesn't require IPv6 in kernel)
+%bcond_without ipv6    # IPv4-only version (doesn't require IPv6 in kernel)
 #
+%define        _rc             rc21
+%define        _rel    3
 Summary:       Boa high speed HTTP server
-Summary(pl):   Boa - szybki serwer HTTP
+Summary(pl.UTF-8):     Boa - szybki serwer HTTP
 Name:          boa
 Version:       0.94.14
-%define        _rc     rc20
-Release:       0.%{_rc}.3
+Release:       0.%{_rc}.%{_rel}
 Epoch:         1
 License:       GPL v2
-Group:         Networking/Daemons
+Group:         Networking/Daemons/HTTP
 Source0:       http://www.boa.org/%{name}-%{version}%{_rc}.tar.gz
-# Source0-md5: 046d1764cd8f325109da9c80c993b2ef
+# Source0-md5: e24b570bd767a124fcfb40a34d148ba9
 Source1:       %{name}.init
 Patch0:                %{name}-PLD.patch
 URL:           http://www.boa.org/
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.59
 BuildRequires: automake
 BuildRequires: flex
-BuildRequires: rpmbuild(macros) >= 1.159
+BuildRequires: rpmbuild(macros) >= 1.268
 BuildRequires: sed >= 4.0
 BuildRequires: texinfo
-PreReq:                rc-scripts
+Requires(post,preun):  /sbin/chkconfig
+Requires(postun):      /usr/sbin/groupdel
+Requires(postun):      /usr/sbin/userdel
 Requires(pre): /bin/id
 Requires(pre): /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
-Requires(postun):      /usr/sbin/groupdel
-Requires(postun):      /usr/sbin/userdel
-Requires(post,preun):  /sbin/chkconfig
+Requires:      rc-scripts
 Provides:      group(http)
 Provides:      user(http)
 Provides:      webserver
@@ -41,11 +42,11 @@ use of the select(2) system call, it internally multiplexes all
 connections without forking, for maximum speed and minimum system
 resource use.
 
-%description -l pl
-Niezwykle szybki i wysoko wydajny serwer WWW (protokó³ HTTP). Bazuje
-na bezpo¶rednim u¿yciu funkcji systemowej select(2) dziêki czemu mo¿e
-obs³ugiwaæ wiele po³±czeñ równocze¶nie bez fork()owania co w efekcie
-znacznie zwiêksza szybko¶æ dzia³ania oraz zmniejsza zu¿ycie zasobów
+%description -l pl.UTF-8
+Niezwykle szybki i wysoko wydajny serwer WWW (protokół HTTP). Bazuje
+na bezpośrednim użyciu funkcji systemowej select(2) dzięki czemu może
+obsługiwać wiele połączeń równocześnie bez fork()owania co w efekcie
+znacznie zwiększa szybkość działania oraz zmniejsza zużycie zasobów
 systemowych.
 
 %prep
@@ -55,7 +56,7 @@ cp examples/boa.conf .
 
 %build
 cp -f /usr/share/automake/config.sub .
-%{__sed} -i 's,},  olddir /var/log/archiv/boa\x0a},' contrib/rpm/boa.logrotate
+%{__sed} -i 's,},  olddir /var/log/archive/boa\x0a},' contrib/rpm/boa.logrotate
 CFLAGS="%{rpmcflags} %{?with_ipv6:-DINET6} -DSERVER_ROOT='\"%{_sysconfdir}\"'"
 %{__autoconf}
 %configure
@@ -64,23 +65,23 @@ CFLAGS="%{rpmcflags} %{?with_ipv6:-DINET6} -DSERVER_ROOT='\"%{_sysconfdir}\"'"
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/etc/rc.d/init.d/ \
-       $RPM_BUILD_ROOT/var/log/{,archiv/}boa \
+install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
+       $RPM_BUILD_ROOT/var/log/{,archive/}boa \
        $RPM_BUILD_ROOT%{_sbindir} \
        $RPM_BUILD_ROOT%{_mandir}/man8 \
        $RPM_BUILD_ROOT/etc/logrotate.d \
        $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
-install src/{boa,boa_indexer} $RPM_BUILD_ROOT%{_sbindir}/
+install src/{boa,boa_indexer} $RPM_BUILD_ROOT%{_sbindir}
 
-install src/*.pl examples/*.pl examples/*.cgi \
+install examples/*.pl examples/*.cgi \
        $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
-install        %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
+install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
 
 install boa.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
 install contrib/rpm/boa.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
 
-install docs/boa.8 $RPM_BUILD_ROOT%{_mandir}/man8/
+install docs/boa.8 $RPM_BUILD_ROOT%{_mandir}/man8
 
 touch $RPM_BUILD_ROOT/var/log/boa/{access_log,agent_log,error_log,referer_log}
 
@@ -88,24 +89,8 @@ touch $RPM_BUILD_ROOT/var/log/boa/{access_log,agent_log,error_log,referer_log}
 rm -rf $RPM_BUILD_ROOT
 
 %pre
-if [ -n "`getgid http`" ]; then
-       if [ "`getgid http`" != "51" ]; then
-               echo "Error: group http doesn't have gid=51. Correct this before installing boa." 1>&2
-               exit 1
-       fi
-else
-       echo "Creating group http GID=51"
-       /usr/sbin/groupadd -g 51 -r -f http
-fi
-if [ -n "`id -u http 2>/dev/null`" ]; then
-       if [ "`id -u http`" != "51" ]; then
-               echo "Error: user http doesn't have uid=51. Correct this before installing boa." 1>&2
-               exit 1
-       fi
-else
-       echo "Creating user http UID=51"
-       /usr/sbin/useradd -u 51 -r -d /usr/share/empty -s /bin/false -c "HTTP User" -g http http 1>&2
-fi
+%groupadd -g 51 -r -f http
+%useradd -u 51 -r -d /usr/share/empty -s /bin/false -c "HTTP User" -g http http
 
 %postun
 if [ "$1" = "0" ]; then
@@ -115,17 +100,11 @@ fi
 
 %post
 /sbin/chkconfig --add boa
-if [ -f /var/lock/subsys/boa ]; then
-       /etc/rc.d/init.d/boa restart 1>&2
-else
-       echo "Run \"/etc/rc.d/init.d/boa start\" to start boa HTTP daemon."
-fi
+%service boa restart "boa HTTP daemon"
 
 %preun
 if [ "$1" = "0" ]; then
-       if [ -f /var/lock/subsys/boa ]; then
-               /etc/rc.d/init.d/boa stop 1>&2
-       fi
+       %service boa stop
        /sbin/chkconfig --del boa
 fi
 
@@ -139,11 +118,11 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc README CHANGES docs/*.html docs/*.png
-%attr(640,root,root) %config(noreplace) %{_sysconfdir}/boa.conf
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/%{name}
+%doc CHANGES README docs/*.html docs/*.png
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/boa.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
 %attr(750,root,root) %dir /var/log/%{name}/
-%attr(750,root,root) %dir /var/log/archiv/%{name}/
+%attr(750,root,root) %dir /var/log/archive/%{name}/
 %attr(640,root,root) %ghost /var/log/%{name}/*
 %attr(755,root,root) %{_sbindir}/*
 %attr(754,root,root) /etc/rc.d/init.d/%{name}
This page took 0.108294 seconds and 4 git commands to generate.