]> git.pld-linux.org Git - packages/boa.git/blobdiff - boa.spec
perl -pi -e "s/^automake -a -c -f --foreing/\%\{__automake\}/; \
[packages/boa.git] / boa.spec
index 9b5ba627ade73ca4fcfe6c37821eaffb4a5416fe..a19598c9245479c62c43c191c665ebef8dd29d82 100644 (file)
--- a/boa.spec
+++ b/boa.spec
@@ -1,26 +1,37 @@
+#
+# Conditional build:
+# _without_ipv6        - IPv4-only version (doesn't require IPv6 in kernel)
+#
 Summary:       Boa high speed HTTP server
 Summary(pl):   Boa - szybki serwer HTTP
 Name:          boa
-Version:       0.94.8.3
+Version:       0.94.12
 Release:       1
-License:       GPL
+Epoch:         1
+License:       GPL v2
 Group:         Networking/Daemons
-Group(de):     Netzwerkwesen/Server
-Group(pl):     Sieciowe/Serwery
 Source0:       http://www.boa.org/%{name}-%{version}.tar.gz
 Source1:       %{name}.init
 Patch0:                %{name}-PLD.patch
-Provides:      httpd                                                           
-Provides:      webserver                                                       
-Prereq:                sh-utils
-Prereq:                %{_sbindir}/groupadd
-Prereq:                %{_sbindir}/groupdel
-Prereq:                %{_sbindir}/useradd
-Prereq:                %{_sbindir}/userdel
+URL:           http://www.boa.org/
+BuildRequires: autoconf
 BuildRequires: flex
-Requires:      rc-scripts
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+BuildRequires: sgml-tools
+PreReq:                rc-scripts
+Requires(pre): /bin/id
+Requires(pre): /usr/bin/getgid
+Requires(pre): /usr/sbin/groupadd
+Requires(pre): /usr/sbin/useradd
+Requires(postun):      /usr/sbin/groupdel
+Requires(postun):      /usr/sbin/userdel
+Requires(post,preun):  /sbin/chkconfig
+Provides:      httpd
+Provides:      webserver
 Obsoletes:     apache
+Obsoletes:     httpd
+Obsoletes:     thttpd
+Obsoletes:     webserver
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sysconfdir     /etc/httpd
 
@@ -43,46 +54,75 @@ systemowych.
 
 %build
 cd src
-CFLAGS="%{!?debug:$RPM_OPT_FLAGS}%{?debug:-O -g} -DINET6"
+CFLAGS="%{rpmcflags} %{!?_without_ipv6:-DINET6}"
+%{__autoconf}
 %configure
 %{__make}
-(cd ../docs; make boa.html )
+cd ../docs
+%{__make} boa.html
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d/,/var/log/httpd} \
+install -d $RPM_BUILD_ROOT/etc/rc.d/init.d/ \
+       $RPM_BUILD_ROOT/var/log/httpd \
        $RPM_BUILD_ROOT/home/httpd/{cgi-bin,html} \
-       $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/conf,%{_mandir}/man8}
+       $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/conf,%{_mandir}/man8} \
+       $RPM_BUILD_ROOT/etc/logrotate.d
 
-install src/{boa,boa_indexer} $RPM_BUILD_ROOT%{_sbindir}
 
-install src/*.pl $RPM_BUILD_ROOT/home/httpd/cgi-bin
-install examples/resolver.pl $RPM_BUILD_ROOT/home/httpd/cgi-bin
+install src/{boa,boa_indexer} $RPM_BUILD_ROOT%{_sbindir}/
+
+install src/*.pl $RPM_BUILD_ROOT/home/httpd/cgi-bin/
+install examples/* $RPM_BUILD_ROOT/home/httpd/cgi-bin/
 install        %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
 
 install boa.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
+install contrib/redhat/boa.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
 
 install docs/boa.8 $RPM_BUILD_ROOT%{_mandir}/man8/
 
 touch $RPM_BUILD_ROOT/var/log/httpd/{access_log,agent_log,error_log,referer_log}
 
-gzip -9nf README
+gzip -9nf README ChangeLog
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %pre
-%{_sbindir}/groupadd -g 51 -f http > /dev/null 2>&1
-%{_sbindir}/useradd -u 51 -f http -g http > /dev/null 2>&1
+if [ -n "`getgid http`" ]; then
+        if [ "`getgid http`" != "51" ]; then
+                echo "Error: group http doesn't have gid=51. Correct this before installing boa." 1>&2
+                exit 1
+        fi
+else
+       echo "Creating group http GID=51"
+        /usr/sbin/groupadd -g 51 -r -f http
+fi
+if [ -n "`id -u http 2>/dev/null`" ]; then
+        if [ "`id -u http`" != "51" ]; then
+                echo "Error: user http doesn't have uid=51. Correct this before installing boa." 1>&2
+                exit 1
+        fi
+else
+       echo "Creating user http UID=51"
+        /usr/sbin/useradd -u 51 -r -d /home/httpd -s /bin/false -c "HTTP User" -g http http 1>&2
+fi
 
 %postun
 if [ "$1" = "0" ]; then
-       %{_sbindir}/userdel http > /dev/null 2>&1
-       %{_sbindir}/groupdel http > /dev/null 2>&1
+       echo "Removing user http UID=51"
+       /usr/sbin/userdel http > /dev/null 2>&1
+       echo "Removing group http GID=51"
+       /usr/sbin/groupdel http > /dev/null 2>&1
 fi
 
 %post
-/sbin/chkconfig -add %{name}
+/sbin/chkconfig --add boa
+if [ -f /var/lock/subsys/boa ]; then
+        /etc/rc.d/init.d/boa restart 1>&2
+else
+        echo "Run \"/etc/rc.d/init.d/boa start\" to start boa http daemon."
+fi
 
 %preun
 if [ "$1" = "0" ]; then
@@ -94,9 +134,10 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc README.gz docs/*.html docs/*.png docs/boa.{ps,sgml}
+%doc *.gz docs/*.html docs/*.png
 %attr(750, root,http) %dir %{_sysconfdir}
-%attr(640, root,http) %config %{_sysconfdir}/*
+%attr(640, root,http) %config(noreplace) %{_sysconfdir}/*
+%attr(640, root,http) %config(noreplace) /etc/logrotate.d/%{name}
 %attr(755, root,http) /home/httpd/html
 %attr(755, root,http) /home/httpd/cgi-bin
 %attr(750, root,http) %dir /var/log/httpd/
This page took 0.066966 seconds and 4 git commands to generate.