]> git.pld-linux.org Git - packages/boa.git/blobdiff - boa.spec
- cleaning
[packages/boa.git] / boa.spec
index c4eefd37e534a01851755122352fa1fa44d65432..994245c9ad7ebe8959998df3a7077a0cfedc04a9 100644 (file)
--- a/boa.spec
+++ b/boa.spec
@@ -1,27 +1,38 @@
+#
+# Conditional build:
+# _without_ipv6        - IPv4-only version (doesn't require IPv6 in kernel)
+#
 Summary:       Boa high speed HTTP server
 Summary(pl):   Boa - szybki serwer HTTP
 Name:          boa
-Version:       0.94.8.3
+Version:       0.94.13
 Release:       1
-License:       GPL
+Epoch:         1
+License:       GPL v2
 Group:         Networking/Daemons
-Group(de):     Netzwerkwesen/Server
-Group(pl):     Sieciowe/Serwery
 Source0:       http://www.boa.org/%{name}-%{version}.tar.gz
 Source1:       %{name}.init
 Patch0:                %{name}-PLD.patch
-Provides:      httpd                                                           
-Provides:      webserver                                                       
-Prereq:                sh-utils
-Prereq:                %{_sbindir}/groupadd
-Prereq:                %{_sbindir}/groupdel
-Prereq:                %{_sbindir}/useradd
-Prereq:                %{_sbindir}/userdel
+Patch1:                %{name}-logrotate.patch
+URL:           http://www.boa.org/
+BuildRequires: autoconf
 BuildRequires: flex
 BuildRequires: sgml-tools
-Prereq:                rc-scripts
+PreReq:                rc-scripts
+Requires(pre): /usr/bin/getgid
+Requires(pre): /bin/id
+Requires(pre): /usr/sbin/groupadd
+Requires(pre): /usr/sbin/useradd
+Requires(postun):      /usr/sbin/groupdel
+Requires(postun):      /usr/sbin/userdel
+Requires(post,preun):  /sbin/chkconfig
+Provides:      httpd
+Provides:      webserver
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Obsoletes:     apache
+Obsoletes:     httpd
+Obsoletes:     thttpd
+Obsoletes:     webserver
 
 %define                _sysconfdir     /etc/httpd
 
@@ -41,72 +52,77 @@ systemowych.
 %prep
 %setup -q
 %patch0 -p1
+%patch1        -p0
 
 %build
 cd src
-CFLAGS="%{?debug:-O0 -g}%{!?debug:$RPM_OPT_FLAGS} -DINET6"
+CFLAGS="%{rpmcflags} %{!?_without_ipv6:-DINET6}"
+%{__autoconf}
 %configure
 %{__make}
-(cd ../docs; make boa.html )
+cd ../docs
+%{__make} boa.html
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d/,/var/log/httpd} \
-       $RPM_BUILD_ROOT/home/httpd/{cgi-bin,html} \
-       $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/conf,%{_mandir}/man8}
+install -d $RPM_BUILD_ROOT/etc/rc.d/init.d/ \
+       $RPM_BUILD_ROOT/var/log/httpd \
+       $RPM_BUILD_ROOT/home/services/httpd/{cgi-bin,html} \
+       $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/conf,%{_mandir}/man8} \
+       $RPM_BUILD_ROOT/etc/logrotate.d
 
-install src/{boa,boa_indexer} $RPM_BUILD_ROOT%{_sbindir}
+install src/{boa,boa_indexer} $RPM_BUILD_ROOT%{_sbindir}/
 
-install src/*.pl $RPM_BUILD_ROOT/home/httpd/cgi-bin
-install examples/resolver.pl $RPM_BUILD_ROOT/home/httpd/cgi-bin
+install src/*.pl $RPM_BUILD_ROOT/home/services/httpd/cgi-bin/
+install examples/* $RPM_BUILD_ROOT/home/services/httpd/cgi-bin/
 install        %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
 
 install boa.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
+install contrib/redhat/boa.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
 
 install docs/boa.8 $RPM_BUILD_ROOT%{_mandir}/man8/
 
 touch $RPM_BUILD_ROOT/var/log/httpd/{access_log,agent_log,error_log,referer_log}
 
-gzip -9nf README
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %pre
 if [ -n "`getgid http`" ]; then
         if [ "`getgid http`" != "51" ]; then
-                echo "Warning:group http haven't gid=51. Corect this before install boa" 1>&2
-                exit 1
+               echo "Error: group http doesn't have gid=51. Correct this before installing boa." 1>&2
+            exit 1
         fi
 else
+        echo "Creating group http GID=51"
         /usr/sbin/groupadd -g 51 -r -f http
 fi
 if [ -n "`id -u http 2>/dev/null`" ]; then
         if [ "`id -u http`" != "51" ]; then
-                echo "Warning:user http haven't uid=51. Corect this before install boa" 1>&2
+                echo "Error: user http doesn't have uid=51. Correct this before installing boa." 1>&2
                 exit 1
         fi
 else
-        /usr/sbin/useradd -u 51 -r -d /home/httpd -s /bin/false -c "HTTP User" -g http http 1>&2
+       echo "Creating user http UID=51"
+        /usr/sbin/useradd -u 51 -r -d /home/services/httpd -s /bin/false -c "HTTP User" -g http http 1>&2
 fi
 
-
 %postun
 if [ "$1" = "0" ]; then
-       %{_sbindir}/userdel http > /dev/null 2>&1
-       %{_sbindir}/groupdel http > /dev/null 2>&1
+       echo "Removing user http UID=51"
+       /usr/sbin/userdel http > /dev/null 2>&1
+       echo "Removing group http GID=51"
+        /usr/sbin/groupdel http > /dev/null 2>&1
 fi
 
 %post
-/sbin/chkconfig --add %{name}
-
-if [ -f /var/lock/subsys/httpd ]; then
-        /etc/rc.d/init.d/httpd restart 1>&2
+/sbin/chkconfig --add boa
+if [ -f /var/lock/subsys/boa ]; then
+        /etc/rc.d/init.d/boa restart 1>&2
 else
         echo "Run \"/etc/rc.d/init.d/boa start\" to start boa http daemon."
 fi
 
-
 %preun
 if [ "$1" = "0" ]; then
         if [ -f /var/lock/subsys/boa ]; then
@@ -117,13 +133,15 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc README.gz docs/*.html docs/*.png docs/boa.{ps,sgml}
-%attr(750, root,http) %dir %{_sysconfdir}
-%attr(640, root,http) %config %{_sysconfdir}/*
-%attr(755, root,http) /home/httpd/html
-%attr(755, root,http) /home/httpd/cgi-bin
-%attr(750, root,http) %dir /var/log/httpd/
-%attr(640, root,http) %ghost /var/log/httpd/*
-%attr(755, root,root) %{_sbindir}/*
-%attr(754, root,root) /etc/rc.d/init.d/%{name}
+%doc README ChangeLog docs/*.html docs/*.png
+%attr(750,root,root) %dir %{_sysconfdir}
+%attr(640,root,root) %config(noreplace) %{_sysconfdir}/*
+%attr(640,root,root) %config(noreplace) /etc/logrotate.d/%{name}
+%dir /home/services/httpd
+%attr(755,root,root) /home/services/httpd/html
+%attr(755,root,root) /home/services/httpd/cgi-bin
+%attr(750,root,root) %dir /var/log/httpd/
+%attr(640,root,root) %ghost /var/log/httpd/*
+%attr(755,root,root) %{_sbindir}/*
+%attr(754,root,root) /etc/rc.d/init.d/%{name}
 %{_mandir}/man8/*
This page took 0.039396 seconds and 4 git commands to generate.