]> git.pld-linux.org Git - packages/bnc.git/blob - bnc.spec
- tabs in preamble
[packages/bnc.git] / bnc.spec
1 # TODO
2 #  - bncsetup working partially, needs newer dialog
3 Summary:        Simple IRC bouncer
4 Summary(pl.UTF-8):      Proste narzędzie do tunelowania IRC
5 Name:           bnc
6 Version:        2.9.4
7 Release:        3
8 License:        GPL
9 Group:          Networking/Utilities
10 Source0:        http://www.gotbnc.com/files/%{name}%{version}.tar.gz
11 # Source0-md5:  190486d2346415e30f6381377e82eb3b
12 Source1:        %{name}.sysconfig
13 Source2:        %{name}.init
14 Source3:        %{name}.conf
15 Patch0:         %{name}-setup.patch
16 Patch1:         %{name}-typo.patch
17 URL:            http://www.gotbnc.com/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  openssl-devel
21 BuildRequires:  rpmbuild(macros) >= 1.268
22 Requires:       dialog >= 1:0.69
23 Provides:       group(bnc)
24 Provides:       user(bnc)
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _sysconfdir     /etc/%{name}
28
29 %description
30 BNC is a great IRC (Internet Relay Chat) proxying server under the GPL
31 (General Public License). It allows users to connect to chat servers
32 by bouncing off the computer which is running BNC. Basically, it
33 forwards the information from the user to the server and vise versa.
34
35 %description -l pl.UTF-8
36 BNC jest rewelacyjnym i prostym proxy do IRC (Internet Relay Chat) na
37 licencji GPL (General Public License). BNC pozwala użytkownikom na
38 połączenie się z serwerem IRC wykorzystując do tego komputer na którym
39 BNC zostało uruchomione. Mówiąc w skrócie, BNC przekazuje informacje
40 od użytkownika do serwera i vice versa.
41
42 %package init
43 Summary:        Simple IRC bouncer daemon
44 Summary(pl.UTF-8):      Prosty demon do tunelowania IRC
45 Group:          Networking/Utilities
46 Requires(post): grep
47 Requires(post,preun):   /sbin/chkconfig
48 Requires(postun):       /usr/sbin/groupdel
49 Requires(postun):       /usr/sbin/userdel
50 Requires(pre):  /bin/id
51 Requires(pre):  /usr/bin/getgid
52 Requires(pre):  /usr/sbin/groupadd
53 Requires(pre):  /usr/sbin/useradd
54 Requires:       %{name} = %{version}-%{release}
55 Requires:       /sbin/start-stop-daemon
56
57 %description init
58 This package contains the initscript to start bnc as system service.
59
60 %description init -l pl.UTF-8
61 Ten pakiet zawiera skrypt init do uruchamiania bnc jako usługi
62 systemowej.
63
64 %prep
65 %setup -q -n %{name}%{version}
66 %patch0 -p1
67 %patch1 -p1
68
69 %build
70 cp -f /usr/share/automake/config.sub .
71 %{__autoconf}
72 %configure \
73         --with-ssl
74
75 %{__make} \
76         CFLAGS="%{rpmcflags} -include config.h"
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 install -d $RPM_BUILD_ROOT{/etc/{sysconfig,rc.d/init.d},%{_bindir},%{_sysconfdir},/var/{log,run/%{name}}}
81
82 install bnc $RPM_BUILD_ROOT%{_bindir}
83 install bncsetup $RPM_BUILD_ROOT%{_bindir}/bncsetup
84 install mkpasswd $RPM_BUILD_ROOT%{_bindir}/bncmkpasswd
85 install motd $RPM_BUILD_ROOT%{_sysconfdir}/motd
86 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
87 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
88 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
89 > $RPM_BUILD_ROOT/var/log/%{name}.log
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %pre init
95 %groupadd -g 142 %{name}
96 %useradd -u 142 -d /var/run/%{name} -s /bin/false -c "%{name} User" -g %{name} %{name}
97
98 %post init
99 if ! egrep -q '^(adminpass|password)' /etc/bnc/bnc.conf; then
100 %banner %{name} -e <<EOF
101 You need to setup passwords in %{_sysconfdir}/%{name}.conf!
102 The daemon will not start unless you've set them!
103
104 EOF
105 # ' vim
106
107 fi
108 /sbin/chkconfig --add %{name}
109 %service %{name} restart "%{name} daemon"
110
111 %preun init
112 if [ "$1" = "0" ]; then
113         %service %{name} stop
114         /sbin/chkconfig --del %{name}
115 fi
116
117 %postun init
118 if [ "$1" = "0" ]; then
119         %userremove %{name}
120         %groupremove %{name}
121 fi
122
123 %files
124 %defattr(644,root,root,755)
125 %doc README Changelog motd example.conf bncchk
126 %attr(755,root,root) %{_bindir}/*
127
128 %files init
129 %defattr(644,root,root,755)
130 %dir %attr(750,root,bnc) %{_sysconfdir}
131 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,bnc) %{_sysconfdir}/*
132 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
133 %attr(754,root,root) /etc/rc.d/init.d/%{name}
134 %dir %attr(770,root,bnc) /var/run/%{name}
135 %attr(620,bnc,bnc) %ghost /var/log/%{name}.log
This page took 0.072773 seconds and 3 git commands to generate.