]> git.pld-linux.org Git - packages/bluez.git/blob - bluez.spec
- updated to 5.9
[packages/bluez.git] / bluez.spec
1 # TODO:
2 # - verify/update bluetooth init script
3 # - update (or drop if it's no longer applicable) rfcomm init script
4 # - separate obexd here? / separate -client in obexd.spec
5 Summary:        Bluetooth utilities
6 Summary(pl.UTF-8):      Narzędzia Bluetooth
7 Name:           bluez
8 Version:        5.9
9 Release:        1
10 License:        GPL v2+
11 Group:          Applications/System
12 Source0:        https://www.kernel.org/pub/linux/bluetooth/%{name}-%{version}.tar.xz
13 # Source0-md5:  d002e7266ea180c9609e55360219a5bd
14 Source1:        %{name}.init
15 Source2:        %{name}.sysconfig
16 # FIXME: rfcomm.conf no longer supported
17 Source5:        rfcomm.init
18 Patch0:         %{name}-wacom-mode-2.patch
19 URL:            http://www.bluez.org/
20 BuildRequires:  autoconf >= 2.60
21 BuildRequires:  automake
22 BuildRequires:  check-devel >= 0.9.6
23 BuildRequires:  dbus-devel >= 1.4
24 BuildRequires:  glib2-devel >= 1:2.28
25 BuildRequires:  libical-devel
26 BuildRequires:  libtool
27 BuildRequires:  pkgconfig >= 1:0.9.0
28 BuildRequires:  readline-devel
29 BuildRequires:  rpmbuild(macros) >= 1.626
30 BuildRequires:  systemd-units >= 38
31 BuildRequires:  tar >= 1:1.22
32 BuildRequires:  udev-devel >= 1:143
33 BuildRequires:  xz
34 Requires(post,preun,postun):    systemd-units >= 38
35 Requires:       %{name}-libs = %{version}-%{release}
36 Requires:       dbus-libs >= 1.4
37 Requires:       glib2 >= 1:2.28
38 Requires:       hwdata >= 0.225
39 Requires:       rc-scripts
40 Requires:       systemd-units >= 38
41 Requires:       udev >= 1:143
42 Provides:       bluez-hcidump = %{version}
43 Provides:       bluez-utils = %{version}-%{release}
44 Provides:       obexd = %{version}
45 Provides:       dbus(org.openobex.client)
46 Provides:       obex-data-server = %{version}
47 # moved somewhere or dropped?
48 #Obsoletes:     alsa-plugins-bluetooth
49 Obsoletes:      bluez-hcidump
50 Obsoletes:      bluez-hciemu
51 Obsoletes:      bluez-pan
52 Obsoletes:      bluez-sdp
53 Obsoletes:      bluez-systemd
54 Obsoletes:      bluez-utils
55 Obsoletes:      bluez-utils-init
56 Obsoletes:      obexd
57 Obsoletes:      obex-data-server
58 # moved somewhere or dropped?
59 #Obsoletes:     gstreamer-bluetooth < 4.101-3
60 #Obsoletes:     gstreamer0.10-bluetooth < 5
61 Conflicts:      bluez-bluefw
62 ExcludeArch:    s390 s390x
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 # currently lib, not %{_lib} (see cups.spec)
66 %define         cupsdir         /usr/lib/cups/backend
67 %define         udevdir         /lib/udev
68
69 %description
70 Bluetooth utilities:
71  - bluetoothd
72  - hciattach
73  - hciconfig
74  - hcidump
75  - hcitool
76  - l2ping
77  - start scripts (PLD)
78
79 The BLUETOOTH trademarks are owned by Bluetooth SIG, Inc., U.S.A.
80
81 %description -l pl.UTF-8
82 Narzędzia Bluetooth:
83  - bluetoothd
84  - hciattach
85  - hciconfig
86  - hcidump
87  - hcitool
88  - l2ping
89  - skrypty startowe (PLD)
90
91 Znaki towarowe BLUETOOTH są własnością Bluetooth SIG, Inc. z USA.
92
93 %package -n cups-backend-bluetooth
94 Summary:        Bluetooth backend for CUPS
95 Summary(pl.UTF-8):      Backend Bluetooth dla CUPS-a
96 Group:          Applications/Printing
97 Requires:       bluez-libs >= %{version}-%{release}
98 Requires:       cups
99
100 %description -n cups-backend-bluetooth
101 Bluetooth backend for CUPS.
102
103 %description -n cups-backend-bluetooth -l pl.UTF-8
104 Backend Bluetooth dla CUPS-a.
105
106 %package libs
107 Summary:        Bluetooth libraries
108 Summary(pl.UTF-8):      Biblioteki Bluetooth
109 Group:          Libraries
110 Obsoletes:      bluez-sdp
111
112 %description libs
113 Libraries for use in Bluetooth applications.
114
115 The BLUETOOTH trademarks are owned by Bluetooth SIG, Inc., U.S.A.
116
117 %description libs -l pl.UTF-8
118 Biblioteki do używania w aplikacjach Bluetooth.
119
120 Znaki towarowe BLUETOOTH są własnością Bluetooth SIG, Inc. z USA.
121
122 %package libs-devel
123 Summary:        Header files for Bluetooth applications
124 Summary(pl.UTF-8):      Pliki nagłówkowe dla aplikacji Bluetooth
125 Group:          Development/Libraries
126 Requires:       %{name}-libs = %{version}-%{release}
127 Obsoletes:      bluez-sdp-devel
128
129 %description libs-devel
130 bluez-libs-devel contains header files for use in Bluetooth
131 applications.
132
133 %description libs-devel -l pl.UTF-8
134 Ten pakiet zawiera pliki nagłówkowe do używania w aplikacjach
135 Bluetooth.
136
137 %package libs-static
138 Summary:        Static Bluetooth libraries
139 Summary(pl.UTF-8):      Biblioteki statyczne Bluetooth
140 Group:          Development/Libraries
141 Requires:       %{name}-libs-devel = %{version}-%{release}
142 Obsoletes:      bluez-sdp-static
143
144 %description libs-static
145 bluez-libs-static contains development static libraries for use in
146 Bluetooth applications.
147
148 %description libs-static -l pl.UTF-8
149 Ten pakiet zawiera biblioteki statyczne, których można używać do
150 aplikacji Bluetooth.
151
152 %prep
153 %setup -q
154 %patch0 -p1
155
156 %build
157 %{__libtoolize}
158 %{__aclocal}
159 %{__autoconf}
160 %{__autoheader}
161 %{__automake}
162 %configure \
163         --disable-silent-rules \
164         --enable-library \
165         --enable-static
166 # these options are broken; BR systemd instead
167 #       --with-systemdsystemunitdir=%{systemdunitdir} \
168 #       --with-systemduserunitdir=%{_prefix}/lib/systemd/user \
169
170 %{__make} \
171         cupsdir=%{cupsdir} \
172         rulesdir=%{udevdir}/rules.d \
173         udevdir=%{udevdir}
174
175 %install
176 rm -rf $RPM_BUILD_ROOT
177 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig} \
178         $RPM_BUILD_ROOT{%{_libdir}/bluetooth/plugins,%{_sysconfdir}/bluetooth}
179
180 %{__make} install \
181         DESTDIR=$RPM_BUILD_ROOT \
182         cupsdir=%{cupsdir} \
183         rulesdir=%{udevdir}/rules.d \
184         udevdir=%{udevdir}
185
186 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/bluetooth
187 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/bluetooth
188 install %{SOURCE5} $RPM_BUILD_ROOT/etc/rc.d/init.d/rfcomm
189
190 install profiles/input/*.conf $RPM_BUILD_ROOT%{_sysconfdir}/bluetooth
191 install profiles/network/*.conf $RPM_BUILD_ROOT%{_sysconfdir}/bluetooth
192 install profiles/proximity/*.conf $RPM_BUILD_ROOT%{_sysconfdir}/bluetooth
193
194 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbluetooth.la
195
196 %clean
197 rm -rf $RPM_BUILD_ROOT
198
199 %post
200 /sbin/chkconfig --add bluetooth
201 /sbin/chkconfig --add rfcomm
202 %service bluetooth restart
203 %service rfcomm restart
204 %systemd_post bluetooth.service
205
206 %preun
207 if [ "$1" = "0" ]; then
208         %service bluetooth stop
209         %service rfcomm stop
210         /sbin/chkconfig --del bluetooth
211         /sbin/chkconfig --del rfcomm
212 fi
213 %systemd_preun bluetooth.service
214
215 %postun
216 %systemd_reload
217
218 %triggerpostun -- bluez < 4.98-3
219 %systemd_trigger bluetooth.service
220
221 %post   libs -p /sbin/ldconfig
222 %postun libs -p /sbin/ldconfig
223
224 %files
225 %defattr(644,root,root,755)
226 %doc AUTHORS ChangeLog README
227 %attr(755,root,root) %{_bindir}/bccmd
228 %attr(755,root,root) %{_bindir}/bluetoothctl
229 %attr(755,root,root) %{_bindir}/btmon
230 %attr(755,root,root) %{_bindir}/ciptool
231 %attr(755,root,root) %{_bindir}/hciattach
232 %attr(755,root,root) %{_bindir}/hciconfig
233 %attr(755,root,root) %{_bindir}/hcidump
234 %attr(755,root,root) %{_bindir}/hcitool
235 %attr(755,root,root) %{_bindir}/l2ping
236 %attr(755,root,root) %{_bindir}/l2test
237 %attr(755,root,root) %{_bindir}/rctest
238 %attr(755,root,root) %{_bindir}/rfcomm
239 %attr(755,root,root) %{_bindir}/sdptool
240 %dir %{_libdir}/bluetooth
241 %attr(755,root,root) %{_libdir}/bluetooth/bluetoothd
242 %attr(755,root,root) %{_libdir}/bluetooth/obexd
243 %dir %{_libdir}/bluetooth/plugins
244 %dir %{_sysconfdir}/bluetooth
245 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bluetooth/input.conf
246 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bluetooth/network.conf
247 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bluetooth/proximity.conf
248 %attr(754,root,root) /etc/rc.d/init.d/bluetooth
249 %attr(754,root,root) /etc/rc.d/init.d/rfcomm
250 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bluetooth
251 %config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/bluetooth.conf
252 %{systemdunitdir}/bluetooth.service
253 %{_prefix}/lib/systemd/user/obex.service
254 %{_datadir}/dbus-1/system-services/org.bluez.service
255 %{_datadir}/dbus-1/services/org.bluez.obex.service
256 %attr(755,root,root) %{udevdir}/hid2hci
257 %{udevdir}/rules.d/97-hid2hci.rules
258 %{_mandir}/man1/bccmd.1*
259 %{_mandir}/man1/ciptool.1*
260 %{_mandir}/man1/hciattach.1*
261 %{_mandir}/man1/hciconfig.1*
262 %{_mandir}/man1/hcidump.1*
263 %{_mandir}/man1/hcitool.1*
264 %{_mandir}/man1/hid2hci.1*
265 %{_mandir}/man1/l2ping.1*
266 %{_mandir}/man1/rctest.1*
267 %{_mandir}/man1/rfcomm.1*
268 %{_mandir}/man1/sdptool.1*
269 %{_mandir}/man8/bluetoothd.8*
270
271 %files -n cups-backend-bluetooth
272 %defattr(644,root,root,755)
273 %attr(755,root,root) %{_prefix}/lib/cups/backend/bluetooth
274
275 %files libs
276 %defattr(644,root,root,755)
277 %attr(755,root,root) %{_libdir}/libbluetooth.so.*.*.*
278 %attr(755,root,root) %ghost %{_libdir}/libbluetooth.so.3
279
280 %files libs-devel
281 %defattr(644,root,root,755)
282 %attr(755,root,root) %{_libdir}/libbluetooth.so
283 %{_includedir}/bluetooth
284 %{_pkgconfigdir}/bluez.pc
285
286 %files libs-static
287 %defattr(644,root,root,755)
288 %{_libdir}/libbluetooth.a
This page took 0.096357 seconds and 4 git commands to generate.