]> git.pld-linux.org Git - packages/bluez-utils.git/blob - bluez-utils.spec
- Conflicts: bluez-bluefw (hotplug stuff)
[packages/bluez-utils.git] / bluez-utils.spec
1 # TODO:
2 # - check init script, add support for rfcomm bind on startup
3 #
4 Summary:        Bluetooth utilities
5 Summary(pl):    Narzêdzia Bluetooth
6 Name:           bluez-utils
7 Version:        2.10
8 Release:        1
9 License:        GPL v2
10 Group:          Applications/System
11 Source0:        http://bluez.sourceforge.net/download/%{name}-%{version}.tar.gz
12 # Source0-md5:  4f936b90e32eb24904dea70bd0a464f0
13 Source1:        %{name}.init
14 Source2:        %{name}.sysconfig
15 Patch0:         %{name}-etc_dir.patch
16 URL:            http://bluez.sourceforge.net/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  bison
20 BuildRequires:  bluez-libs-devel >= 2.10
21 BuildRequires:  dbus-devel
22 BuildRequires:  libtool
23 BuildRequires:  libusb-devel
24 PreReq:         rc-scripts
25 Requires:       bluez-libs >= 2.10
26 Obsoletes:      blues-pan
27 Obsoletes:      bluez-sdp
28 Conflicts:      bluez-bluefw
29 ExcludeArch:    s390 s390x
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 # currently lib, not %{_lib} (see cups.spec)
33 %define         cupsdir         /usr/lib/cups/backend
34
35 %description
36 Bluetooth utilities:
37  - hcitool
38  - hciattach
39  - hciconfig
40  - hcid
41  - l2ping
42  - start scripts (PLD)
43  - PCMCIA configuration files
44
45 The BLUETOOTH trademarks are owned by Bluetooth SIG, Inc., U.S.A.
46
47 %description -l pl
48 Narzêdzia Bluetooth:
49  - hcitool
50  - hciattach
51  - hciconfig
52  - hcid
53  - l2ping
54  - skrypty startowe (PLD)
55  - pliki konfiguracji PCMCIA
56
57 %package -n cups-backend-bluetooth
58 Summary:        Bluetooth backend for CUPS
59 Summary(pl):    Backend Bluetooth dla CUPS-a
60 Group:          Applications/Printing
61 Requires:       bluez-libs >= 2.10
62 Requires:       cups
63
64 %description -n cups-backend-bluetooth
65 Bluetooth backend for CUPS.
66
67 %description -n cups-backend-bluetooth -l pl
68 Backend Bluetooth dla CUPS-a.
69
70 %package init
71 Summary:        Init script for Bluetooth subsystem
72 Summary(pl):    Skrypt init dla podsystemu Bluetooth
73 Group:          Applications/System
74 Requires:       %{name} = %{epoch}:%{version}-%{release}
75 Requires(post,preun):   /sbin/chkconfig
76
77 %description init
78 Init script for Bluetooth subsystem.
79
80 %description init -l pl
81 Skrypt init dla podsystemu Bluetooth.
82
83 %prep
84 %setup -q
85 %patch0 -p1
86
87 %build
88 %{__libtoolize}
89 %{__aclocal}
90 %{__autoconf}
91 %{__automake}
92 %configure \
93         --enable-bcm203x \
94         --enable-cups \
95         --enable-pcmcia \
96         --with-cups=/usr
97 %{__make} \
98         cupsdir=%{cupsdir}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT \
106         cupsdir=%{cupsdir}
107
108 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/bluetooth
109 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/bluetooth
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post init
115 /sbin/chkconfig --add bluetooth
116 if [ -f /var/lock/subsys/bluetooth ]; then
117         /etc/rc.d/init.d/bluetooth restart >&2
118 else
119         echo "Run \"/etc/rc.d/init.d/bluetooth\" to start bluetooth." >&2
120 fi
121
122 %postun init
123 if [ "$1" = "0" ]; then
124         if [ -f /var/lock/subsys/bluetooth ]; then
125                 /etc/rc.d/init.d/bluetooth stop 1>&2
126         fi
127         /sbin/chkconfig --del bluetooth
128 fi
129
130 %files
131 %defattr(644,root,root,755)
132 %doc AUTHORS ChangeLog README
133 %attr(755,root,root) %{_bindir}/*
134 %attr(755,root,root) %{_sbindir}/*
135 %{_mandir}/man*/*
136 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/bluetooth
137 %dir %{_sysconfdir}/bluetooth
138 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/bluetooth/*
139 %attr(755,root,root) %{_sysconfdir}/hotplug/usb/bcm203x
140 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/hotplug/usb/bcm203x.usermap
141 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/pcmcia/bluetooth.conf
142 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/pcmcia/bluetooth
143
144 %files -n cups-backend-bluetooth
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_prefix}/lib/cups/backend/bluetooth
147
148 %files init
149 %defattr(644,root,root,755)
150 %attr(754,root,root) /etc/rc.d/init.d/bluetooth
This page took 0.045099 seconds and 4 git commands to generate.