]> git.pld-linux.org Git - packages/bluez-utils.git/blob - bluez-utils.spec
- merged invalid-timeval,poll-timeout patches and files update from AC-branch
[packages/bluez-utils.git] / bluez-utils.spec
1 Summary:        Bluetooth utilities
2 Summary(pl):    Narzêdzia Bluetooth
3 Name:           bluez-utils
4 Version:        2.25
5 Release:        4
6 Epoch:          0
7 License:        GPL v2
8 Group:          Applications/System
9 Source0:        http://bluez.sourceforge.net/download/%{name}-%{version}.tar.gz
10 # Source0-md5:  ae3729ab5592be06ed01b973d4b3e9fe
11 Source1:        %{name}.init
12 Source2:        %{name}.sysconfig
13 Source3:        %{name}-udev.rules
14 Source4:        %{name}-udev.script
15 Patch0:         %{name}-etc_dir.patch
16 Patch1:         %{name}-invalid-timeval.patch
17 Patch2:         %{name}-poll-timeout.patch
18 URL:            http://bluez.sourceforge.net/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  bison
22 BuildRequires:  bluez-libs-devel >= 2.25
23 BuildRequires:  dbus-devel >= 0.33
24 BuildRequires:  libtool
25 BuildRequires:  libusb-devel
26 BuildRequires:  rpmbuild(macros) >= 1.268
27 # alsa-lib-devel, openobex-devel - currently only checked for, not used
28 Requires:       bluez-libs >= 2.21
29 Requires:       rc-scripts
30 Obsoletes:      bluez-pan
31 Obsoletes:      bluez-sdp
32 Conflicts:      bluez-bluefw
33 ExcludeArch:    s390 s390x
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 # currently lib, not %{_lib} (see cups.spec)
37 %define         cupsdir         /usr/lib/cups/backend
38
39 %description
40 Bluetooth utilities:
41  - hcitool
42  - hciattach
43  - hciconfig
44  - hcid
45  - l2ping
46  - start scripts (PLD)
47  - PCMCIA configuration files
48
49 The BLUETOOTH trademarks are owned by Bluetooth SIG, Inc., U.S.A.
50
51 %description -l pl
52 Narzêdzia Bluetooth:
53  - hcitool
54  - hciattach
55  - hciconfig
56  - hcid
57  - l2ping
58  - skrypty startowe (PLD)
59  - pliki konfiguracji PCMCIA
60
61 %package -n cups-backend-bluetooth
62 Summary:        Bluetooth backend for CUPS
63 Summary(pl):    Backend Bluetooth dla CUPS-a
64 Group:          Applications/Printing
65 Requires:       bluez-libs >= 2.21
66 Requires:       cups
67
68 %description -n cups-backend-bluetooth
69 Bluetooth backend for CUPS.
70
71 %description -n cups-backend-bluetooth -l pl
72 Backend Bluetooth dla CUPS-a.
73
74 %package init
75 Summary:        Init script for Bluetooth subsystem
76 Summary(pl):    Skrypt init dla podsystemu Bluetooth
77 Group:          Applications/System
78 Requires(post,preun):   /sbin/chkconfig
79 Requires:       %{name} = %{epoch}:%{version}-%{release}
80
81 %description init
82 Init script for Bluetooth subsystem.
83
84 %description init -l pl
85 Skrypt init dla podsystemu Bluetooth.
86
87 %prep
88 %setup -q
89 %patch0 -p1
90 %patch1 -p1
91 %patch2 -p1
92
93 %build
94 %{__libtoolize}
95 %{__aclocal}
96 %{__autoconf}
97 %{__automake}
98 %configure \
99         --enable-bcm203x \
100         --enable-cups \
101         --enable-pcmcia \
102         --with-cups=/usr
103 %{__make} \
104         cupsdir=%{cupsdir}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
109 install -d $RPM_BUILD_ROOT{/etc/udev/rules.d,/lib/udev}
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT \
113         cupsdir=%{cupsdir}
114
115 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/bluetooth
116 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/bluetooth
117 install %{SOURCE3} $RPM_BUILD_ROOT/etc/udev/rules.d/70-bluetooth.rules
118 install %{SOURCE4} $RPM_BUILD_ROOT/lib/udev/bluetooth.sh
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post init
124 /sbin/chkconfig --add bluetooth
125 %service bluetooth restart
126
127 %preun init
128 if [ "$1" = "0" ]; then
129         %service bluetooth stop
130         /sbin/chkconfig --del bluetooth
131 fi
132
133 %files
134 %defattr(644,root,root,755)
135 %doc AUTHORS ChangeLog README
136 %attr(755,root,root) %{_bindir}/*
137 %attr(755,root,root) %{_sbindir}/*
138 %{_mandir}/man*/*
139 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bluetooth
140 %dir %{_sysconfdir}/bluetooth
141 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bluetooth/*
142 %attr(755,root,root) %{_sysconfdir}/hotplug/usb/bcm203x
143 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dbus-1/system.d/*
144 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hotplug/usb/bcm203x.usermap
145 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pcmcia/bluetooth
146 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pcmcia/bluetooth.conf
147
148 %files -n cups-backend-bluetooth
149 %defattr(644,root,root,755)
150 %attr(755,root,root) %{_prefix}/lib/cups/backend/bluetooth
151
152 %files init
153 %defattr(644,root,root,755)
154 %attr(754,root,root) /etc/rc.d/init.d/bluetooth
155 %attr(755,root,root) /lib/udev/bluetooth.sh
156 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/70-bluetooth.rules
This page took 0.052867 seconds and 4 git commands to generate.