]> git.pld-linux.org Git - packages/bluez-utils.git/blob - bluez-utils.spec
- needs bluez-libs 3.4
[packages/bluez-utils.git] / bluez-utils.spec
1 Summary:        Bluetooth utilities
2 Summary(pl):    Narzêdzia Bluetooth
3 Name:           bluez-utils
4 Version:        3.4
5 Release:        1
6 Epoch:          0
7 License:        GPL v2
8 Group:          Applications/System
9 #Source0Download: http://www.bluez.org/download.html
10 Source0:        http://bluez.sourceforge.net/download/%{name}-%{version}.tar.gz
11 # Source0-md5:  f63b440396baee7dee9259395a205d48
12 Source1:        %{name}.init
13 Source2:        %{name}.sysconfig
14 Source3:        %{name}-udev.rules
15 Source4:        %{name}-udev.script
16 Patch0:         %{name}-etc_dir.patch
17 URL:            http://www.bluez.org/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  bison
21 BuildRequires:  bluez-libs-devel >= 3.4
22 BuildRequires:  dbus-glib-devel >= 0.35
23 BuildRequires:  libtool
24 BuildRequires:  libusb-devel
25 BuildRequires:  pkgconfig
26 BuildRequires:  rpmbuild(macros) >= 1.268
27 # for future use (ALSA plugins not finished)
28 #BuildRequires: alsa-lib-devel >= 0.9
29 # for future use (fuse module is just testing stub now)
30 #BuildRequires: libfuse-devel
31 #BuildRequires: openobex-devel >= 1.1
32 Requires:       bluez-libs >= 3.4
33 Requires:       rc-scripts
34 Obsoletes:      bluez-pan
35 Obsoletes:      bluez-sdp
36 Obsoletes:      bluez-utils-init
37 Conflicts:      bluez-bluefw
38 ExcludeArch:    s390 s390x
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 # currently lib, not %{_lib} (see cups.spec)
42 %define         cupsdir         /usr/lib/cups/backend
43
44 %description
45 Bluetooth utilities:
46  - hcitool
47  - hciattach
48  - hciconfig
49  - hcid
50  - l2ping
51  - start scripts (PLD)
52  - PCMCIA configuration files
53
54 The BLUETOOTH trademarks are owned by Bluetooth SIG, Inc., U.S.A.
55
56 %description -l pl
57 Narzêdzia Bluetooth:
58  - hcitool
59  - hciattach
60  - hciconfig
61  - hcid
62  - l2ping
63  - skrypty startowe (PLD)
64  - pliki konfiguracji PCMCIA
65
66 %package -n cups-backend-bluetooth
67 Summary:        Bluetooth backend for CUPS
68 Summary(pl):    Backend Bluetooth dla CUPS-a
69 Group:          Applications/Printing
70 Requires:       bluez-libs >= 3.4
71 Requires:       cups
72
73 %description -n cups-backend-bluetooth
74 Bluetooth backend for CUPS.
75
76 %description -n cups-backend-bluetooth -l pl
77 Backend Bluetooth dla CUPS-a.
78
79 %package init
80 Summary:        Init script for Bluetooth subsystem
81 Summary(pl):    Skrypt init dla podsystemu Bluetooth
82 Group:          Applications/System
83 Requires(post,preun):   /sbin/chkconfig
84 Requires:       %{name} = %{epoch}:%{version}-%{release}
85
86 %description init
87 Init script for Bluetooth subsystem.
88
89 %description init -l pl
90 Skrypt init dla podsystemu Bluetooth.
91
92 %prep
93 %setup -q
94 %patch0 -p1
95
96 %build
97 %{__libtoolize}
98 %{__aclocal}
99 %{__autoconf}
100 %{__automake}
101 %configure \
102         --enable-avctrl \
103         --enable-bccmd \
104         --enable-cups \
105         --enable-dfutool \
106         --enable-pcmciarules \
107         --with-cups=/usr
108 %{__make} \
109         cupsdir=%{cupsdir}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
114 install -d $RPM_BUILD_ROOT{/etc/udev/rules.d,/lib/udev}
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT \
118         cupsdir=%{cupsdir} \
119         udevdir=/lib/udev
120
121 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/bluetooth
122 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/bluetooth
123 install %{SOURCE3} $RPM_BUILD_ROOT/etc/udev/rules.d/70-bluetooth.rules
124 install %{SOURCE4} $RPM_BUILD_ROOT/lib/udev/bluetooth.sh
125
126 mv $RPM_BUILD_ROOT/etc/udev/bluetooth.rules \
127         $RPM_BUILD_ROOT/etc/udev/rules.d/71-bluetooth.rules
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post init
133 /sbin/chkconfig --add bluetooth
134 %service bluetooth restart
135
136 %preun init
137 if [ "$1" = "0" ]; then
138         %service bluetooth stop
139         /sbin/chkconfig --del bluetooth
140 fi
141
142 %files
143 %defattr(644,root,root,755)
144 %doc AUTHORS ChangeLog README
145 %attr(755,root,root) %{_bindir}/*
146 %attr(755,root,root) %{_sbindir}/*
147 %{_mandir}/man*/*
148
149 %attr(754,root,root) /etc/rc.d/init.d/bluetooth
150 %attr(755,root,root) /lib/udev/bluetooth.sh
151 %attr(755,root,root) /lib/udev/bluetooth_serial
152 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/70-bluetooth.rules
153 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/71-bluetooth.rules
154
155 %dir /etc/bluetooth
156 %dir /etc/sysconfig/bluetooth
157 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bluetooth
158 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bluetooth/*
159 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dbus-1/system.d/*
160
161 %files -n cups-backend-bluetooth
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_prefix}/lib/cups/backend/bluetooth
This page took 0.093728 seconds and 3 git commands to generate.