]> git.pld-linux.org Git - packages/bluez-utils.git/blob - bluez-utils.spec
8dfa1ad08599d9d9c452e7f59a69c5559c2c0c18
[packages/bluez-utils.git] / bluez-utils.spec
1 Summary:        Bluetooth utilities
2 Summary(pl.UTF-8):      Narzędzia Bluetooth
3 Name:           bluez-utils
4 Version:        3.13
5 Release:        1
6 Epoch:          0
7 License:        GPL v2+
8 Group:          Applications/System
9 #Source0Download: http://www.bluez.org/download.html
10 Source0:        http://bluez.sourceforge.net/download/%{name}-%{version}.tar.gz
11 # Source0-md5:  88df46a585b5823729f23adee58426d3
12 Source1:        %{name}.init
13 Source2:        %{name}.sysconfig
14 Source3:        %{name}-udev.rules
15 Source4:        %{name}-udev.script
16 Patch0:         %{name}-etc_dir.patch
17 URL:            http://www.bluez.org/
18 BuildRequires:  alsa-lib-devel >= 1.0.10-1
19 BuildRequires:  autoconf >= 2.50
20 BuildRequires:  automake
21 BuildRequires:  bison
22 BuildRequires:  bluez-libs-devel >= 3.12
23 BuildRequires:  dbus-glib-devel >= 0.60
24 BuildRequires:  glib2-devel >= 2.0
25 BuildRequires:  hal-devel >= 0.5.8
26 BuildRequires:  libtool
27 BuildRequires:  libusb-devel
28 BuildRequires:  pkgconfig
29 BuildRequires:  rpmbuild(macros) >= 1.268
30 # used only by noinst bluetoothd-service-sync
31 #BuildRequires: libopensync-devel
32 # used only by noinst bluetoothd-service-transfer
33 #BuildRequires: openobex-devel >= 1.1
34 Requires:       bluez-libs >= 3.12
35 Requires:       rc-scripts
36 Obsoletes:      bluez-pan
37 Obsoletes:      bluez-sdp
38 Obsoletes:      bluez-utils-init
39 Conflicts:      bluez-bluefw
40 ExcludeArch:    s390 s390x
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 # currently lib, not %{_lib} (see cups.spec)
44 %define         cupsdir         /usr/lib/cups/backend
45
46 %description
47 Bluetooth utilities:
48  - hcitool
49  - hciattach
50  - hciconfig
51  - hcid
52  - l2ping
53  - start scripts (PLD)
54  - PCMCIA configuration files
55
56 The BLUETOOTH trademarks are owned by Bluetooth SIG, Inc., U.S.A.
57
58 %description -l pl.UTF-8
59 Narzędzia Bluetooth:
60  - hcitool
61  - hciattach
62  - hciconfig
63  - hcid
64  - l2ping
65  - skrypty startowe (PLD)
66  - pliki konfiguracji PCMCIA
67
68 Znaki towarowe BLUETOOTH są własnością Bluetooth SIG, Inc. z USA.
69
70 %package -n alsa-plugins-bluetooth
71 Summary:        ALSA plugins for Bluetooth audio devices
72 Summary(pl.UTF-8):      Wtyczki systemu ALSA dla urządzeń dźwiękowych Bluetooth
73 Group:          Libraries
74 # bluetoothd + audio service
75 Requires:       %{name} = %{epoch}:%{version}-%{release}
76 Requires:       alsa-lib >= 1.0.10-1
77
78 %description -n alsa-plugins-bluetooth
79 ALSA plugins for Bluetooth audio devices.
80
81 %description -n alsa-plugins-bluetooth -l pl.UTF-8
82 Wtyczki systemu ALSA dla urządzeń dźwiękowych Bluetooth.
83
84 %package -n cups-backend-bluetooth
85 Summary:        Bluetooth backend for CUPS
86 Summary(pl.UTF-8):      Backend Bluetooth dla CUPS-a
87 Group:          Applications/Printing
88 Requires:       bluez-libs >= 3.12
89 Requires:       cups
90
91 %description -n cups-backend-bluetooth
92 Bluetooth backend for CUPS.
93
94 %description -n cups-backend-bluetooth -l pl.UTF-8
95 Backend Bluetooth dla CUPS-a.
96
97 %prep
98 %setup -q
99 %patch0 -p1
100
101 %build
102 %{__libtoolize}
103 %{__aclocal}
104 %{__autoconf}
105 %{__autoheader}
106 %{__automake}
107 %configure \
108         --enable-audio \
109         --enable-avctrl \
110         --enable-bccmd \
111         --enable-cups \
112         --enable-dfutool \
113         --enable-glib \
114         --enable-network \
115         --enable-pcmciarules \
116         --enable-serial \
117         --with-cups=/usr
118 %{__make} \
119         cupsdir=%{cupsdir}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
124 install -d $RPM_BUILD_ROOT{/etc/udev/rules.d,/lib/udev}
125
126 %{__make} install \
127         DESTDIR=$RPM_BUILD_ROOT \
128         cupsdir=%{cupsdir} \
129         udevdir=/lib/udev
130
131 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/bluetooth
132 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/bluetooth
133 install %{SOURCE3} $RPM_BUILD_ROOT/etc/udev/rules.d/70-bluetooth.rules
134 install %{SOURCE4} $RPM_BUILD_ROOT/lib/udev/bluetooth.sh
135 install daemon/passkey-agent $RPM_BUILD_ROOT/%{_bindir}
136 mv $RPM_BUILD_ROOT/etc/udev/bluetooth.rules \
137         $RPM_BUILD_ROOT/etc/udev/rules.d/71-bluetooth.rules
138
139 rm -f $RPM_BUILD_ROOT%{_libdir}/alsa-lib/*.la
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post
145 /sbin/chkconfig --add bluetooth
146 %service bluetooth restart
147
148 %preun
149 if [ "$1" = "0" ]; then
150         %service bluetooth stop
151         /sbin/chkconfig --del bluetooth
152 fi
153
154 %files
155 %defattr(644,root,root,755)
156 %doc AUTHORS ChangeLog README audio/audio-api.txt daemon/hal-namespace.txt hcid/dbus-api.txt input/input-api.txt network/network-api.txt serial/serial-api.txt
157 %attr(755,root,root) %{_bindir}/*
158 %attr(755,root,root) %{_sbindir}/*
159 %dir %{_libdir}/bluetooth
160 %attr(755,root,root) %{_libdir}/bluetooth/bluetoothd-service-audio
161 %attr(755,root,root) %{_libdir}/bluetooth/bluetoothd-service-network
162 %attr(755,root,root) %{_libdir}/bluetooth/bluetoothd-service-serial
163 %dir %{_sysconfdir}/bluetooth
164 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bluetooth/hcid.conf
165 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bluetooth/rfcomm.conf
166 %{_sysconfdir}/bluetooth/audio.service
167 %{_sysconfdir}/bluetooth/network.service
168 %{_sysconfdir}/bluetooth/serial.service
169 %attr(754,root,root) /etc/rc.d/init.d/bluetooth
170 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bluetooth
171 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dbus-1/system.d/bluetooth.conf
172 %attr(755,root,root) /lib/udev/bluetooth.sh
173 %attr(755,root,root) /lib/udev/bluetooth_serial
174 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/70-bluetooth.rules
175 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/71-bluetooth.rules
176 %{_mandir}/man[18]/*
177 %{_mandir}/man5/hcid.conf.5*
178
179 %files -n alsa-plugins-bluetooth
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{_libdir}/alsa-lib/libasound_module_ctl_bluetooth.so
182 %attr(755,root,root) %{_libdir}/alsa-lib/libasound_module_pcm_bluetooth.so
183
184 %files -n cups-backend-bluetooth
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{_prefix}/lib/cups/backend/bluetooth
This page took 0.057683 seconds and 2 git commands to generate.