]> git.pld-linux.org Git - packages/bluez-utils.git/blame_incremental - bluez-utils.spec
- typo?
[packages/bluez-utils.git] / bluez-utils.spec
... / ...
CommitLineData
1Summary: Bluetooth utilities
2Summary(pl.UTF-8): Narzędzia Bluetooth
3Name: bluez-utils
4Version: 3.16
5Release: 2
6Epoch: 0
7License: GPL v2+
8Group: Applications/System
9#Source0Download: http://www.bluez.org/download.html
10Source0: http://bluez.sourceforge.net/download/%{name}-%{version}.tar.gz
11# Source0-md5: f6e5bf09d5f282671aa0abe50e700ee6
12Source1: %{name}.init
13Source2: %{name}.sysconfig
14Source3: %{name}-udev.rules
15Source4: %{name}-udev.script
16Patch0: %{name}-etc_dir.patch
17URL: http://www.bluez.org/
18BuildRequires: alsa-lib-devel >= 1.0.10-1
19BuildRequires: autoconf >= 2.50
20BuildRequires: automake
21BuildRequires: bison
22BuildRequires: bluez-libs-devel >= 3.16
23BuildRequires: dbus-glib-devel >= 0.60
24BuildRequires: glib2-devel >= 2.0
25BuildRequires: gstreamer-devel
26BuildRequires: hal-devel >= 0.5.8
27BuildRequires: libtool
28BuildRequires: libusb-devel
29BuildRequires: pkgconfig >= 0.9.0
30BuildRequires: rpmbuild(macros) >= 1.268
31# used only by noinst bluetoothd-service-sync
32#BuildRequires: libopensync-devel
33# used only by noinst bluetoothd-service-transfer
34#BuildRequires: openobex-devel >= 1.1
35Requires: bluez-libs >= 3.16
36Requires: rc-scripts
37Obsoletes: bluez-pan
38Obsoletes: bluez-sdp
39Obsoletes: bluez-utils-init
40Conflicts: bluez-bluefw
41ExcludeArch: s390 s390x
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44# currently lib, not %{_lib} (see cups.spec)
45%define cupsdir /usr/lib/cups/backend
46
47%description
48Bluetooth utilities:
49 - hcitool
50 - hciattach
51 - hciconfig
52 - hcid
53 - l2ping
54 - start scripts (PLD)
55 - PCMCIA configuration files
56
57The BLUETOOTH trademarks are owned by Bluetooth SIG, Inc., U.S.A.
58
59%description -l pl.UTF-8
60Narzędzia Bluetooth:
61 - hcitool
62 - hciattach
63 - hciconfig
64 - hcid
65 - l2ping
66 - skrypty startowe (PLD)
67 - pliki konfiguracji PCMCIA
68
69Znaki towarowe BLUETOOTH są własnością Bluetooth SIG, Inc. z USA.
70
71%package -n alsa-plugins-bluetooth
72Summary: ALSA plugins for Bluetooth audio devices
73Summary(pl.UTF-8): Wtyczki systemu ALSA dla urządzeń dźwiękowych Bluetooth
74Group: Libraries
75# bluetoothd + audio service
76Requires: %{name} = %{epoch}:%{version}-%{release}
77Requires: alsa-lib >= 1.0.10-1
78
79%description -n alsa-plugins-bluetooth
80ALSA plugins for Bluetooth audio devices.
81
82%description -n alsa-plugins-bluetooth -l pl.UTF-8
83Wtyczki systemu ALSA dla urządzeń dźwiękowych Bluetooth.
84
85%package -n cups-backend-bluetooth
86Summary: Bluetooth backend for CUPS
87Summary(pl.UTF-8): Backend Bluetooth dla CUPS-a
88Group: Applications/Printing
89Requires: bluez-libs >= 3.16
90Requires: cups
91
92%description -n cups-backend-bluetooth
93Bluetooth backend for CUPS.
94
95%description -n cups-backend-bluetooth -l pl.UTF-8
96Backend Bluetooth dla CUPS-a.
97
98%package -n gstreamer-bluetooth
99Summary: Bluetooth support for gstreamer
100Summary(pl.UTF-8): Obsługa Bluetooth dla gstreamera
101Group: Libraries
102Requires: bluez-libs >= 3.16
103Requires: gstreamer
104
105%description -n gstreamer-bluetooth
106Bluetooth support for gstreamer.
107
108%description -n gstreamer-bluetooth -l pl.UTF-8
109Obsługa Bluetooth dla gstreamera.
110
111%prep
112%setup -q
113%patch0 -p1
114
115%build
116%{__libtoolize}
117%{__aclocal}
118%{__autoconf}
119%{__autoheader}
120%{__automake}
121%configure \
122 --enable-audio \
123 --enable-avctrl \
124 --enable-bccmd \
125 --enable-cups \
126 --enable-dfutool \
127 --enable-glib \
128 --enable-gstreamer \
129 --enable-input \
130 --enable-network \
131 --enable-pcmciarules \
132 --enable-serial \
133 --enable-test \
134 --with-cups=/usr
135
136%{__make} \
137 cupsdir=%{cupsdir}
138
139%install
140rm -rf $RPM_BUILD_ROOT
141install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
142install -d $RPM_BUILD_ROOT{/etc/udev/rules.d,/lib/udev}
143
144%{__make} install \
145 DESTDIR=$RPM_BUILD_ROOT \
146 cupsdir=%{cupsdir} \
147 udevdir=/lib/udev
148
149install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/bluetooth
150install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/bluetooth
151install %{SOURCE3} $RPM_BUILD_ROOT/etc/udev/rules.d/70-bluetooth.rules
152install %{SOURCE4} $RPM_BUILD_ROOT/lib/udev/bluetooth.sh
153install daemon/passkey-agent $RPM_BUILD_ROOT/%{_bindir}
154mv $RPM_BUILD_ROOT/etc/udev/bluetooth.rules \
155 $RPM_BUILD_ROOT/etc/udev/rules.d/71-bluetooth.rules
156
157rm -f $RPM_BUILD_ROOT%{_libdir}/alsa-lib/*.la
158
159%clean
160rm -rf $RPM_BUILD_ROOT
161
162%post
163/sbin/chkconfig --add bluetooth
164%service bluetooth restart
165
166%preun
167if [ "$1" = "0" ]; then
168 %service bluetooth stop
169 /sbin/chkconfig --del bluetooth
170fi
171
172%files
173%defattr(644,root,root,755)
174%doc AUTHORS ChangeLog README audio/audio-api.txt daemon/hal-namespace.txt hcid/dbus-api.txt input/input-api.txt network/network-api.txt serial/serial-api.txt
175%attr(755,root,root) %{_bindir}/*
176%attr(755,root,root) %{_sbindir}/*
177%dir %{_libdir}/bluetooth
178%attr(755,root,root) %{_libdir}/bluetooth/bluetoothd-service-audio
179%attr(755,root,root) %{_libdir}/bluetooth/bluetoothd-service-network
180%attr(755,root,root) %{_libdir}/bluetooth/bluetoothd-service-serial
181%attr(755,root,root) %{_libdir}/bluetooth/bluetoothd-service-input
182%dir %{_sysconfdir}/bluetooth
183%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bluetooth/hcid.conf
184%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bluetooth/rfcomm.conf
185%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bluetooth/input.service
186%{_sysconfdir}/bluetooth/audio.service
187%{_sysconfdir}/bluetooth/network.service
188%{_sysconfdir}/bluetooth/serial.service
189%attr(754,root,root) /etc/rc.d/init.d/bluetooth
190%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bluetooth
191%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dbus-1/system.d/bluetooth.conf
192%attr(755,root,root) /lib/udev/bluetooth.sh
193%attr(755,root,root) /lib/udev/bluetooth_serial
194%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/70-bluetooth.rules
195%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/71-bluetooth.rules
196%{_mandir}/man[18]/*
197%{_mandir}/man5/hcid.conf.5*
198
199%files -n alsa-plugins-bluetooth
200%defattr(644,root,root,755)
201%attr(755,root,root) %{_libdir}/alsa-lib/libasound_module_ctl_bluetooth.so
202%attr(755,root,root) %{_libdir}/alsa-lib/libasound_module_pcm_bluetooth.so
203
204%files -n cups-backend-bluetooth
205%defattr(644,root,root,755)
206%attr(755,root,root) %{_prefix}/lib/cups/backend/bluetooth
207
208%files -n gstreamer-bluetooth
209%defattr(644,root,root,755)
210%attr(755,root,root) %{_libdir}/gstreamer*/libgstbluetooth.so
This page took 0.058769 seconds and 4 git commands to generate.