]> git.pld-linux.org Git - packages/blueman.git/commitdiff
- added missing status icons auto/th/blueman-1.23-3
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 18 Dec 2013 07:36:51 +0000 (08:36 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 18 Dec 2013 07:36:51 +0000 (08:36 +0100)
- rel 3

blueman-statusicon.patch [deleted file]
blueman.spec
icon-active.patch [new file with mode: 0644]
missing-icons.patch [new file with mode: 0644]

diff --git a/blueman-statusicon.patch b/blueman-statusicon.patch
deleted file mode 100644 (file)
index 1031b62..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- blueman-1.23/blueman/plugins/applet/StatusIcon.py.orig     2012-04-26 23:52:01.900955192 +0200
-+++ blueman-1.23/blueman/plugins/applet/StatusIcon.py  2012-04-26 23:52:34.882160450 +0200
-@@ -68,7 +68,7 @@
-               entry.connect("changed", self.on_entry_changed, ic, image)
-               
-       __options__ = {"icon": {"type": str,
--                                                      "default": "blueman-tray",
-+                                                      "default": "bluetooth",
-                                                       "name": _("Icon Name"),
-                                                       "desc": _("Custom icon to use for the notification area"),
-                                                       "decorator": widget_decorator
-@@ -166,7 +166,7 @@
-               self.QueryVisibility()
-               
-       def on_status_icon_resized(self):
--              self.icon = "blueman-tray"
-+              self.icon = "bluetooth"
-               
-               #p = gtk.gdk.Pixbuf(gtk.gdk.COLORSPACE_RGB, True, 8, 22, 22)
-               #p.fill(0)
index 87a087365625233adb5f00526bdaf55405c7d3a9..b760281b56972f5cdca86c39b0a12304740c8839 100644 (file)
@@ -6,17 +6,19 @@
 Summary:       Blueman - bluetooth management utility for GNOME
 Name:          blueman
 Version:       1.23
-Release:       2
+Release:       3
 License:       GPL
 Group:         Applications
 Source0:       http://download.tuxfamily.org/blueman/%{name}-%{version}.tar.gz
 # Source0-md5: f0bee59589f4c23e35bf08c2ef8acaef
-Patch0:                %{name}-statusicon.patch
+Patch0:                missing-icons.patch
+Patch1:                icon-active.patch
 URL:           http://blueman.tuxfamily.org/
 BuildRequires: bluez-libs-devel
 BuildRequires: gettext-devel
 BuildRequires: gnome-bluetooth-devel
 BuildRequires: intltool
+BuildRequires: librsvg
 BuildRequires: pkgconfig
 BuildRequires: python-Pyrex
 BuildRequires: python-dbus-devel
@@ -61,6 +63,7 @@ Features:
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %configure \
@@ -74,6 +77,18 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+for s in 16 32 48 ; do
+       install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${s}x${s}/status
+       rsvg-convert -w $s -h $s -o $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${s}x${s}/status/blueman-tray.png \
+               data/icons/hicolor/scalable/status/blueman-tray.svg
+       rsvg-convert -w $s -h $s -o $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${s}x${s}/status/blueman-tray-active.png \
+               data/icons/hicolor/scalable/status/blueman-tray-active.svg
+       rsvg-convert -w $s -h $s -o $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${s}x${s}/status/blueman-tray-disabled.png \
+               data/icons/hicolor/scalable/status/blueman-tray-disabled.svg
+done
+install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/status
+install data/icons/hicolor/scalable/status/*.svg $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/status
+
 %find_lang %{name} --with-gnome
 
 %clean
@@ -94,7 +109,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/%{name}
 %{_datadir}/dbus-1/system-services/org.blueman.Mechanism.service
 %{_iconsdir}/hicolor/scalable/*/*.svg
-%{_iconsdir}/hicolor/*/apps/*.png
+%{_iconsdir}/hicolor/*/*/*.png
 %{_datadir}/polkit-1/actions/org.blueman.policy
 %{_desktopdir}/blueman-manager.desktop
 %{py_sitedir}/*.so
diff --git a/icon-active.patch b/icon-active.patch
new file mode 100644 (file)
index 0000000..0aff7ee
--- /dev/null
@@ -0,0 +1,12 @@
+Index: blueman-1.23/blueman/plugins/applet/PowerManager.py
+===================================================================
+--- blueman-1.23.orig/blueman/plugins/applet/PowerManager.py   2011-10-08 21:09:16.000000000 +0200
++++ blueman-1.23/blueman/plugins/applet/PowerManager.py        2012-09-27 02:14:10.481892534 +0200
+@@ -243,6 +243,7 @@
+               #return pixbuf
+               if not self.GetBluetoothStatus():
+                       return ("blueman-tray-disabled", "bluetooth-disabled") 
++              return ("blueman-tray-active", "bluetooth-active")
+               
+       def on_adapter_added(self, path):
+               adapter = Bluez.Adapter(path)
diff --git a/missing-icons.patch b/missing-icons.patch
new file mode 100644 (file)
index 0000000..0d2aa6b
--- /dev/null
@@ -0,0 +1,555 @@
+commit 9863fb99aa384e42b8349d505af77c071f8cb6e6
+Author: Christopher Schramm <cschramm@shakaweb.org>
+Date:   Sun Oct 13 10:01:32 2013 +0200
+
+    Add missing icons (fixes #2)
+
+diff --git a/data/icons/hicolor/scalable/status/Makefile.am b/data/icons/hicolor/scalable/status/Makefile.am
+index f0ddd52..2082dfc 100644
+--- a/data/icons/hicolor/scalable/status/Makefile.am
++++ b/data/icons/hicolor/scalable/status/Makefile.am
+@@ -4,6 +4,6 @@ context = status
+ iconsdir = $(themedir)/$(size)/$(context)
+-icons_DATA = blueman-tray-active.svg
++icons_DATA = blueman-tray-active.svg blueman-tray-disabled.svg blueman-tray.svg
+ EXTRA_DIST = $(icons_DATA)
+diff --git a/data/icons/hicolor/scalable/status/blueman-tray-disabled.svg b/data/icons/hicolor/scalable/status/blueman-tray-disabled.svg
+new file mode 100644
+index 0000000..8ee5fe0
+--- /dev/null
++++ b/data/icons/hicolor/scalable/status/blueman-tray-disabled.svg
+@@ -0,0 +1,291 @@
++<?xml version="1.0" encoding="UTF-8" standalone="no"?>
++<!-- Created with Inkscape (http://www.inkscape.org/) -->
++
++<svg
++   xmlns:dc="http://purl.org/dc/elements/1.1/"
++   xmlns:cc="http://creativecommons.org/ns#"
++   xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
++   xmlns:svg="http://www.w3.org/2000/svg"
++   xmlns="http://www.w3.org/2000/svg"
++   xmlns:xlink="http://www.w3.org/1999/xlink"
++   xmlns:sodipodi="http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd"
++   xmlns:inkscape="http://www.inkscape.org/namespaces/inkscape"
++   width="48"
++   height="48"
++   id="svg2160"
++   sodipodi:version="0.32"
++   inkscape:version="0.48.4 r9939"
++   version="1.0"
++   sodipodi:docname="blueman-tray-disabled.svg"
++   inkscape:output_extension="org.inkscape.output.svg.inkscape"
++   inkscape:export-filename="/home/andreas/Desktop/bluetooth/bluetooth-applet-16.png"
++   inkscape:export-xdpi="90"
++   inkscape:export-ydpi="90">
++  <defs
++     id="defs2162">
++    <linearGradient
++       inkscape:collect="always"
++       id="linearGradient3393">
++      <stop
++         style="stop-color:#729fcf;stop-opacity:1;"
++         offset="0"
++         id="stop3395" />
++      <stop
++         style="stop-color:#729fcf;stop-opacity:0;"
++         offset="1"
++         id="stop3397" />
++    </linearGradient>
++    <linearGradient
++       inkscape:collect="always"
++       id="linearGradient3383">
++      <stop
++         style="stop-color:#729fcf;stop-opacity:1"
++         offset="0"
++         id="stop3385" />
++      <stop
++         style="stop-color:#3465a4;stop-opacity:1"
++         offset="1"
++         id="stop3387" />
++    </linearGradient>
++    <linearGradient
++       id="linearGradient4140"
++       inkscape:collect="always">
++      <stop
++         id="stop4142"
++         offset="0"
++         style="stop-color:#ffffff;stop-opacity:1" />
++      <stop
++         id="stop4144"
++         offset="1"
++         style="stop-color:#ffffff;stop-opacity:0" />
++    </linearGradient>
++    <linearGradient
++       id="linearGradient8692"
++       inkscape:collect="always">
++      <stop
++         id="stop8694"
++         offset="0"
++         style="stop-color:#000000;stop-opacity:1;" />
++      <stop
++         id="stop8696"
++         offset="1"
++         style="stop-color:#000000;stop-opacity:0;" />
++    </linearGradient>
++    <filter
++       inkscape:collect="always"
++       id="filter3274">
++      <feGaussianBlur
++         inkscape:collect="always"
++         stdDeviation="0.511583"
++         id="feGaussianBlur3276" />
++    </filter>
++    <radialGradient
++       inkscape:collect="always"
++       xlink:href="#linearGradient8692"
++       id="radialGradient3286"
++       gradientUnits="userSpaceOnUse"
++       gradientTransform="matrix(0.8963782,0,6.4445216e-6,0.1737589,2.7974976,36.922651)"
++       cx="27"
++       cy="45.047184"
++       fx="27"
++       fy="45.047184"
++       r="17.625" />
++    <radialGradient
++       inkscape:collect="always"
++       xlink:href="#linearGradient3383"
++       id="radialGradient3288"
++       gradientUnits="userSpaceOnUse"
++       gradientTransform="matrix(2.9717705,-0.4142331,0.1691176,1.2132755,-27.792082,-2.2504815)"
++       cx="10.930984"
++       cy="8.4716578"
++       fx="10.930984"
++       fy="8.4716578"
++       r="17.000002" />
++    <linearGradient
++       inkscape:collect="always"
++       xlink:href="#linearGradient3393"
++       id="linearGradient3290"
++       gradientUnits="userSpaceOnUse"
++       x1="23.25"
++       y1="48.216961"
++       x2="23.25"
++       y2="32.278145" />
++    <linearGradient
++       inkscape:collect="always"
++       xlink:href="#linearGradient4140"
++       id="linearGradient3292"
++       gradientUnits="userSpaceOnUse"
++       gradientTransform="matrix(2.8151854,0,0,2.6854398,-6.9670375,-7.8825588)"
++       x1="8.2285843"
++       y1="7.8516045"
++       x2="19.823189"
++       y2="24.029535" />
++  </defs>
++  <sodipodi:namedview
++     id="base"
++     pagecolor="#ffffff"
++     bordercolor="#666666"
++     borderopacity="1.0"
++     inkscape:pageopacity="0.0"
++     inkscape:pageshadow="2"
++     inkscape:zoom="1"
++     inkscape:cx="-29.207866"
++     inkscape:cy="23.321019"
++     inkscape:current-layer="layer1"
++     showgrid="false"
++     inkscape:grid-bbox="true"
++     inkscape:document-units="px"
++     width="48px"
++     height="48px"
++     inkscape:window-width="872"
++     inkscape:window-height="740"
++     inkscape:window-x="347"
++     inkscape:window-y="1"
++     inkscape:grid-points="true"
++     inkscape:showpageshadow="false"
++     showborder="false"
++     inkscape:window-maximized="0">
++    <inkscape:grid
++       id="GridFromPre046Settings"
++       type="xygrid"
++       originx="0px"
++       originy="0px"
++       spacingx="0.5px"
++       spacingy="0.5px"
++       color="#3f3fff"
++       empcolor="#3f3fff"
++       opacity="0.15"
++       empopacity="0.38"
++       empspacing="2" />
++  </sodipodi:namedview>
++  <metadata
++     id="metadata2165">
++    <rdf:RDF>
++      <cc:Work
++         rdf:about="">
++        <dc:format>image/svg+xml</dc:format>
++        <dc:type
++           rdf:resource="http://purl.org/dc/dcmitype/StillImage" />
++        <cc:license
++           rdf:resource="http://creativecommons.org/licenses/GPL/2.0/" />
++        <dc:title></dc:title>
++      </cc:Work>
++      <cc:License
++         rdf:about="http://creativecommons.org/licenses/GPL/2.0/">
++        <cc:permits
++           rdf:resource="http://web.resource.org/cc/Reproduction" />
++        <cc:permits
++           rdf:resource="http://web.resource.org/cc/Distribution" />
++        <cc:requires
++           rdf:resource="http://web.resource.org/cc/Notice" />
++        <cc:permits
++           rdf:resource="http://web.resource.org/cc/DerivativeWorks" />
++        <cc:requires
++           rdf:resource="http://web.resource.org/cc/ShareAlike" />
++        <cc:requires
++           rdf:resource="http://web.resource.org/cc/SourceCode" />
++      </cc:License>
++    </rdf:RDF>
++  </metadata>
++  <g
++     id="layer1"
++     inkscape:label="Layer 1"
++     inkscape:groupmode="layer">
++    <g
++       id="g3278"
++       transform="translate(0,1)">
++      <path
++         transform="matrix(1.0212766,0,0,1.2040816,-3.5744683,-10.244898)"
++         d="m 44.625,44.6875 c 0,1.691372 -7.890981,3.0625 -17.625,3.0625 -9.734019,0 -17.625,-1.371128 -17.625,-3.0625 0,-1.691372 7.890981,-3.0625 17.625,-3.0625 9.734019,0 17.625,1.371128 17.625,3.0625 z"
++         sodipodi:ry="3.0625"
++         sodipodi:rx="17.625"
++         sodipodi:cy="44.6875"
++         sodipodi:cx="27"
++         id="path3361"
++         style="opacity:0.46330273;fill:url(#radialGradient3286);fill-opacity:1;stroke:none;stroke-width:0.80671531;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1"
++         sodipodi:type="arc" />
++      <rect
++         ry="16.484543"
++         rx="16.484543"
++         y="0.51545823"
++         x="7.5154586"
++         height="44.969082"
++         width="32.969086"
++         id="rect3363"
++         style="color:#000000;fill:url(#radialGradient3288);fill-opacity:1;fill-rule:evenodd;stroke:#204a87;stroke-width:1.03091633;stroke-linecap:butt;stroke-linejoin:miter;marker:none;marker-start:none;marker-mid:none;marker-end:none;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;visibility:visible;display:inline;overflow:visible" />
++      <rect
++         ry="16.129303"
++         rx="15.999998"
++         y="0.99999833"
++         x="8.0000029"
++         height="44"
++         width="31.999996"
++         id="rect3391"
++         style="color:#000000;fill:url(#linearGradient3290);fill-opacity:1;fill-rule:evenodd;stroke:none;stroke-width:1.03091633;stroke-linecap:butt;stroke-linejoin:miter;marker:none;marker-start:none;marker-mid:none;marker-end:none;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;visibility:visible;display:inline;overflow:visible" />
++      <rect
++         ry="15.48352"
++         rx="15.48352"
++         y="1.516481"
++         x="8.5164804"
++         height="42.967037"
++         width="30.967039"
++         id="rect3365"
++         style="opacity:0.39768342;color:#000000;fill:none;fill-opacity:1;fill-rule:evenodd;stroke:url(#linearGradient3292);stroke-width:1.03296196;stroke-linecap:butt;stroke-linejoin:miter;marker:none;marker-start:none;marker-mid:none;marker-end:none;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;visibility:visible;display:inline;overflow:visible" />
++      <path
++         sodipodi:nodetypes="cccccc"
++         id="path3401"
++         d="M 14.638608,32.077196 L 32.499999,16.291697 L 23.58028,7.4999996 L 23.553586,36.5 L 32.493732,27.775843 L 14.500001,14.606097"
++         style="fill:none;fill-rule:evenodd;stroke:#3465a4;stroke-width:3;stroke-linecap:butt;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-opacity:1;filter:url(#filter3274)" />
++      <path
++         sodipodi:nodetypes="cccccc"
++         id="path3367"
++         d="M 14.638608,33.077196 L 32.499999,17.291697 L 23.58028,8.4999996 L 23.553586,37.5 L 32.493732,28.775843 L 14.500001,15.606097"
++         style="fill:none;fill-rule:evenodd;stroke:#ffffff;stroke-width:3;stroke-linecap:butt;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-opacity:1" />
++    </g>
++    <g
++       inkscape:label="Layer 1"
++       id="g3679"
++       transform="matrix(1.5000146,0,0,1.4999942,63.224033,3.1271527)">
++      <g
++         transform="translate(-53.549142,-0.2846614)"
++         style="display:inline"
++         inkscape:label="Muted"
++         id="layer4">
++        <g
++           transform="translate(-2,0)"
++           id="g4694">
++          <rect
++             style="fill:#ef2929;fill-opacity:1;stroke:#cc0000;stroke-width:0.9964897;stroke-linecap:round;stroke-linejoin:round;stroke-miterlimit:4;stroke-opacity:1;stroke-dasharray:none;stroke-dashoffset:1.20000057;display:inline"
++             id="rect2021"
++             width="12.00351"
++             height="12.00351"
++             x="31.498245"
++             y="16.498245"
++             rx="1.4868355"
++             ry="1.4868355" />
++          <rect
++             style="opacity:0.3;fill:none;stroke:#ffffff;stroke-width:0.99999988;stroke-linecap:round;stroke-linejoin:round;stroke-miterlimit:4;stroke-opacity:1;stroke-dasharray:none;stroke-dashoffset:1.20000057;display:inline"
++             id="rect3795"
++             width="9.9999962"
++             height="9.9999962"
++             x="32.5"
++             y="17.500002"
++             rx="0.4861359"
++             ry="0.4861359" />
++          <path
++             inkscape:connector-curvature="0"
++             style="fill:none;stroke:#ffffff;stroke-width:1.5;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-opacity:1;stroke-dasharray:none"
++             d="m 35,20 5,5"
++             id="path4682"
++             sodipodi:nodetypes="cc" />
++          <path
++             inkscape:connector-curvature="0"
++             style="fill:none;stroke:#ffffff;stroke-width:1.5;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-opacity:1;stroke-dasharray:none;display:inline"
++             d="m 40,20 -5,5"
++             id="path4684"
++             sodipodi:nodetypes="cc" />
++        </g>
++      </g>
++    </g>
++  </g>
++</svg>
+diff --git a/data/icons/hicolor/scalable/status/blueman-tray.svg b/data/icons/hicolor/scalable/status/blueman-tray.svg
+new file mode 100644
+index 0000000..3624a88
+--- /dev/null
++++ b/data/icons/hicolor/scalable/status/blueman-tray.svg
+@@ -0,0 +1,234 @@
++<?xml version="1.0" encoding="UTF-8" standalone="no"?>
++<!-- Created with Inkscape (http://www.inkscape.org/) -->
++<svg
++   xmlns:dc="http://purl.org/dc/elements/1.1/"
++   xmlns:cc="http://web.resource.org/cc/"
++   xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
++   xmlns:svg="http://www.w3.org/2000/svg"
++   xmlns="http://www.w3.org/2000/svg"
++   xmlns:xlink="http://www.w3.org/1999/xlink"
++   xmlns:sodipodi="http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd"
++   xmlns:inkscape="http://www.inkscape.org/namespaces/inkscape"
++   width="48"
++   height="48"
++   id="svg2160"
++   sodipodi:version="0.32"
++   inkscape:version="0.45.1"
++   version="1.0"
++   sodipodi:docname="bluetooth-applet-48.svg"
++   sodipodi:docbase="/home/lapo/Scrivania/bluetooth-icons"
++   inkscape:output_extension="org.inkscape.output.svg.inkscape"
++   inkscape:export-filename="/home/andreas/Desktop/bluetooth/bluetooth-applet-16.png"
++   inkscape:export-xdpi="90"
++   inkscape:export-ydpi="90">
++  <defs
++     id="defs2162">
++    <linearGradient
++       inkscape:collect="always"
++       id="linearGradient3393">
++      <stop
++         style="stop-color:#729fcf;stop-opacity:1;"
++         offset="0"
++         id="stop3395" />
++      <stop
++         style="stop-color:#729fcf;stop-opacity:0;"
++         offset="1"
++         id="stop3397" />
++    </linearGradient>
++    <linearGradient
++       inkscape:collect="always"
++       id="linearGradient3383">
++      <stop
++         style="stop-color:#729fcf;stop-opacity:1"
++         offset="0"
++         id="stop3385" />
++      <stop
++         style="stop-color:#3465a4;stop-opacity:1"
++         offset="1"
++         id="stop3387" />
++    </linearGradient>
++    <linearGradient
++       id="linearGradient4140"
++       inkscape:collect="always">
++      <stop
++         id="stop4142"
++         offset="0"
++         style="stop-color:#ffffff;stop-opacity:1" />
++      <stop
++         id="stop4144"
++         offset="1"
++         style="stop-color:#ffffff;stop-opacity:0" />
++    </linearGradient>
++    <linearGradient
++       id="linearGradient8692"
++       inkscape:collect="always">
++      <stop
++         id="stop8694"
++         offset="0"
++         style="stop-color:#000000;stop-opacity:1;" />
++      <stop
++         id="stop8696"
++         offset="1"
++         style="stop-color:#000000;stop-opacity:0;" />
++    </linearGradient>
++    <filter
++       inkscape:collect="always"
++       id="filter3274">
++      <feGaussianBlur
++         inkscape:collect="always"
++         stdDeviation="0.511583"
++         id="feGaussianBlur3276" />
++    </filter>
++    <radialGradient
++       inkscape:collect="always"
++       xlink:href="#linearGradient8692"
++       id="radialGradient3286"
++       gradientUnits="userSpaceOnUse"
++       gradientTransform="matrix(0.8963782,0,6.4445216e-6,0.1737589,2.7974976,36.922651)"
++       cx="27"
++       cy="45.047184"
++       fx="27"
++       fy="45.047184"
++       r="17.625" />
++    <radialGradient
++       inkscape:collect="always"
++       xlink:href="#linearGradient3383"
++       id="radialGradient3288"
++       gradientUnits="userSpaceOnUse"
++       gradientTransform="matrix(2.9717705,-0.4142331,0.1691176,1.2132755,-27.792082,-2.2504815)"
++       cx="10.930984"
++       cy="8.4716578"
++       fx="10.930984"
++       fy="8.4716578"
++       r="17.000002" />
++    <linearGradient
++       inkscape:collect="always"
++       xlink:href="#linearGradient3393"
++       id="linearGradient3290"
++       gradientUnits="userSpaceOnUse"
++       x1="23.25"
++       y1="48.216961"
++       x2="23.25"
++       y2="32.278145" />
++    <linearGradient
++       inkscape:collect="always"
++       xlink:href="#linearGradient4140"
++       id="linearGradient3292"
++       gradientUnits="userSpaceOnUse"
++       gradientTransform="matrix(2.8151854,0,0,2.6854398,-6.9670375,-7.8825588)"
++       x1="8.2285843"
++       y1="7.8516045"
++       x2="19.823189"
++       y2="24.029535" />
++  </defs>
++  <sodipodi:namedview
++     id="base"
++     pagecolor="#ffffff"
++     bordercolor="#666666"
++     borderopacity="1.0"
++     inkscape:pageopacity="0.0"
++     inkscape:pageshadow="2"
++     inkscape:zoom="1"
++     inkscape:cx="-31.207866"
++     inkscape:cy="23.321019"
++     inkscape:current-layer="layer1"
++     showgrid="false"
++     inkscape:grid-bbox="true"
++     inkscape:document-units="px"
++     width="48px"
++     height="48px"
++     inkscape:window-width="872"
++     inkscape:window-height="946"
++     inkscape:window-x="418"
++     inkscape:window-y="49"
++     gridspacingx="0.5px"
++     gridspacingy="0.5px"
++     gridempspacing="2"
++     inkscape:grid-points="true"
++     inkscape:showpageshadow="false"
++     showborder="false" />
++  <metadata
++     id="metadata2165">
++    <rdf:RDF>
++      <cc:Work
++         rdf:about="">
++        <dc:format>image/svg+xml</dc:format>
++        <dc:type
++           rdf:resource="http://purl.org/dc/dcmitype/StillImage" />
++        <cc:license
++           rdf:resource="http://creativecommons.org/licenses/GPL/2.0/" />
++      </cc:Work>
++      <cc:License
++         rdf:about="http://creativecommons.org/licenses/GPL/2.0/">
++        <cc:permits
++           rdf:resource="http://web.resource.org/cc/Reproduction" />
++        <cc:permits
++           rdf:resource="http://web.resource.org/cc/Distribution" />
++        <cc:requires
++           rdf:resource="http://web.resource.org/cc/Notice" />
++        <cc:permits
++           rdf:resource="http://web.resource.org/cc/DerivativeWorks" />
++        <cc:requires
++           rdf:resource="http://web.resource.org/cc/ShareAlike" />
++        <cc:requires
++           rdf:resource="http://web.resource.org/cc/SourceCode" />
++      </cc:License>
++    </rdf:RDF>
++  </metadata>
++  <g
++     id="layer1"
++     inkscape:label="Layer 1"
++     inkscape:groupmode="layer">
++    <g
++       id="g3278"
++       transform="translate(0,1)">
++      <path
++         transform="matrix(1.0212766,0,0,1.2040816,-3.5744683,-10.244898)"
++         d="M 44.625 44.6875 A 17.625 3.0625 0 1 1  9.375,44.6875 A 17.625 3.0625 0 1 1  44.625 44.6875 z"
++         sodipodi:ry="3.0625"
++         sodipodi:rx="17.625"
++         sodipodi:cy="44.6875"
++         sodipodi:cx="27"
++         id="path3361"
++         style="opacity:0.46330273;fill:url(#radialGradient3286);fill-opacity:1;stroke:none;stroke-width:0.80671531;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1"
++         sodipodi:type="arc" />
++      <rect
++         ry="16.484543"
++         rx="16.484543"
++         y="0.51545823"
++         x="7.5154586"
++         height="44.969082"
++         width="32.969086"
++         id="rect3363"
++         style="color:#000000;fill:url(#radialGradient3288);fill-opacity:1;fill-rule:evenodd;stroke:#204a87;stroke-width:1.03091633;stroke-linecap:butt;stroke-linejoin:miter;marker:none;marker-start:none;marker-mid:none;marker-end:none;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;visibility:visible;display:inline;overflow:visible" />
++      <rect
++         ry="16.129303"
++         rx="15.999998"
++         y="0.99999833"
++         x="8.0000029"
++         height="44"
++         width="31.999996"
++         id="rect3391"
++         style="color:#000000;fill:url(#linearGradient3290);fill-opacity:1;fill-rule:evenodd;stroke:none;stroke-width:1.03091633;stroke-linecap:butt;stroke-linejoin:miter;marker:none;marker-start:none;marker-mid:none;marker-end:none;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;visibility:visible;display:inline;overflow:visible" />
++      <rect
++         ry="15.48352"
++         rx="15.48352"
++         y="1.516481"
++         x="8.5164804"
++         height="42.967037"
++         width="30.967039"
++         id="rect3365"
++         style="opacity:0.39768342;color:#000000;fill:none;fill-opacity:1;fill-rule:evenodd;stroke:url(#linearGradient3292);stroke-width:1.03296196;stroke-linecap:butt;stroke-linejoin:miter;marker:none;marker-start:none;marker-mid:none;marker-end:none;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;visibility:visible;display:inline;overflow:visible" />
++      <path
++         sodipodi:nodetypes="cccccc"
++         id="path3401"
++         d="M 14.638608,32.077196 L 32.499999,16.291697 L 23.58028,7.4999996 L 23.553586,36.5 L 32.493732,27.775843 L 14.500001,14.606097"
++         style="fill:none;fill-rule:evenodd;stroke:#3465a4;stroke-width:3;stroke-linecap:butt;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-opacity:1;filter:url(#filter3274)" />
++      <path
++         sodipodi:nodetypes="cccccc"
++         id="path3367"
++         d="M 14.638608,33.077196 L 32.499999,17.291697 L 23.58028,8.4999996 L 23.553586,37.5 L 32.493732,28.775843 L 14.500001,15.606097"
++         style="fill:none;fill-rule:evenodd;stroke:#ffffff;stroke-width:3;stroke-linecap:butt;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-opacity:1" />
++    </g>
++  </g>
++</svg>
This page took 0.065801 seconds and 4 git commands to generate.