]> git.pld-linux.org Git - packages/blueman.git/blob - blueman.spec
c5b7cdbbbc7741af9b878895c264a25119b2486e
[packages/blueman.git] / blueman.spec
1 Summary:        Blueman - bluetooth management utility for GNOME
2 Name:           blueman
3 Version:        2.0
4 Release:        2
5 License:        GPL
6 Group:          X11/Applications
7 Source0:        https://github.com/blueman-project/blueman/releases/download/%{version}/%{name}-%{version}.tar.xz
8 # Source0-md5:  d95270145475ce41a33bf7390afe3428
9 URL:            https://github.com/blueman-project/blueman
10 BuildRequires:  autoconf
11 BuildRequires:  automake
12 BuildRequires:  bluez-libs-devel >= 4.61
13 BuildRequires:  gettext-tools
14 BuildRequires:  glib2-devel >= 2.32
15 BuildRequires:  gtk+3-devel >= 3.12
16 BuildRequires:  intltool >= 0.35.0
17 BuildRequires:  libtool
18 BuildRequires:  pkgconfig >= 0.9.0
19 BuildRequires:  python-Cython
20 BuildRequires:  python-dbus
21 BuildRequires:  python-devel >= 2.7
22 BuildRequires:  python-pygobject3-common-devel
23 BuildRequires:  rpm-pythonprov
24 Requires(post,postun):  gtk-update-icon-cache
25 Requires(post,postun):  hicolor-icon-theme
26 Requires:       bluez-libs >= 4.25
27 Requires:       bluez-utils >= 4.25
28 Requires:       gtk+3 >= 3.12
29 Requires:       python >= %py_ver
30 Requires:       python-appindicator-gtk2
31 Requires:       python-bluetooth
32 Requires:       python-dbus
33 Requires:       python-pygtk-gtk
34 Requires:       python-pynotify
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Blueman is a GTK+ bluetooth management utility for GNOME using bluez
39 dbus backend. The aim is to create a full featured graphical bluetooth
40 manager for Linux.
41
42 Features:
43
44 - Easy to use interface
45 - Storing Favourite devices
46 - Send files
47 - Browse files on devices
48 - List all seen devices
49 - View Local/Remote Device information
50 - View transfer speeds and link quality
51 - Configure local devices
52 - Manage Pairing (Bonding)
53 - Host/Connect to Personal Area Networks
54 - Bind services to /dev/rfcomm ports, for eg. connecting via gprs
55 - Connect and receive connections from: audio, network, input and
56   serial devices
57
58 %package thunar
59 Summary:        Blueman plugin for Thunar
60 Summary(pl.UTF-8):      Wtyczka Blueman-a dla Thunar-a
61 Group:          X11/Applications
62
63 %description thunar
64 Blueman plugin for Thunar.
65
66 %description thunar -l pl.UTF-8
67 Wtyczka Blueman-a dla Thunar-a.
68
69 %prep
70 %setup -q
71
72 %build
73 %{__aclocal}
74 %{__autoheader}
75 %{__libtoolize}
76 %{__intltoolize}
77 %{__automake}
78 %{__autoconf}
79 %configure \
80         --enable-xfce-settings=yes \
81         --disable-static \
82         --disable-schemas-compile \
83
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
92 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_blueman.la
93
94 %find_lang %{name} --with-gnome
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post
100 %update_icon_cache hicolor
101 glib-compile-schemas %{_datadir}/glib-2.0/schemas
102
103 %postun
104 %update_icon_cache hicolor
105 glib-compile-schemas %{_datadir}/glib-2.0/schemas
106
107 %files -f %{name}.lang
108 %defattr(644,root,root,755)
109 %doc README.md CHANGELOG.md COPYING FAQ
110 %config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/org.blueman.Mechanism.conf
111 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/autostart/blueman.desktop
112 %attr(755,root,root) %{_bindir}/blueman-adapters
113 %attr(755,root,root) %{_bindir}/blueman-applet
114 %attr(755,root,root) %{_bindir}/blueman-assistant
115 %attr(755,root,root) %{_bindir}/blueman-browse
116 %attr(755,root,root) %{_bindir}/blueman-manager
117 %attr(755,root,root) %{_bindir}/blueman-report
118 %attr(755,root,root) %{_bindir}/blueman-sendto
119 %attr(755,root,root) %{_bindir}/blueman-services
120 %{_mandir}/man1/blueman-adapters.1*
121 %{_mandir}/man1/blueman-applet.1*
122 %{_mandir}/man1/blueman-assistant.1*
123 %{_mandir}/man1/blueman-browse.1*
124 %{_mandir}/man1/blueman-manager.1*
125 %{_mandir}/man1/blueman-report.1
126 %{_mandir}/man1/blueman-sendto.1*
127 %{_mandir}/man1/blueman-services.1*
128 %attr(755,root,root) %{_libdir}/%{name}-mechanism
129 %attr(755,root,root) %{_libdir}/%{name}-rfcomm-watcher
130 %{_datadir}/%{name}
131 %{_datadir}/dbus-1/system-services/org.blueman.Mechanism.service
132 %{_desktopdir}/blueman-manager.desktop
133 %{_desktopdir}/blueman-adapters.desktop
134 %{_iconsdir}/hicolor/scalable/*/*.svg
135 %{_iconsdir}/hicolor/*/*/*.png
136 %dir %{_pixmapsdir}/blueman
137 %{_pixmapsdir}/blueman/blueman-*.png
138 %{_datadir}/glib-2.0/schemas/org.blueman.gschema.xml
139 %{_datadir}/dbus-1/services/blueman-applet.service
140 %{_datadir}/polkit-1/actions/org.blueman.policy
141 %attr(755,root,root) %{py_sitedir}/_blueman.so
142 %{py_sitescriptdir}/%{name}
143
144 %files thunar
145 %defattr(644,root,root,755)
146 %{_datadir}/Thunar/sendto/thunar-sendto-blueman.desktop
This page took 0.031893 seconds and 2 git commands to generate.