]> git.pld-linux.org Git - packages/blueman.git/blob - blueman.spec
vebrose files in system dirs; fix python .so permission
[packages/blueman.git] / blueman.spec
1 Summary:        Blueman - bluetooth management utility for GNOME
2 Name:           blueman
3 Version:        2.0
4 Release:        2
5 License:        GPL
6 Group:          X11/Applications
7 Source0:        https://github.com/blueman-project/blueman/releases/download/%{version}/%{name}-%{version}.tar.xz
8 # Source0-md5:  d95270145475ce41a33bf7390afe3428
9 URL:            https://github.com/blueman-project/blueman
10 BuildRequires:  autoconf
11 BuildRequires:  automake
12 BuildRequires:  bluez-libs-devel >= 4.61
13 BuildRequires:  gettext-tools
14 BuildRequires:  glib2-devel >= 2.32
15 BuildRequires:  gtk+3-devel >= 3.12
16 BuildRequires:  intltool >= 0.35.0
17 BuildRequires:  libtool
18 BuildRequires:  pkgconfig >= 0.9.0
19 BuildRequires:  python-Cython
20 BuildRequires:  python-dbus
21 BuildRequires:  python-devel >= 2.7
22 BuildRequires:  python-pygobject3-common-devel
23 BuildRequires:  rpm-pythonprov
24 Requires(post,postun):  gtk-update-icon-cache
25 Requires(post,postun):  hicolor-icon-theme
26 Requires:       bluez-libs >= 4.25
27 Requires:       bluez-utils >= 4.25
28 Requires:       gtk+3 >= 3.12
29 Requires:       python >= %py_ver
30 Requires:       python-appindicator-gtk2
31 Requires:       python-bluetooth
32 Requires:       python-dbus
33 Requires:       python-pygtk-gtk
34 Requires:       python-pynotify
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Blueman is a GTK+ bluetooth management utility for GNOME using bluez
39 dbus backend. The aim is to create a full featured graphical bluetooth
40 manager for Linux.
41
42 Features:
43
44 - Easy to use interface
45 - Storing Favourite devices
46 - Send files
47 - Browse files on devices
48 - List all seen devices
49 - View Local/Remote Device information
50 - View transfer speeds and link quality
51 - Configure local devices
52 - Manage Pairing (Bonding)
53 - Host/Connect to Personal Area Networks
54 - Bind services to /dev/rfcomm ports, for eg. connecting via gprs
55 - Connect and receive connections from: audio, network, input and
56   serial devices
57
58 %package thunar
59 Summary:        Blueman plugin for Thunar
60 Summary(pl.UTF-8):      Wtyczka Blueman-a dla Thunar-a
61 Group:          X11/Applications
62
63 %description thunar
64 Blueman plugin for Thunar.
65
66 %description thunar -l pl.UTF-8
67 Wtyczka Blueman-a dla Thunar-a.
68
69 %prep
70 %setup -q
71
72 %build
73 export NOCONFIGURE='yes' && ./autogen.sh \
74         --enable-xfce-settings=yes \
75         --no-configure
76 %configure \
77         --disable-static \
78         --disable-schemas-compile \
79
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
88 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_blueman.la
89
90 %find_lang %{name} --with-gnome
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post
96 %update_icon_cache hicolor
97 glib-compile-schemas %{_datadir}/glib-2.0/schemas
98
99 %postun
100 %update_icon_cache hicolor
101 glib-compile-schemas %{_datadir}/glib-2.0/schemas
102
103 %files -f %{name}.lang
104 %defattr(644,root,root,755)
105 %doc README.md CHANGELOG.md COPYING FAQ
106 %config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/org.blueman.Mechanism.conf
107 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/autostart/blueman.desktop
108 %attr(755,root,root) %{_bindir}/blueman-adapters
109 %attr(755,root,root) %{_bindir}/blueman-applet
110 %attr(755,root,root) %{_bindir}/blueman-assistant
111 %attr(755,root,root) %{_bindir}/blueman-browse
112 %attr(755,root,root) %{_bindir}/blueman-manager
113 %attr(755,root,root) %{_bindir}/blueman-report
114 %attr(755,root,root) %{_bindir}/blueman-sendto
115 %attr(755,root,root) %{_bindir}/blueman-services
116 %{_mandir}/man1/blueman-adapters.1*
117 %{_mandir}/man1/blueman-applet.1*
118 %{_mandir}/man1/blueman-assistant.1*
119 %{_mandir}/man1/blueman-browse.1*
120 %{_mandir}/man1/blueman-manager.1*
121 %{_mandir}/man1/blueman-report.1
122 %{_mandir}/man1/blueman-sendto.1*
123 %{_mandir}/man1/blueman-services.1*
124 %attr(755,root,root) %{_libdir}/%{name}-mechanism
125 %{_datadir}/%{name}
126 %{_datadir}/dbus-1/system-services/org.blueman.Mechanism.service
127 %{_desktopdir}/blueman-manager.desktop
128 %{_desktopdir}/blueman-adapters.desktop
129 %{_iconsdir}/hicolor/scalable/*/*.svg
130 %{_iconsdir}/hicolor/*/*/*.png
131 %dir %{_pixmapsdir}/blueman
132 %{_pixmapsdir}/blueman/blueman-*.png
133 %{_libdir}/blueman-rfcomm-watcher
134 %{_datadir}/glib-2.0/schemas/org.blueman.gschema.xml
135 %{_datadir}/dbus-1/services/blueman-applet.service
136 %{_datadir}/polkit-1/actions/org.blueman.policy
137 %attr(755,root,root) %{py_sitedir}/_blueman.so
138 %{py_sitescriptdir}/%{name}
139
140 %files thunar
141 %defattr(644,root,root,755)
142 %{_datadir}/Thunar/sendto/thunar-sendto-blueman.desktop
This page took 0.057074 seconds and 3 git commands to generate.