]> git.pld-linux.org Git - packages/blueman.git/blob - blueman.spec
up to 2.2.3
[packages/blueman.git] / blueman.spec
1 # Conditional build:
2 %bcond_without  cinnamon        # build without nemo support
3 %bcond_without  gnome           # build without nautilus support
4 %bcond_without  mate            # build without caja support
5 %bcond_without  xfce            # build without Thunar support
6
7 Summary:        Blueman - bluetooth management utility for GNOME
8 Name:           blueman
9 Version:        2.2.3
10 Release:        1
11 License:        GPL v3+
12 Group:          X11/Applications
13 Source0:        https://github.com/blueman-project/blueman/releases/download/%{version}/%{name}-%{version}.tar.xz
14 # Source0-md5:  ccdb860090a751312e841538606b4393
15 URL:            https://github.com/blueman-project/blueman
16 BuildRequires:  bluez-libs-devel >= 5.48
17 %{?with_mate:BuildRequires:     caja-python-devel}
18 %{?with_cinnamon:BuildRequires: cinnamon-nemo-python-devel}
19 BuildRequires:  gettext-tools >= 0.19.7
20 BuildRequires:  glib2-devel >= 1:2.32
21 BuildRequires:  libtool
22 %{?with_gnome:BuildRequires:    nautilus-python-devel}
23 BuildRequires:  pkgconfig >= 1:0.9.0
24 BuildRequires:  polkit-devel
25 BuildRequires:  python-pygobject3-common-devel >= 3.27.2
26 BuildRequires:  python3-Cython
27 BuildRequires:  python3-devel >= 1:3.6
28 BuildRequires:  rpm-pythonprov
29 BuildRequires:  rpmbuild(macros) >= 1.644
30 BuildRequires:  systemd-units
31 BuildRequires:  tar >= 1:1.22
32 BuildRequires:  xz
33 Requires(post,postun):  gtk-update-icon-cache
34 Requires(post,postun):  hicolor-icon-theme
35 Requires(post,preun,postun):    systemd-units >= 38
36 Requires:       bluez >= 5.48
37 Requires:       dbus >= 1.9.18
38 Requires:       glib2 >= 1:2.32
39 Requires:       gtk+3 >= 3.22
40 Requires:       pango
41 Requires:       python3 >= %py3_ver
42 Requires:       python3-pycairo
43 Requires:       python3-pygobject3 >= 3.27.2
44 Suggests:       NetworkManager-libs
45 Suggests:       iproute2
46 Suggests:       libappindicator-gtk3
47 Suggests:       pulseaudio-bluetooth
48 Suggests:       pulseaudio-hal
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 Blueman is a GTK+ bluetooth management utility for GNOME using bluez
53 dbus backend. The aim is to create a full featured graphical bluetooth
54 manager for Linux.
55
56 Features:
57
58 - Easy to use interface
59 - Storing Favourite devices
60 - Send files
61 - Browse files on devices
62 - List all seen devices
63 - View Local/Remote Device information
64 - View transfer speeds and link quality
65 - Configure local devices
66 - Manage Pairing (Bonding)
67 - Host/Connect to Personal Area Networks
68 - Bind services to /dev/rfcomm ports, for eg. connecting via gprs
69 - Connect and receive connections from: audio, network, input and
70   serial devices
71
72 %package caja
73 Summary:        Blueman plugin for Caja
74 Summary(pl.UTF-8):      Wtyczka Blueman-a dla managera plików Caja
75 Group:          X11/Applications
76 Requires:       %{name} = %{version}
77 Requires:       caja-python
78
79 %description caja
80 Blueman plugin for Caja.
81
82 %description caja -l pl.UTF-8
83 Wtyczka Blueman-a dla managera plików Caja.
84
85 %package nautilus
86 Summary:        Blueman plugin for Nautilus
87 Summary(pl.UTF-8):      Wtyczka Blueman-a dla Nautilus-a
88 Group:          X11/Applications
89 Requires:       %{name} = %{version}
90 Requires:       nautilus-python
91
92 %description nautilus
93 Blueman plugin for Nautilus.
94
95 %description nautilus -l pl.UTF-8
96 Wtyczka Blueman-a dla Nautilus-a.
97
98 %package nemo
99 Summary:        Blueman plugin for Nemo
100 Summary(pl.UTF-8):      Wtyczka Blueman-a dla managera plików Nemo.
101 Group:          X11/Applications
102 Requires:       %{name} = %{version}
103 Requires:       cinnamon-nemo-python
104
105 %description nemo
106 Blueman plugin for Nautilus.
107
108 %description nemo -l pl.UTF-8
109 Wtyczka Blueman-a dla managera plików Nemo.
110
111 %package thunar
112 Summary:        Blueman plugin for Thunar
113 Summary(pl.UTF-8):      Wtyczka Blueman-a dla Thunar-a
114 Group:          X11/Applications
115 Requires:       %{name} = %{version}
116
117 %description thunar
118 Blueman plugin for Thunar.
119
120 %description thunar -l pl.UTF-8
121 Wtyczka Blueman-a dla Thunar-a.
122
123 %prep
124 %setup -q
125
126 %build
127 %configure \
128         CYTHONEXEC=/usr/bin/cython3 \
129         NETWORKTOOLS=/sbin/ip \
130         --disable-runtime-deps-check \
131         --disable-schemas-compile \
132         --disable-static \
133         --enable-polkit \
134         %{__enable_disable mate caja-sendto} \
135         %{__enable_disable cinnamon nemo-sendto} \
136         %{__enable_disable gnome nautilus-sendto} \
137         %{__enable_disable xfce thunar-sendto} \
138         --enable-settings-integration
139
140 %{__make}
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144 %{__make} install \
145         DESTDIR=$RPM_BUILD_ROOT
146
147 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
148 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/_blueman.la
149
150 # DO NOT RUN py_postclean - breaks plugins and everything
151
152 %find_lang %{name} --with-gnome
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %post
158 %update_icon_cache hicolor
159 glib-compile-schemas %{_datadir}/glib-2.0/schemas
160 %service %{name}-mechanism restart
161 %systemd_post %{name}-mechanism.service
162
163 %preun
164 if [ "$1" = "0" ]; then
165         %service -q %{name}-mechanism stop
166 fi
167 %systemd_preun %{name}-mechanism.service
168
169 %postun
170 %update_icon_cache hicolor
171 glib-compile-schemas %{_datadir}/glib-2.0/schemas
172 %systemd_reload
173
174 %files -f %{name}.lang
175 %defattr(644,root,root,755)
176 %doc README.md CHANGELOG.md COPYING FAQ
177 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/autostart/blueman.desktop
178 %attr(755,root,root) %{_bindir}/blueman-adapters
179 %attr(755,root,root) %{_bindir}/blueman-applet
180 %attr(755,root,root) %{_bindir}/blueman-manager
181 %attr(755,root,root) %{_bindir}/blueman-sendto
182 %attr(755,root,root) %{_bindir}/blueman-services
183 %attr(755,root,root) %{_bindir}/blueman-tray
184 %{_mandir}/man1/blueman-adapters.1*
185 %{_mandir}/man1/blueman-applet.1*
186 %{_mandir}/man1/blueman-manager.1*
187 %{_mandir}/man1/blueman-sendto.1*
188 %{_mandir}/man1/blueman-services.1*
189 %{_mandir}/man1/blueman-tray.1*
190 %attr(755,root,root) %{_libexecdir}/%{name}-mechanism
191 %attr(755,root,root) %{_libexecdir}/%{name}-rfcomm-watcher
192 %{_datadir}/%{name}
193 %{_datadir}/dbus-1/system-services/org.blueman.Mechanism.service
194 %{_desktopdir}/blueman-manager.desktop
195 %{_desktopdir}/blueman-adapters.desktop
196 %{_iconsdir}/hicolor/scalable/*/*.svg
197 %{_iconsdir}/hicolor/*/*/*.png
198 %{_datadir}/glib-2.0/schemas/org.blueman.gschema.xml
199 %{systemdunitdir}/blueman-mechanism.service
200 %{systemduserunitdir}/blueman-applet.service
201 %{systemduserunitdir}/blueman-manager.service
202 %{_datadir}/dbus-1/services/org.blueman.Applet.service
203 %{_datadir}/dbus-1/services/org.blueman.Manager.service
204 %{_datadir}/dbus-1/system.d/org.blueman.Mechanism.conf
205 %{_datadir}/polkit-1/actions/org.blueman.policy
206 %{_datadir}/polkit-1/rules.d/blueman.rules
207 %attr(755,root,root) %{py3_sitedir}/_blueman.so
208 %{py3_sitedir}/%{name}
209
210 %if %{with mate}
211 %files caja
212 %defattr(644,root,root,755)
213 %{_datadir}/caja-python/extensions/caja_blueman_sendto.py
214 %endif
215
216 %if %{with gnome}
217 %files nautilus
218 %defattr(644,root,root,755)
219 %{_datadir}/nautilus-python/extensions/nautilus_blueman_sendto.py
220 %endif
221
222 %if %{with cinnamon}
223 %files nemo
224 %defattr(644,root,root,755)
225 %{_datadir}/nemo-python/extensions/nemo_blueman_sendto.py
226 %endif
227
228 %if %{with xfce}
229 %files thunar
230 %defattr(644,root,root,755)
231 %{_datadir}/Thunar/sendto/thunar-sendto-blueman.desktop
232 %endif
This page took 0.047574 seconds and 3 git commands to generate.