]> git.pld-linux.org Git - packages/blueman.git/blob - blueman.spec
426d98ba63b7d3513e2c617aca36e3da556f6937
[packages/blueman.git] / blueman.spec
1 Summary:        Blueman - bluetooth management utility for GNOME
2 Name:           blueman
3 Version:        2.0.5
4 Release:        1
5 License:        GPL
6 Group:          X11/Applications
7 Source0:        https://github.com/blueman-project/blueman/releases/download/%{version}/%{name}-%{version}.tar.xz
8 # Source0-md5:  677afd610bd893745ee5ae506bede2dd
9 URL:            https://github.com/blueman-project/blueman
10 BuildRequires:  autoconf
11 BuildRequires:  automake
12 BuildRequires:  bluez-libs-devel >= 4.61
13 BuildRequires:  gettext-tools
14 BuildRequires:  glib2-devel >= 2.32
15 BuildRequires:  gtk+3-devel >= 3.12
16 BuildRequires:  intltool >= 0.35.0
17 BuildRequires:  libtool
18 BuildRequires:  pkgconfig >= 0.9.0
19 BuildRequires:  python-Cython
20 BuildRequires:  python-dbus
21 BuildRequires:  python-devel >= 2.7
22 BuildRequires:  python-pygobject3-common-devel
23 BuildRequires:  rpm-pythonprov
24 BuildRequires:  rpmbuild(macros) >= 1.219
25 Requires(post,postun):  gtk-update-icon-cache
26 Requires(post,postun):  hicolor-icon-theme
27 Requires:       bluez-libs >= 4.25
28 Requires:       bluez-utils >= 4.25
29 Requires:       gtk+3 >= 3.12
30 Requires:       python >= %py_ver
31 Requires:       python-appindicator-gtk2
32 Requires:       python-bluetooth
33 Requires:       python-dbus
34 Requires:       python-pygtk-gtk
35 Requires:       python-pynotify
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Blueman is a GTK+ bluetooth management utility for GNOME using bluez
40 dbus backend. The aim is to create a full featured graphical bluetooth
41 manager for Linux.
42
43 Features:
44
45 - Easy to use interface
46 - Storing Favourite devices
47 - Send files
48 - Browse files on devices
49 - List all seen devices
50 - View Local/Remote Device information
51 - View transfer speeds and link quality
52 - Configure local devices
53 - Manage Pairing (Bonding)
54 - Host/Connect to Personal Area Networks
55 - Bind services to /dev/rfcomm ports, for eg. connecting via gprs
56 - Connect and receive connections from: audio, network, input and
57   serial devices
58
59 %package thunar
60 Summary:        Blueman plugin for Thunar
61 Summary(pl.UTF-8):      Wtyczka Blueman-a dla Thunar-a
62 Group:          X11/Applications
63
64 %description thunar
65 Blueman plugin for Thunar.
66
67 %description thunar -l pl.UTF-8
68 Wtyczka Blueman-a dla Thunar-a.
69
70 %prep
71 %setup -q
72
73 %build
74 %configure \
75         --enable-xfce-settings=yes \
76         --disable-static \
77         --disable-schemas-compile \
78
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
87 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_blueman.la
88
89 # DO NOT RUN py_postclean - breaks plugins and everything
90
91 %find_lang %{name} --with-gnome
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post
97 %update_icon_cache hicolor
98 glib-compile-schemas %{_datadir}/glib-2.0/schemas
99
100 %postun
101 %update_icon_cache hicolor
102 glib-compile-schemas %{_datadir}/glib-2.0/schemas
103
104 %files -f %{name}.lang
105 %defattr(644,root,root,755)
106 %doc README.md CHANGELOG.md COPYING FAQ
107 %config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/org.blueman.Mechanism.conf
108 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/autostart/blueman.desktop
109 %attr(755,root,root) %{_bindir}/blueman-adapters
110 %attr(755,root,root) %{_bindir}/blueman-applet
111 %attr(755,root,root) %{_bindir}/blueman-assistant
112 %attr(755,root,root) %{_bindir}/blueman-browse
113 %attr(755,root,root) %{_bindir}/blueman-manager
114 %attr(755,root,root) %{_bindir}/blueman-report
115 %attr(755,root,root) %{_bindir}/blueman-sendto
116 %attr(755,root,root) %{_bindir}/blueman-services
117 %{_mandir}/man1/blueman-adapters.1*
118 %{_mandir}/man1/blueman-applet.1*
119 %{_mandir}/man1/blueman-assistant.1*
120 %{_mandir}/man1/blueman-browse.1*
121 %{_mandir}/man1/blueman-manager.1*
122 %{_mandir}/man1/blueman-report.1
123 %{_mandir}/man1/blueman-sendto.1*
124 %{_mandir}/man1/blueman-services.1*
125 %attr(755,root,root) %{_libexecdir}/%{name}-mechanism
126 %attr(755,root,root) %{_libexecdir}/%{name}-rfcomm-watcher
127 %{_datadir}/%{name}
128 %{_datadir}/dbus-1/system-services/org.blueman.Mechanism.service
129 %{_desktopdir}/blueman-manager.desktop
130 %{_desktopdir}/blueman-adapters.desktop
131 %{_iconsdir}/hicolor/scalable/*/*.svg
132 %{_iconsdir}/hicolor/*/*/*.png
133 %dir %{_pixmapsdir}/blueman
134 %{_pixmapsdir}/blueman/blueman-*.png
135 %{_datadir}/glib-2.0/schemas/org.blueman.gschema.xml
136 %{_datadir}/dbus-1/services/blueman-applet.service
137 %{_datadir}/polkit-1/actions/org.blueman.policy
138 %attr(755,root,root) %{py_sitedir}/_blueman.so
139 %{py_sitescriptdir}/%{name}
140
141 %files thunar
142 %defattr(644,root,root,755)
143 %{_datadir}/Thunar/sendto/thunar-sendto-blueman.desktop
This page took 0.057884 seconds and 2 git commands to generate.