]> git.pld-linux.org Git - packages/blueman.git/blame_incremental - blueman.spec
clean .py
[packages/blueman.git] / blueman.spec
... / ...
CommitLineData
1Summary: Blueman - bluetooth management utility for GNOME
2Name: blueman
3Version: 2.0
4Release: 2
5License: GPL
6Group: X11/Applications
7Source0: https://github.com/blueman-project/blueman/releases/download/%{version}/%{name}-%{version}.tar.xz
8# Source0-md5: d95270145475ce41a33bf7390afe3428
9URL: https://github.com/blueman-project/blueman
10BuildRequires: autoconf
11BuildRequires: automake
12BuildRequires: bluez-libs-devel >= 4.61
13BuildRequires: gettext-tools
14BuildRequires: glib2-devel >= 2.32
15BuildRequires: gtk+3-devel >= 3.12
16BuildRequires: intltool >= 0.35.0
17BuildRequires: libtool
18BuildRequires: pkgconfig >= 0.9.0
19BuildRequires: python-Cython
20BuildRequires: python-dbus
21BuildRequires: python-devel >= 2.7
22BuildRequires: python-pygobject3-common-devel
23BuildRequires: rpm-pythonprov
24BuildRequires: rpmbuild(macros) >= 1.219
25Requires(post,postun): gtk-update-icon-cache
26Requires(post,postun): hicolor-icon-theme
27Requires: bluez-libs >= 4.25
28Requires: bluez-utils >= 4.25
29Requires: gtk+3 >= 3.12
30Requires: python >= %py_ver
31Requires: python-appindicator-gtk2
32Requires: python-bluetooth
33Requires: python-dbus
34Requires: python-pygtk-gtk
35Requires: python-pynotify
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
39Blueman is a GTK+ bluetooth management utility for GNOME using bluez
40dbus backend. The aim is to create a full featured graphical bluetooth
41manager for Linux.
42
43Features:
44
45- Easy to use interface
46- Storing Favourite devices
47- Send files
48- Browse files on devices
49- List all seen devices
50- View Local/Remote Device information
51- View transfer speeds and link quality
52- Configure local devices
53- Manage Pairing (Bonding)
54- Host/Connect to Personal Area Networks
55- Bind services to /dev/rfcomm ports, for eg. connecting via gprs
56- Connect and receive connections from: audio, network, input and
57 serial devices
58
59%package thunar
60Summary: Blueman plugin for Thunar
61Summary(pl.UTF-8): Wtyczka Blueman-a dla Thunar-a
62Group: X11/Applications
63
64%description thunar
65Blueman plugin for Thunar.
66
67%description thunar -l pl.UTF-8
68Wtyczka Blueman-a dla Thunar-a.
69
70%prep
71%setup -q
72
73%build
74%{__aclocal}
75%{__autoheader}
76%{__libtoolize}
77%{__intltoolize}
78%{__automake}
79%{__autoconf}
80%configure \
81 --enable-xfce-settings=yes \
82 --disable-static \
83 --disable-schemas-compile \
84
85%{__make}
86
87%install
88rm -rf $RPM_BUILD_ROOT
89%{__make} install \
90 DESTDIR=$RPM_BUILD_ROOT
91
92%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
93%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_blueman.la
94
95%py_postclean
96%find_lang %{name} --with-gnome
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%post
102%update_icon_cache hicolor
103glib-compile-schemas %{_datadir}/glib-2.0/schemas
104
105%postun
106%update_icon_cache hicolor
107glib-compile-schemas %{_datadir}/glib-2.0/schemas
108
109%files -f %{name}.lang
110%defattr(644,root,root,755)
111%doc README.md CHANGELOG.md COPYING FAQ
112%config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/org.blueman.Mechanism.conf
113%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/autostart/blueman.desktop
114%attr(755,root,root) %{_bindir}/blueman-adapters
115%attr(755,root,root) %{_bindir}/blueman-applet
116%attr(755,root,root) %{_bindir}/blueman-assistant
117%attr(755,root,root) %{_bindir}/blueman-browse
118%attr(755,root,root) %{_bindir}/blueman-manager
119%attr(755,root,root) %{_bindir}/blueman-report
120%attr(755,root,root) %{_bindir}/blueman-sendto
121%attr(755,root,root) %{_bindir}/blueman-services
122%{_mandir}/man1/blueman-adapters.1*
123%{_mandir}/man1/blueman-applet.1*
124%{_mandir}/man1/blueman-assistant.1*
125%{_mandir}/man1/blueman-browse.1*
126%{_mandir}/man1/blueman-manager.1*
127%{_mandir}/man1/blueman-report.1
128%{_mandir}/man1/blueman-sendto.1*
129%{_mandir}/man1/blueman-services.1*
130%attr(755,root,root) %{_libdir}/%{name}-mechanism
131%attr(755,root,root) %{_libdir}/%{name}-rfcomm-watcher
132%{_datadir}/%{name}
133%{_datadir}/dbus-1/system-services/org.blueman.Mechanism.service
134%{_desktopdir}/blueman-manager.desktop
135%{_desktopdir}/blueman-adapters.desktop
136%{_iconsdir}/hicolor/scalable/*/*.svg
137%{_iconsdir}/hicolor/*/*/*.png
138%dir %{_pixmapsdir}/blueman
139%{_pixmapsdir}/blueman/blueman-*.png
140%{_datadir}/glib-2.0/schemas/org.blueman.gschema.xml
141%{_datadir}/dbus-1/services/blueman-applet.service
142%{_datadir}/polkit-1/actions/org.blueman.policy
143%attr(755,root,root) %{py_sitedir}/_blueman.so
144%{py_sitescriptdir}/%{name}
145
146%files thunar
147%defattr(644,root,root,755)
148%{_datadir}/Thunar/sendto/thunar-sendto-blueman.desktop
This page took 0.064641 seconds and 4 git commands to generate.