]> git.pld-linux.org Git - packages/blueman.git/blame - blueman.spec
add bcond for each DE
[packages/blueman.git] / blueman.spec
CommitLineData
3552d76d
JP
1# Conditional build:
2%bcond_without cinnamon # build without nemo support
3%bcond_without gnome # build without nautilus support
4%bcond_without mate # build without caja support
5%bcond_without xfce # build without Thunar support
6
5cc4ce65
MWP
7Summary: Blueman - bluetooth management utility for GNOME
8Name: blueman
c8d32e64 9Version: 2.1.3
806b6c2d 10Release: 2
3c7b0773 11License: GPL
fa941284
L
12Group: X11/Applications
13Source0: https://github.com/blueman-project/blueman/releases/download/%{version}/%{name}-%{version}.tar.xz
c8d32e64 14# Source0-md5: b341822c8362bf9619fbbc22c957b00c
fa941284
L
15URL: https://github.com/blueman-project/blueman
16BuildRequires: autoconf
17BuildRequires: automake
c8d32e64 18BuildRequires: bluez-libs-devel >= 5.0
3552d76d
JP
19%{?with_mate:BuildRequires: caja-python-devel}
20%{?with_cinnamon:BuildRequires: cinnamon-nemo-python-devel}
15e75860 21BuildRequires: gettext-tools
fa941284 22BuildRequires: glib2-devel >= 2.32
f081be6b 23BuildRequires: gtk+3-devel >= 3.12
fa941284 24BuildRequires: intltool >= 0.35.0
293276eb 25BuildRequires: libtool
3552d76d 26%{?with_gnome:BuildRequires: nautilus-python-devel}
fa941284
L
27BuildRequires: pkgconfig >= 0.9.0
28BuildRequires: python-Cython
c8d32e64
KM
29BuildRequires: python-devel >= 3.3
30BuildRequires: python-pygobject3-common-devel >= 3.27.2
5cc4ce65 31BuildRequires: rpm-pythonprov
3552d76d 32BuildRequires: rpmbuild(macros) >= 1.527
f0242065
AF
33Requires(post,postun): gtk-update-icon-cache
34Requires(post,postun): hicolor-icon-theme
c8d32e64
KM
35Requires(post,preun,postun): systemd-units >= 38
36Requires: bluez-libs >= 5.0
37Requires: bluez-utils >= 5.0
f081be6b 38Requires: gtk+3 >= 3.12
fa941284
L
39Requires: python >= %py_ver
40Requires: python-appindicator-gtk2
11ad311c 41Requires: python-bluetooth
11ad311c 42Requires: python-pygtk-gtk
c8d32e64
KM
43Suggests: pulseaudio-bluetooth
44Suggests: pulseaudio-hal
5cc4ce65
MWP
45BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47%description
48Blueman is a GTK+ bluetooth management utility for GNOME using bluez
49dbus backend. The aim is to create a full featured graphical bluetooth
50manager for Linux.
51
52Features:
53
54- Easy to use interface
55- Storing Favourite devices
56- Send files
57- Browse files on devices
58- List all seen devices
59- View Local/Remote Device information
60- View transfer speeds and link quality
61- Configure local devices
62- Manage Pairing (Bonding)
63- Host/Connect to Personal Area Networks
64- Bind services to /dev/rfcomm ports, for eg. connecting via gprs
65- Connect and receive connections from: audio, network, input and
66 serial devices
67
c8d32e64
KM
68%package caja
69Summary: Blueman plugin for Caja
70Summary(pl.UTF-8): Wtyczka Blueman-a dla managera plików Caja
71Group: X11/Applications
72Requires: %{name} = %{version}
73Requires: caja-python
74
75%description caja
76Blueman plugin for Caja.
77
78%description caja -l pl.UTF-8
79Wtyczka Blueman-a dla managera plików Caja.
80
81%package nautilus
82Summary: Blueman plugin for Nautilus
83Summary(pl.UTF-8): Wtyczka Blueman-a dla Nautilus-a
84Group: X11/Applications
85Requires: %{name} = %{version}
86Requires: nautilus-python
87
88%description nautilus
89Blueman plugin for Nautilus.
90
91%description nautilus -l pl.UTF-8
92Wtyczka Blueman-a dla Nautilus-a.
93
94%package nemo
95Summary: Blueman plugin for Nemo
96Summary(pl.UTF-8): Wtyczka Blueman-a dla managera plików Nemo.
97Group: X11/Applications
98Requires: %{name} = %{version}
99Requires: cinnamon-nemo-python
100
101%description nemo
102Blueman plugin for Nautilus.
103
104%description nemo -l pl.UTF-8
105Wtyczka Blueman-a dla managera plików Nemo.
106
fa941284
L
107%package thunar
108Summary: Blueman plugin for Thunar
109Summary(pl.UTF-8): Wtyczka Blueman-a dla Thunar-a
110Group: X11/Applications
c8d32e64 111Requires: %{name} = %{version}
fa941284
L
112
113%description thunar
114Blueman plugin for Thunar.
115
116%description thunar -l pl.UTF-8
117Wtyczka Blueman-a dla Thunar-a.
118
5cc4ce65 119%prep
fb1a0cdd 120%setup -q
5cc4ce65
MWP
121
122%build
0348fefb 123%configure \
fc378da1 124 NETWORKTOOLS=/sbin/ip \
68bdd93d 125 --disable-static \
fa941284 126 --disable-schemas-compile \
c8d32e64 127 --enable-polkit \
3552d76d
JP
128 %{__enable_disable mate caja-sendto} \
129 %{__enable_disable cinnamon nemo-sendto} \
130 %{__enable_disable gnome nautilus-sendto} \
131 %{__enable_disable xfce thunar-sendto} \
c8d32e64 132 --enable-settings-integration
fa941284 133
fb1a0cdd 134%{__make}
5cc4ce65
MWP
135
136%install
137rm -rf $RPM_BUILD_ROOT
fb1a0cdd 138%{__make} install \
11ad311c 139 DESTDIR=$RPM_BUILD_ROOT
5cc4ce65 140
68bdd93d 141%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
c8d32e64 142%{__rm} $RPM_BUILD_ROOT%{_libdir}/python3.8/site-packages/_blueman.la
68bdd93d 143
5759428a
JR
144# DO NOT RUN py_postclean - breaks plugins and everything
145
5cc4ce65
MWP
146%find_lang %{name} --with-gnome
147
148%clean
149rm -rf $RPM_BUILD_ROOT
150
8235d8ec 151%post
152%update_icon_cache hicolor
fa941284 153glib-compile-schemas %{_datadir}/glib-2.0/schemas
c8d32e64
KM
154%service %{name}-mechanism restart
155%systemd_post %{name}-mechanism.service
156
157%preun
158if [ "$1" = "0" ]; then
159 %service -q %{name}-mechanism stop
160fi
161%systemd_preun %{name}-mechanism.service
8235d8ec 162
163%postun
164%update_icon_cache hicolor
fa941284 165glib-compile-schemas %{_datadir}/glib-2.0/schemas
c8d32e64 166%systemd_reload
8235d8ec 167
5cc4ce65
MWP
168%files -f %{name}.lang
169%defattr(644,root,root,755)
fa941284 170%doc README.md CHANGELOG.md COPYING FAQ
fb1a0cdd 171%config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/org.blueman.Mechanism.conf
017008df
ER
172%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/autostart/blueman.desktop
173%attr(755,root,root) %{_bindir}/blueman-adapters
174%attr(755,root,root) %{_bindir}/blueman-applet
175%attr(755,root,root) %{_bindir}/blueman-assistant
017008df
ER
176%attr(755,root,root) %{_bindir}/blueman-manager
177%attr(755,root,root) %{_bindir}/blueman-report
178%attr(755,root,root) %{_bindir}/blueman-sendto
179%attr(755,root,root) %{_bindir}/blueman-services
c8d32e64 180%attr(755,root,root) %{_bindir}/blueman-tray
017008df
ER
181%{_mandir}/man1/blueman-adapters.1*
182%{_mandir}/man1/blueman-applet.1*
183%{_mandir}/man1/blueman-assistant.1*
017008df
ER
184%{_mandir}/man1/blueman-manager.1*
185%{_mandir}/man1/blueman-report.1
186%{_mandir}/man1/blueman-sendto.1*
187%{_mandir}/man1/blueman-services.1*
c8d32e64 188%{_mandir}/man1/blueman-tray.1*
5759428a
JR
189%attr(755,root,root) %{_libexecdir}/%{name}-mechanism
190%attr(755,root,root) %{_libexecdir}/%{name}-rfcomm-watcher
5cc4ce65
MWP
191%{_datadir}/%{name}
192%{_datadir}/dbus-1/system-services/org.blueman.Mechanism.service
017008df
ER
193%{_desktopdir}/blueman-manager.desktop
194%{_desktopdir}/blueman-adapters.desktop
7e0fad4e 195%{_iconsdir}/hicolor/scalable/*/*.svg
b8c4aac2 196%{_iconsdir}/hicolor/*/*/*.png
017008df
ER
197%dir %{_pixmapsdir}/blueman
198%{_pixmapsdir}/blueman/blueman-*.png
fa941284 199%{_datadir}/glib-2.0/schemas/org.blueman.gschema.xml
c8d32e64
KM
200%{systemdunitdir}/blueman-mechanism.service
201%{systemduserunitdir}/blueman-applet.service
202%{_datadir}/dbus-1/services/org.blueman.Applet.service
afb5f40e 203%{_datadir}/polkit-1/actions/org.blueman.policy
c8d32e64
KM
204%{_datadir}/polkit-1/rules.d/blueman.rules
205%attr(755,root,root) %{_libdir}/python3.8/site-packages/_blueman.so
206%{_libdir}/python3.8/site-packages/%{name}
207
3552d76d 208%if %{with mate}
c8d32e64
KM
209%files caja
210%defattr(644,root,root,755)
211%{_datadir}/caja-python/extensions/caja_blueman_sendto.py
3552d76d 212%endif
c8d32e64 213
3552d76d 214%if %{with gnome}
c8d32e64
KM
215%files nautilus
216%defattr(644,root,root,755)
217%{_datadir}/nautilus-python/extensions/nautilus_blueman_sendto.py
3552d76d 218%endif
c8d32e64 219
3552d76d 220%if %{with cinnamon}
c8d32e64
KM
221%files nemo
222%defattr(644,root,root,755)
223%{_datadir}/nemo-python/extensions/nemo_blueman_sendto.py
3552d76d 224%endif
fa941284 225
3552d76d 226%if %{with xfce}
fa941284
L
227%files thunar
228%defattr(644,root,root,755)
229%{_datadir}/Thunar/sendto/thunar-sendto-blueman.desktop
3552d76d 230%endif
This page took 0.063232 seconds and 4 git commands to generate.