]> git.pld-linux.org Git - packages/bluefish.git/blobdiff - bluefish.spec
- s/libungif/giflib/ in deps
[packages/bluefish.git] / bluefish.spec
index dbf279a202466df26fa8f58dbadd6bce190c909e..2d822fbe5e3cf6dc28a422dabda433f309117f38 100644 (file)
@@ -1,47 +1,56 @@
+#
+# Conditional build:
+%bcond_with    opts    # use extra optimizations
+#
+# note: optflags used with this bcond are very strong, and partially
+#      obsoleted for C (like -fno-rtti) - use at own risk!
+#
 Summary:       Bluefish - HTML editor for the experienced web designer
-Summary(pl):   Bluefish - Edytor HTML dla zaawansowanych
-Summary(pt_BR):        Editor HTML Bluefish
+Summary(pl):   Bluefish - Edytor HTML-a dla zaawansowanych
 Name:          bluefish
-Version:       0.7
-Release:       5
+Version:       1.0.4
+Release:       1
 License:       GPL
 Group:         X11/Applications/Editors
 # The master server is here
 Source0:       http://pkedu.fbt.eitn.wau.nl/~olivier/downloads/%{name}-%{version}.tar.bz2
+# Source0-md5: 8d5c1b7315cdc935aa024954093d2b32
 # but if you want ftp: try this one
 # Source0:     ftp://bluefish.advancecreations.com/bluefish/downloads/%{name}-%{version}.tar.bz2
-Source1:       %{name}.desktop
-Source2:       %{name}.png
-Patch0:                %{name}-DESTDIR.patch
-Patch1:                %{name}-ac_lt.patch
-Patch2:                %{name}-locale.patch
-Patch3:                %{name}-netscape-now-mozilla.patch
-Patch4:                %{name}-pl.patch
+Patch0:                %{name}-desktop.patch
+Patch1:                %{name}-home_etc.patch
+Patch2:                %{name}-locales.patch
 URL:           http://bluefish.openoffice.nl/
+BuildRequires: aspell-devel
 BuildRequires: autoconf
 BuildRequires: automake
-BuildRequires: libtool
 BuildRequires: gettext-devel
-BuildRequires: gtk+-devel >= 1.2.0
-BuildRequires: imlib-devel
+BuildRequires: giflib-devel
+BuildRequires: gnome-vfs2-devel >= 2.2
+BuildRequires: gtk+2-devel
+BuildRequires: libbonobo-devel >= 2.2
 BuildRequires: libjpeg-devel
-BuildRequires: libpng >= 1.0.8
+BuildRequires: libpng >= 1.2.5
 BuildRequires: libtiff-devel
-BuildRequires: libungif-devel
+BuildRequires: libtool
+BuildRequires: pcre-devel
+BuildRequires: pkgconfig
+BuildRequires: rpmbuild(macros) >= 1.197
+Requires(post,postun): desktop-file-utils
+Requires(post,postun): shared-mime-info
+Requires:      gnome-icon-theme
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _prefix         /usr/X11R6
-
 %description
 Bluefish is a GTK+ based HTML editor designed for the experienced web
 designer.
 
 %description -l pl
-Bluefish jest opartym na GTK+ edytorem HTML, przeznaczonym dla
+Bluefish jest opartym na GTK+ edytorem HTML-a, przeznaczonym dla
 do¶wiadczonych projektantów stron WWW.
 
 %description -l pt_BR
-O bluefish é um editor HTML feito com GTK para web designers
+O bluefish é um editor HTML feito com GTK+ para web designers
 experientes. Atualmente ele está em estágio alfa, mas já está bastante
 usável. Algumas opções ainda não estão completamente finalizadas.
 Bluefish é liberado sob a licença GPL.
@@ -49,51 +58,60 @@ Bluefish 
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
+#%patch1 -p1
 %patch2 -p1
-%patch3 -p1
-%patch4 -p1
 
-%build
-%ifarch i586
-OPTIMIZATION="--with-pentium"
-%endif
-%ifarch i686 athlon
-OPTIMIZATION="--with-pentiumpro"
-%endif
+mv -f po/{no,nb}.po
+mv -f po/sr{,@Latn}.po
 
-%{__gettextize}
+%build
+#%%{__gettextize}
 %{__libtoolize}
 %{__aclocal}
 %{__autoconf}
 %configure \
-       --with-install-location=%{_datadir}/bluefish \
-       --with-autocomplet \
-       $OPTIMIZATION
-       
+       --disable-update-databases \
+       --without-gnome2_4-mime \
+       --without-gnome2_4-appreg \
+       %{?with_opts:--enable-auto-optimization}
+
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_applnkdir}/Editors/HTML,%{_pixmapsdir}}
+install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}} \
+       $RPM_BUILD_ROOT%{_iconsdir}/gnome/48x48/mimetypes
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install %{SOURCE1} $RPM_BUILD_ROOT%{_applnkdir}/Editors/HTML
-install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
+rm -f $RPM_BUILD_ROOT%{_desktopdir}/bluefish-project.desktop
+mv $RPM_BUILD_ROOT%{_pixmapsdir}/gnome-application-bluefish-project.png \
+       $RPM_BUILD_ROOT%{_iconsdir}/gnome/48x48/mimetypes
 
 %find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post
+umask 022
+update-mime-database %{_datadir}/mime ||:
+%update_desktop_database_post
+
+%postun
+%update_desktop_database_postun
+if [ $1 = 0 ]; then
+    umask 022
+    update-mime-database %{_datadir}/mime
+fi
+
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc README ChangeLog BUGS AUTHORS NEWS TODO
+%doc AUTHORS README TODO
 %attr(755,root,root) %{_bindir}/*
-%{_mandir}/man1/*
-
-%{_datadir}/bluefish
-%{_applnkdir}/Editors/HTML/bluefish.desktop
+%{_datadir}/%{name}
+%{_datadir}/mime/packages/*.xml
+%{_desktopdir}/*
+%{_iconsdir}/gnome/48x48/mimetypes/*.png
 %{_pixmapsdir}/*
This page took 0.103871 seconds and 4 git commands to generate.