]> git.pld-linux.org Git - packages/blender.git/commitdiff
- fix building with gcc 8 auto/th/blender-2.79b-2
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 7 Apr 2019 13:21:03 +0000 (15:21 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 7 Apr 2019 13:21:03 +0000 (15:21 +0200)
- rel 2

blender.spec
gcc8.patch [new file with mode: 0644]

index 1bdd7b5ece9142ffa1e6877b621c2237d75f8b7d..bf5282cadd8a34f281bac551990f601dbb8b22c3 100644 (file)
@@ -5,7 +5,7 @@ Summary:        3D modeling, rendering, animation and game creation package
 Summary(pl.UTF-8):     Pakiet do tworzenia animacji 3D oraz gier
 Name:          blender
 Version:       2.79b
 Summary(pl.UTF-8):     Pakiet do tworzenia animacji 3D oraz gier
 Name:          blender
 Version:       2.79b
-Release:       1
+Release:       2
 License:       GPL
 Group:         X11/Applications/Graphics
 Source0:       http://download.blender.org/source/%{name}-%{version}.tar.gz
 License:       GPL
 Group:         X11/Applications/Graphics
 Source0:       http://download.blender.org/source/%{name}-%{version}.tar.gz
@@ -15,6 +15,7 @@ Source2:      %{name}.png
 Source3:       %{name}.manpage
 Patch0:                %{name}-2.76-droid.patch
 Patch1:                ffmpeg4.patch
 Source3:       %{name}.manpage
 Patch0:                %{name}-2.76-droid.patch
 Patch1:                ffmpeg4.patch
+Patch2:                gcc8.patch
 URL:           http://www.blender.org/
 BuildRequires: OpenAL-devel
 BuildRequires: OpenEXR-devel
 URL:           http://www.blender.org/
 BuildRequires: OpenAL-devel
 BuildRequires: OpenEXR-devel
@@ -64,6 +65,7 @@ Blender to darmowy i w pełni funkcjonalny pakiet do tworzenia animacji
 %setup -q
 %patch0 -p1
 %patch1 -p1
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 install -d build
 
 %build
 install -d build
diff --git a/gcc8.patch b/gcc8.patch
new file mode 100644 (file)
index 0000000..c86d7f4
--- /dev/null
@@ -0,0 +1,22 @@
+--- blender-2.79b/intern/itasc/kdl/tree.hpp~   2018-03-23 16:22:25.000000000 +0100
++++ blender-2.79b/intern/itasc/kdl/tree.hpp    2019-04-07 14:56:10.531752354 +0200
+@@ -34,7 +34,7 @@
+     //Forward declaration
+     class TreeElement;
+     // Eigen allocator is needed for alignment of Eigen data types
+-    typedef std::map<std::string,TreeElement, std::less<std::string>, Eigen::aligned_allocator<std::pair<std::string, TreeElement> > > SegmentMap;
++    typedef std::map<std::string,TreeElement, std::less<std::string>, Eigen::aligned_allocator<std::pair<const std::string, TreeElement> > > SegmentMap;
+     class TreeElement
+     {
+--- blender-2.79b/intern/cycles/util/util_sseb.h~      2018-03-23 16:22:25.000000000 +0100
++++ blender-2.79b/intern/cycles/util/util_sseb.h       2019-04-07 15:00:05.901328020 +0200
+@@ -116,7 +116,7 @@
+ __forceinline const sseb unpackhi( const sseb& a, const sseb& b ) { return _mm_unpackhi_ps(a, b); }
+ template<size_t i0, size_t i1, size_t i2, size_t i3> __forceinline const sseb shuffle( const sseb& a ) {
+-      return _mm_shuffle_epi32(a, _MM_SHUFFLE(i3, i2, i1, i0));
++      return _mm_castsi128_ps(_mm_shuffle_epi32(a, _MM_SHUFFLE(i3, i2, i1, i0)));
+ }
+ template<> __forceinline const sseb shuffle<0, 1, 0, 1>( const sseb& a ) {
This page took 0.17102 seconds and 4 git commands to generate.