]> git.pld-linux.org Git - packages/blender.git/blobdiff - blender.spec
- up to 2.78b
[packages/blender.git] / blender.spec
index a8d5df24a1aa89e9789bcf9df61889031ff70129..ed8e3f2a37579d2a6eb4d99134b44c47b2fa39ba 100644 (file)
@@ -4,30 +4,30 @@
 Summary:       3D modeling, rendering, animation and game creation package
 Summary(pl.UTF-8):     Pakiet do tworzenia animacji 3D oraz gier
 Name:          blender
-Version:       2.48
+Version:       2.78b
 Release:       1
 License:       GPL
 Group:         X11/Applications/Graphics
 Source0:       http://download.blender.org/source/%{name}-%{version}.tar.gz
-# Source0-md5: e63aa1bd1c2e6d124d2f9699934e9a26
+# Source0-md5: 336d48dba72b1c7b177733e5b7f3839c
 Source1:       %{name}.desktop
 Source2:       %{name}.png
-Source4:       %{name}-wrapper
-Source5:       %{name}.manpage
-Patch0:                %{name}-po_and_locale_names.patch
-Patch1:                %{name}-noxml-yafray.patch
-Patch2:                %{name}-ffmpeg.patch
+Source3:       %{name}.manpage
+Patch0:                %{name}-2.76-droid.patch
 URL:           http://www.blender.org/
+BuildRequires: OpenAL-devel
 BuildRequires: OpenEXR-devel
 BuildRequires: OpenGL-devel
-BuildRequires: SDL-devel
-BuildRequires: gcc >= 5:3.4.0
+BuildRequires: OpenImageIO-devel
+BuildRequires: SDL2-devel
+BuildRequires: cmake
+#BuildRequires:        esound-devel
 BuildRequires: ffmpeg-devel >= 0.4.9-4.20080930.1
 BuildRequires: freealut-devel
 BuildRequires: freetype-devel
 BuildRequires: ftgl-devel
-BuildRequires: gettext-devel
-#BuildRequires:        esound-devel
+BuildRequires: gcc >= 5:3.4.0
+BuildRequires: gettext-tools
 BuildRequires: libjpeg-devel
 BuildRequires: libpng-devel
 BuildRequires: libstdc++-devel
@@ -35,11 +35,12 @@ BuildRequires:      libtiff-devel
 BuildRequires: libtool
 BuildRequires: libvorbis-devel
 BuildRequires: openssl-devel >= 0.9.7d
-BuildRequires: python-devel >= 1:2.3
+BuildRequires: python3-devel
+BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.385
-BuildRequires: scons
 BuildRequires: sed >= 4.0
 #BuildRequires:        smpeg-devel
+BuildRequires: xorg-lib-libXi-devel
 BuildRequires: zlib-devel
 Requires(post,postun): desktop-file-utils
 Requires:      OpenGL
@@ -47,7 +48,7 @@ Requires:     freetype
 Requires:      python-modules
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define        _noautoreqdep   libGL.so.1 libGLU.so.1
+%define                _noautoreqdep   libGL.so.1 libGLU.so.1
 
 %description
 Blender is a free and fully functional 3D modeling, rendering,
@@ -61,68 +62,53 @@ Blender to darmowy i w pełni funkcjonalny pakiet do tworzenia animacji
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
-%patch2 -p0
-
-rm -f missing
-rm -f user-config.py
-rm -rf bin/.blender/locale
-
-RPMCFLAGS="\"`echo %{rpmcflags}|sed 's/ /\",\"/g'`\""
-RPMLDFLAGS="\"`echo %{rpmldflags}|sed 's/ /\",\"/g'`\""
-
-cat > user-config.py <<END
-CCFLAGS           = [$RPMCFLAGS, "-funsigned-char", "-fPIC"]
-CXXFLAGS          = [$RPMCFLAGS, "-funsigned-char", "-fPIC"]
-LDFLAGS           = [$RPMLDFLAGS]
-TARGET_CC         = '%{__cc}'
-TARGET_CXX        = '%{__cxx}'
-
-BF_PYTHON_VERSION = '%{py_ver}'
-
-BF_FFMPEG         = '/usr'
-BF_FFMPEG_INC     = '%{_includedir}/ffmpeg'
-BF_FFMPEG_LIBPATH = '%{_libdir}'
-BF_FFMPEG_LIB     = 'avformat avcodec swscale avutil'
-
-LCGDIR            = 'lib/linux2'
-BF_BUILDDIR       = 'build/linux2'
-BF_INSTALLDIR     = 'install/linux2'
-END
 
 %build
-%scons BF_OPENGL_LIBPATH=%{_x_libraries}
-%{__make} -C po OCGDIR=..
-
-install -d release/plugins/include
-install source/blender/blenpluginapi/*.h release/plugins/include
-chmod +x release/plugins/bmake
-%{__make} -C release/plugins/
+install -d build
+cd build
+%cmake \
+       -DCMAKE_SKIP_RPATH=ON \
+       -DBUILD_SHARED_LIBS=OFF \
+       -DWITH_FFTW3:BOOL=ON \
+       -DWITH_JACK:BOOL=ON \
+       -DWITH_CODEC_SNDFILE:BOOL=ON \
+       -DWITH_IMAGE_OPENJPEG:BOOL=ON \
+       -DWITH_OPENCOLLADA:BOOL=ON \
+       -DWITH_CYCLES:BOOL=ON \
+       -DWITH_FFTW3:BOOL=ON \
+       -DWITH_MOD_OCEANSIM:BOOL=ON \
+       -DOPENCOLLADA=%{_includedir} \
+       -DWITH_PYTHON:BOOL=ON \
+       -DPYTHON_VERSION:STRING=%{py3_ver} \
+       -DWITH_PYTHON_INSTALL:BOOL=OFF \
+       -DWITH_CODEC_FFMPEG:BOOL=ON \
+       -DWITH_GAMEENGINE:BOOL=ON \
+       -DWITH_CXX_GUARDEDALLOC:BOOL=OFF \
+       -DWITH_BUILTIN_GLEW=OFF \
+       -DWITH_INSTALL_PORTABLE=OFF \
+       -DWITH_PYTHON_SAFETY=ON \
+       -DWITH_PLAYER=ON \
+       -DWITH_MEM_JEMALLOC=ON \
+       -DBOOST_ROOT=%{_prefix} \
+       -DWITH_INPUT_NDOF=ON \
+       -DWITH_SDL:BOOL=ON \
+       ..
+
+%{__make} V=1
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_datadir},%{_desktopdir},%{_pixmapsdir},%{_bindir}} \
-       $RPM_BUILD_ROOT%{_datadir}/blender/bpydata
 
-install ./install/linux2/blender $RPM_BUILD_ROOT%{_bindir}/blender-bin
-install %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/blender
-#install blenderplayer $RPM_BUILD_ROOT%{_bindir}
-install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
-install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
-install -d $RPM_BUILD_ROOT%{_libdir}/blender/plugins/sequence
-install -d $RPM_BUILD_ROOT%{_libdir}/blender/plugins/texture
-install ./release/plugins/sequence/*.so $RPM_BUILD_ROOT%{_libdir}/blender/plugins/sequence
-install ./release/plugins/texture/*.so $RPM_BUILD_ROOT%{_libdir}/blender/plugins/texture
-install -d $RPM_BUILD_ROOT%{_datadir}/blender
-cp -aR ./release/scripts $RPM_BUILD_ROOT%{_datadir}/blender
-install ./release/VERSION $RPM_BUILD_ROOT%{_datadir}/blender
-install ./bin/.blender/.Blanguages $RPM_BUILD_ROOT%{_datadir}/blender
-install ./bin/.blender/.bfont.ttf $RPM_BUILD_ROOT%{_datadir}/blender
-cp -a bin/.blender/locale $RPM_BUILD_ROOT%{_datadir}
-install -d $RPM_BUILD_ROOT%{_mandir}/man1
-install %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/man1/blender.1
+install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_mandir}/man1}
+
+%{__make} -C build install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
+cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/blender.1
 
-%find_lang %{name}
+#%find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -133,13 +119,16 @@ rm -rf $RPM_BUILD_ROOT
 %postun
 %update_desktop_database_postun
 
-%files -f %{name}.lang
+%files
 %defattr(644,root,root,755)
-%doc README doc/bf-members.txt doc/python-dev-guide.txt doc/oldbugs.txt doc/interface_API.txt
-%doc release/text/{blender.html,release*.txt}
-%attr(755,root,root) %{_bindir}/*
+# -f %{name}.lang
+%doc doc/license/bf-members.txt doc/guides/*.txt
+%attr(755,root,root) %{_bindir}/blender
+%attr(755,root,root) %{_bindir}/blender-thumbnailer.py
+%attr(755,root,root) %{_bindir}/blenderplayer
 %attr(755,root,root) %{_datadir}/%{name}
-%attr(755,root,root) %{_libdir}/%{name}
 %{_desktopdir}/*.desktop
 %{_pixmapsdir}/*.png
+%{_iconsdir}/*/*x*/apps/blender.png
+%{_iconsdir}/*/scalable/apps/blender.svg
 %{_mandir}/man1/*
This page took 0.030719 seconds and 4 git commands to generate.